zbigb69

Impossible To Delete A !sync File, It Reappears

Recommended Posts

Hello,

i've deleted a file. Then, a !sync file appears on all machines, and impossible to sync this files, and i can't delete this file, it reappears all the time !

 

I turned of sync on all machines (3), delete this files, the restarts all computers, and still here !

 

 

i have lots of messages like this in the log file :

[2014-04-25 08:06:01] Torrent \\?\E:\...\myfile.ext status:137 error:<NULL> meta:1 conns:1 io:0

How can i fix it ?

 

on pc, btsync 1.3.94

on mac, btsync 1.3.93

Share this post


Link to post
Share on other sites

@zbibgb69

!sync file is a temporary BTSync file which contains the data transferred from other peers. You don't need to manage them manually, sync will do that for you. The log line you display actually normal line and indicates there is no error.

Could you please elaborate if there is any functional issues that you suffer?

Share this post


Link to post
Share on other sites

well, i know that !sync files are temporary btsync files, but it stays for days...

btsync never remove this file in particular, so i tried to remove this manually, it was impossible.

 

Finally, i remove the folder on all computers, then delete the file, and create a new sync folder and now its ok

Share this post


Link to post
Share on other sites

I am having the same problem. The file in question has been deleted but the !sync file remains in the folder. I have tried deleting it but it always re-appears. This is the only file in my sync folder now and the Bit Torrent Sync icon is swirling like it is working. It is listed under "transfers" but says 0 kbps up & 0 kbps down. Status shows that the file in question is currently transferring.

 

Is there a fix for this?

 

Both PCs are Windows 7 and running version 1.3.105

Edited by Michael Poss

Share this post


Link to post
Share on other sites

Micheal,

  Have you tried exiting Sync on all the devices you're syncing with, locating and delete .!sync files on all your devices, then restart Sync on all of your devices?

 

  This usually resolves issues with stray .!sync files

Share this post


Link to post
Share on other sites

Micheal,

  Have you tried exiting Sync on all the devices you're syncing with, locating and delete .!sync files on all your devices, then restart Sync on all of your devices?

 

  This usually resolves issues with stray .!sync files

 

I exited all Sync and deleted the file in each. I started it back up on my "home pc" and everything seemed normal. I started it back up on my "work pc" and after a few seconds the file reappeared and started "syncing".

Under History I now get a message that says:

"Failed to download *******filename***** - Files missing from job. Please recheck."

It repeats this message every few seconds.

 

I guess I could do the same thing but delete and recreate the folders on each pc.

Share this post


Link to post
Share on other sites

@Michael Poss

 

That sounds unusual. Folder re-adding is very likely to resolve your issue, but not reveal us its nature. If the issue still bothering you - could you please collect debug logs from 2 peers that suffer it and send to syncapp@bittorrent.com for analysis? Please refer to this forum topic.

 

Thanks!

Share this post


Link to post
Share on other sites

Kind of the same problem here. I created 2 nodes: Main and Client for Read Only.

- Set it up and both working ok. 

- I delete both Main and Client folders, including .Sync files

- I setup new folder to sync (same keys)

 

Everything start syncing, but suddenly I see old folder re-appearing with all .!sync files and with the log showing:

 

[20140616 14:22:02.319] Blocked downloading file oldfoder/file due Connection closed
[20140616 14:22:02.319] Blocked downloading file oldfoder/other_file due Connection closed
[20140616 14:22:02.319] Blocked downloading file oldfoder/another_file due Connection closed
[20140616 14:22:03.118] Blocked downloading file oldfoder/and_so_on_file due Connection closed
...
 
What has to be deleted to have it as a brand new sync?
 
So far I have :
.SyncArchice, .SyncIgnore, .SyncID - from all nodes
.Sync folder from all nodes (contains file.db  settings.dat  sync.dat  sync.dat.old  sync.log  sync.pid)
 
Anything else?

Share this post


Link to post
Share on other sites

@gmosquera

 

You can find and clean up all files in %appdata%\BitTorrent Sync, it does not store information in any other folders.

 

The log entries you shown ("Connection closed") just indicate that issue covers on another peer, so to find the root cause you need to see what is happening in the log at the same time on another peer. I suggest contacting our support with pair of logs from your peer, so we can help you with log analysis.

Share this post


Link to post
Share on other sites

Both systems are Ubuntu servers. There is no  other peer connected to it, and just the log from Main system shows this error. The other node does not show any information about this !sync files. 

 

So my guess is that the Main system creates the !sync files back (I don't know where it's getting the info to recreate it) and the Client system is just trying to sync it.

 

If I delete those files looks like they don;t show up again, but I was just wondering why should they reappear.

Share this post


Link to post
Share on other sites

@gmosquera

 

BTSync does not sync !sync files for sure as they are treated as service files (like .syncid, .syncignore, etc). These files appear when BTSync transfers files from other peers. Once transfer complete, it moves old file to .SyncArchive and renames !sync file instead of moved one. So it is a temp cache for incoming files. I suggest that some files can't be transferred completely, that's why you get !sync files stuck in your system.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.