user318

Btsync Runs, But Did Not Work

Recommended Posts

Hello. I have problem with btsync. I have tested it last time today with Linux x64 1.3.94 version.

It is starts, reports no error, but do not do any work, do not write anything into log. Also, it exits only on second Ctrl-C or SIGTERM. I turned on debug:

~ $ cat ~/.btsync/debug.txtFFFF

But the log file still do not appear. If I start it in foreground mode, I see this:

~/.btsync $ /opt/btsync/btsync --config /etc/btsync/config --nodaemon --log sync.logBy using this application, you agree to our Privacy Policy and Terms.http://www.bittorrent.com/legal/privacyhttp://www.bittorrent.com/legal/terms-of-usetotal physical memory 536870912 max disk cache 2097152Using IP address XXX.XXX.XXX.XXXtest sha1: AE5BD8EFEA5322C4D9986D06680A781392F9A642test sha2: 630DCD2966C4336691125448BBB25B4FF412A49C732DB2C8ABC1B8581BD710DDtest aes: 0A940BB5416EF045F1C39458C653EA5A07FEEF74E1D5036E900EEE118E949293^C^C

It does nothing after "test aes: ...". If I run strace on the process, which stuck in that way I see this:

~ $ strace -p 28735 -ffProcess 28735 attachedrestart_syscall(<... resuming interrupted call ...>) = -1 ETIMEDOUT (Connection timed out)futex(0x4501920, FUTEX_WAKE_PRIVATE, 1) = 0futex(0x450194c, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 5, {1398668412, 247165000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)futex(0x4501920, FUTEX_WAKE_PRIVATE, 1) = 0futex(0x450194c, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 7, {1398668472, 247366000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)futex(0x4501920, FUTEX_WAKE_PRIVATE, 1) = 0futex(0x450194c, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 9, {1398668532, 247562000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)futex(0x4501920, FUTEX_WAKE_PRIVATE, 1) = 0futex(0x450194c, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 11, {1398668592, 247750000}, ffffffff) = ? ERESTART_RESTARTBLOCK (Interrupted by signal)--- SIGINT {si_signo=SIGINT, si_code=SI_KERNEL, si_value={int=943012408, ptr=0x4b534d2038353a38}} ---rt_sigaction(SIGINT, {SIG_DFL, [], SA_RESTORER, 0x724b0ce15b10}, NULL, 8) = 0rt_sigreturn()                          = -1 EINTR (Interrupted system call)futex(0x450194c, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 11, {1398668592, 247750000}, ffffffff) = ? ERESTART_RESTARTBLOCK (Interrupted by signal)--- SIGINT {si_signo=SIGINT, si_code=SI_KERNEL, si_value={int=943012408, ptr=0x4b534d2038353a38}} ---+++ killed by SIGINT +++

Config file have nothing special:

{  "device_name": "user",  "listening_port" : 14444,  "storage_path" : "/home/user/.btsync",  "pid_file" : "/home/user/.btsync/btsync.pid",  "check_for_updates" : false,  "use_upnp" : false,  "download_limit" : 10240,                         "upload_limit" : 10240,  "webui" :  {    "listen" : "127.0.0.1:8888",    "login" : "admin",    "password" : "password"  }  ,  "shared_folders" :  [    {      "secret" : SECRET,      "dir" : "/home/user/sync",      "use_relay_server" : true,      "use_tracker" : true,      "use_dht" : true,      "search_lan" : false,      "use_sync_trash" : true,      "known_hosts" :      [      ]    }  ]}

Share this post


Link to post
Share on other sites

Here is run of:

strace -ftt /opt/btsync/btsync --config /etc/btsync/config --nodaemon --log sync.log

http://pastebin.com/LBWcnm84

I stopped it by sending SIGINT twice. If I do "telnet localhost 14444" after the run - there is no any change in the strace log.

 

PS. Also I have notice, that I have IP XXX.XXX.XXX.106 and btsync for some reason sends couple of UDP packets to XXX.XXX.XXX.97, which is the first allowed host IP in my subnetwork (mask /27):

tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes22:43:23.751360 IP (tos 0x0, ttl 64, id 27890, offset 0, flags [DF], proto UDP (17), length 40)    XXX.XXX.XXX.106.5351 > XXX.XXX.XXX.97.5351: [udp sum ok] UDP, length 1222:43:23.751435 IP (tos 0x0, ttl 64, id 27891, offset 0, flags [DF], proto UDP (17), length 40)    XXX.XXX.XXX.106.5351 > XXX.XXX.XXX.97.5351: [udp sum ok] UDP, length 12^C

Share this post


Link to post
Share on other sites

Thank you.

 

> 1. You can disable NAT PMP and UPNP  via advanced options.

UPNP is disabled, but I don't know option name for NAT PMP. Google and User Guide did not helped.

Share this post


Link to post
Share on other sites

How specific should they be? To report not any error. I am using gentoo system, it have glibc version 2.17 with enabled hardened patches:

sys-libs/glibc-2.17:2.2  USE="hardened (multilib) -debug -gd -nscd -profile (-selinux) -suid -systemtap -vanilla"
 

Share this post


Link to post
Share on other sites

I've installed Sync and configured the folders.  After indexing, the file counts don't match and it doesn't seem to be syncing.  Is there a way to force the sync?  Why would the file count vary?

Share this post


Link to post
Share on other sites

> Did you test on another linux dists, or you use only Gentoo?

Not yet. I want to run btsync on this particular host. So I think there will be small benefit from testing it on other system. Only in case I doing something terribly wrong. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.