Btsync Not Syncing Anything


Recommended Posts



I was using btsync without issues since I installed it 2 months ago, then a few days ago, it stoped to work as spected. No files are syncing in any configured folder.


I must say that Iḿ using tuxpoldo deb package in Ubuntu 12.0.4 LTS, I upgrade few times the pagages using the repo, I don know if the issue is due an upgrade.


@work: there is an always on server with some shared folders, then there are a few workstations with those shared folders configured, all synced realtime because all devices are in the same network, but in different VLANs.


@home: One worstation syncing the same shared folders from work.


So, I don't know what is happening with the syncing, I'm using btsync version 1.3.93 recently upgraded using apt. I do restart the service but the log file doesn't show any thing more that stop start events, no incomming conections or file transfers.


BTW: Connected devices just gone from the Web UI, no more devices are showed.


Thanks in advance for any help, regards.

Edited by omata
Link to comment
Share on other sites



The only way that btsync works in my network is configuring a fixed server and port at every shared folder; in that way it syncs the files. I think that something was changed in the protocol and discovering servers within a network, (VLAN environment), are broken or just doesn work as before any more.


I need to test this issue more, because I can't see that this, always online server, is syncing with external clients.



Link to comment
Share on other sites

similar issue here, starting recently, did not notice this on 1.2.

when I turn of the NAS, and turn it on again, which automatically starts btsync,  no more devices are found.

Pause/Resume sync does not help only stop/starting of btsync on the PC reconnects these devices.


NAS is a ARM based QNAP, PC is Win 7 32bit


I will try now with fixed IP and see if this then works

Link to comment
Share on other sites



As I understand you have several peers in the office (different VLANs) and one peer at home. Can you please try to reach the file "" from your peers? It looks like your peers can't contact the tracker server - and the location of tracker server determined by the conf file I mention above.



Most likely you have a different issue. I guess that your UI states something like "Cannot sync due to time difference more than 600 seconds" - which means that you either has a wrong time on one/multiple of your peers OR you have a wrong timezone set. Please check your time and your timezone.



The devices you expect to see - are they in LAN or connected to the internet?



Indeed, 1.3 has a different mechanism of devices discovery and communications. It generates much less redundant traffic and designed to be faster.

Link to comment
Share on other sites

they are both in the local LAN.

- in my case it is sufficient to kill btsync on the NAS, wait, restart it, devices do not find each other.

- only search lan is selected, all other ticks off.


unrelated question:

can I generated a config file based on current configuration or do I have to write it from scratch, based on the sample file I can dump?





however it seems, when I add them to the predefined host list, then it works once the the rescan interval has passed once.

Link to comment
Share on other sites

I just had the same problem. I'm running btsync v1.3.94 on Ubuntu 14.04 amd64 on two machines:. laptop connected to file server via ethernet, each connected to net via WiFi. They were syncing fine, then just stopped.


I tried killling and restarted btsync on each. No connected devices shown. Rebooted both machines, sync web page worked fine on the file server, but showed no connected devices. sync web page on laptop did not show version or any Folders. Clicking "Preferences" did nothing. Killed/restarted btsync serval times, same result. Log file shows:

[20140510 02:22:56.348] Loading config file version 1.3.94
[20140510 02:23:00.369] UPnP: Could not map UPnP Port on this pass, retrying.


I noticed a btsync Folder was not mounted on my laptop. Mounted drive. Restarted btsync, worked. Drive was mounted when problem started, so that may be another problem.


This is not good. :(

Link to comment
Share on other sites

Looks like I'm having a similar problem. I have been using BTSync with an iMac, a Windows Computer and a NAS for several weeks without any problems. Since I've installed the recent update, the iMac can't find the other devices (they are not shown in the related box) and the other way round (whereas the Windows Computer and the NAS are still communicating).

What mail address should I send the log files to so you can deal with the problem? 

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.