ei96naNi

Indexing Fault On Slow Drives

Recommended Posts

Hi.
 
I have a folder with 31 files, 48 GBytes.  Some of them are videos recorded from my TV (2 or 3 GBytes) and the rest are small files.
 
When I add this folder from my PC to Bit Torrent Sync all works well.  BTS says there is 31 files and 48 GBytes.
 
But I copied this folder to a NAS, 'Lc Power LC-35NAS' (http://www.lc-power.de/index.php?id=397&L=1), without the BTS files.  Of course, it works on Ethernet.
 
When I add this new folder (with new secret) to BTS, it starts indexing, but end with only three files indexed, not with the 31.
 
The log shows something like this:
 
[2014-05-09 10:31:26] total physical memory 4294967295 max disk cache 33554432
[2014-05-09 10:31:26] Using IP address 192.168.1.15
[2014-05-09 10:31:26] Loading config file version 1.3.94
[2014-05-09 10:31:26] Loaded folder \\?\UNC\192.168.1.16\user\TV Show 1
[2014-05-09 10:31:26] Got Teredo Address: EXT
 
And when I turn off the BTS (one hour later):
[2014-05-09 11:43:34] Shutdown. Saving config sync.dat
 
I'm using Windows 8.1.

 

If I disconect the Ethernet and plug it with the USB, and then add the same folder (but now from a USB Drive), it works well.

 

Only problems with Ethernet.

 

¿Why BTS is not indexing all the files?

 

 
Thanks !!

Share this post


Link to post
Share on other sites

If I disconect the Ethernet and plug it with the USB, and then add the same folder (but now from a USB Drive), it works well.

 

Only problems with Ethernet.

 

Thanks !!

Share this post


Link to post
Share on other sites

@ei96naNi

 

As I understand, when you try to store files on the NAS over SMB protocol (so-called "network shares" starting with "\\...") - the indexing can't index all files.

 

 

I suggest trying to map your NAS as a network drive - it might help as OS processes SMB shares slightly different from other devices in OS.

Share this post


Link to post
Share on other sites

I've tried this, yet, to map a drive letter.  Same result.

 

The reading speed is limited to 25 MBytes/sec, and the files are too big (2 or 3 GBytes).

 

I don't understad why this happen.

 

Thanks !!

Share this post


Link to post
Share on other sites

@ei96naNi

 

The log is surprisingly short. Did you enable full debug output?

Also, the log gave me a hint - when you connect to your NAS over SMB - do you have write permissions to the folder?

Share this post


Link to post
Share on other sites

The log is short because I turned on only when I connected the NAS the first time.  Then I turned off.

 

The log size is set to 1000000 in the properties.  I don't know if is fully enabled, but is short.

 

The log shows since I add the folder (in the windows shows 'Indexing...') till the indexing ends. Then I wait one hour and turns off the Bit Torrent Sync app.

 

Yes, I have write permisions to this folder.  From the same computer and user I copied files from and to the NAS.

 

Thanks a lot.

Share this post


Link to post
Share on other sites

@ei96naNi

 

Its simple to check if log turned to full output. On desktops with UI you need to right-click the Sync icon in system tray, see if "Enable debug logging" menu item is ticked.

 

On Linux-based systems check if file "debug.txt" exists in .sync subfolder near binary file (see details here).

Share this post


Link to post
Share on other sites

I think the log was not enabled, but something was writtent to it.

 

I'm going to test using two computers.  One of them it's going to be a "NAS".  I also connect it with UTP-5 cable to slow down the bit rate transfer.

 

I'll send the log when I have it tested.

 

Thanks.

Share this post


Link to post
Share on other sites

I'm sorry, but I have not this error.  Now it indexes well.

 

It's crazy.

 

:-(

 

I made some tests with other folder (for not delete the files) and the log shows this:

[2014-05-15 15:51:48] SyncFolderScanner: GetFileList failed for folder \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\.SyncArchive - error -1[2014-05-15 15:51:48] SyncTrashFolder: Sync trash scan for folder "\\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\.SyncArchive" started, max file age = 1 days[2014-05-15 15:51:48] SyncTrashFolder: GetFileList failed for folder \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\.SyncArchive - error -1[2014-05-15 15:51:49] SyncFilesController: started periodic scan[2014-05-15 15:51:49] SyncFilesController [file updated]: Processing file \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\TV_4.avi 1398672528 2326084564[2014-05-15 15:51:49] SyncFilesController [file updated]: Processing file \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\TV_3.vrp 1398672370 338662[2014-05-15 15:51:49] SyncFilesController [file updated]: Processing file \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\TV_2.ts 1395232848 2897690812[2014-05-15 15:51:49] SyncFilesController [file updated]: Processing file \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\TV_1.ts 1394795666 1921077248[2014-05-15 15:51:49] SyncFolderScanner: GetFileList failed for folder \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\.SyncArchive - error -1[2014-05-15 15:51:49] SyncTrashFolder: Sync trash scan for folder "\\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\.SyncArchive" started, max file age = 1 days[2014-05-15 15:51:49] SyncTrashFolder: GetFileList failed for folder \\?\UNC\Nas-j4ht512\user1\TVaaaaaaaaaaaaaaaaaaaaaaaaaaaa\.SyncArchive - error -1[2014-05-15 15:52:09] SyncFilesController: started periodic scan

I'll send to you the full log by mail.

 

I hope this could help.

 

Thanks a lot.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.