RomanZ

Latest Desktop Build 1.3.105

Recommended Posts

@JimmyTheSaint, @merlinuwe, @sandymac, @nils

 

Thanks a lot for the feedback regarding new UI. I'm checking what can be adjusted in new versions.

 

I very much prefer the new WebUI. It's great! 

I don't need to - nor do I want to - see a mile long page of peers.

 

One small bug at first glance: Encrypted secrets don't show up in the input box like read-only secrets.

 

And a question: At first, it only showed the basename of the paths, now it shows full paths.

Why? Can it be configured?

Share this post


Link to post
Share on other sites

I very much prefer the new WebUI. It's great! 

I don't need to - nor do I want to - see a mile long page of peers.

Two kinds of users, obviously: those whose peers can all show their sync folders on one web page, and those who overflow. In my case, with 4 sync folders and 6 peers, the present webui consolidates way too much and I have a mile long of blank space.

Share this post


Link to post
Share on other sites

Two kinds of users, obviously: those whose peers can all show their sync folders on one web page, and those who overflow. In my case, with 4 sync folders and 6 peers, the present webui consolidates way too much and I have a mile long of blank space.

 

Then it will be nice to have switch option to turn on/off peers details :)

Share this post


Link to post
Share on other sites

Hello,

 

I´ve installed btsync again just a couple of days ago.. After my nasty "filesgetoverwrittenbyoldversion"-bug i tried some alternatives.. but let me say you guys have made definitly the best concept, there´s no way around!

 

the overwrite bug seems to be gone, but now there´s another problem.. i´ve deleted all btsync-related files from my share on the server, added it to a new key and tried to sync that to the clients. But only half of the directory gets synced, i´m missing about 12gb of data!

I´ve updated the server now to this newest build, rebooted a few times.. But it just dont index the rest. Can´t figure out why, it randomly leaves out some of the root folders with all its content.

File system is german, maby there are some problem with special chars in the filenames? But that problem is definitly new, the older 1.2.* versions synced without problems!

 

//funny things happen, i´ve created a new file in one of the non-syncing folder, this file gets synced! But just this one, rest is still not on my disk

 

Another thing what would be nice are public http share-links like in Dropbox..

You have a http server and full access to the storange, i think it wouldn´t be too hard to generate some temporary paths for sharing links with non-btsync-users?

 

 

best regards,

Andi

Share this post


Link to post
Share on other sites
Guest proactiveservices

I know that BTSync will not function on root directories on Windows systems, as it ungracefully fails when hitting a file it cannot access, which is a rather glaring bug. I assume this is a possibility on other file systems and operating systems. I've also seen it when a filesystem is broken, or say a file has security permissions such that BTSync can't access them, or other invalid metadata. It might be worth checking your data/file system is OK. If that checks out, talk to BTSync's log and maybe with debugging enabled, to see if it sheds a light.

Share this post


Link to post
Share on other sites

All,

 

Thanks for the feedback.

 

@Lightning

Thanks for the bug report - we'll fix it. Not sure what do you mean regarding the path - both in 1.3.94 and 1.3.105 it shows full path including the dir name. Could you please elaborate / show a screenshots?

 

@b0rman

Well, its a good point to be mentioned in Feature Requests forum.

 

@andi

Your issue does not look like to be bound to 1.3.105 release as it had only WebUI changed as well as couple of crashes fixed. I suggest collecting full debug logs with log size limitation of ~200Mb and sending them to me for analysis to syncapp@bittorrent.com.

Share this post


Link to post
Share on other sites

found the problem..

 

http://forum.bittorrent.com/topic/12658-if-you-have-syncapp-issue :

"Linux: create file debug.txt with contents of FFFF in the .sync folder. You can find the .sync folder in the same directory where the btsync binary is located."

i think thats wrong? have to add following line in config for new version?

//DEBUG_DAEMON=FFFF in config brings a debug.txt in /var/lib/btsync, but it only contains FFFF

 

/usr/lib/btsync/btsync-daemon --nodaemon --config /etc/btsync/debconf-default.conf gave me some informations:

Warning: config option 'lan_use_tcp' is deprecated //but it´s configed by debconf!
total physical memory -1 max disk cache 2097152 //i know a raspberry pi has less memory, but thats wrong..

 

[20140603 08:44:57.055] SyncFolderScanner: Removing notifier "/mnt/data/Bilder"
[20140603 08:44:57.056] Removing folder /mnt/data/Bilder from inotify
 

and then a list of hundred files come up wich gets removed. But i think thats not the point, some files exists wich are removed before..

 

but thats also not the debug.txt. i now watch the sync.log, it grows permanently, think the debug output is now there?

 

this file show the problem

LoadTorrent: file /mnt/data/Bilder/.recycle/38C993E0.tmp exists, but failed to get mtime 13

that fails for all files in the samba recycle folder, and this folder (also)contains the old synctrash folder.

 

now i just removed that recycle folder and the daemon starts to index the rest of the files, i´m now at 14gb and rising!  :wub:

 

log files give now this message repeated:

 09:30:20.783] SyncFilesController: Skipping load torrent for file "/mnt/data/Bilder/.recycle/1C8C7433.tmp" - fui: 1, fse: 1

 

i bet these mtime-error files are blocking the "file-search-threads", they just cant skip bad files so they stop working and can´t index the rest!

Share this post


Link to post
Share on other sites

@stalk

 

I guess you have a data which can be well compressed, right? BTSync does not compress data on the fly. It just splits data to blocks, hashes it encrypts and transmits.


@andi

 

The instructions link you mentioned is correct. You need to make a debug.txt file in BTSync storage containing "FFFF" and that will force BTSync for full debug output into sync.log. I checked this functionality for 1.3.105 on Linux Mint - it works just fine.

 

As for the "Failed to get mtime" - this usually indicates permissions issue. BTSync could not access these files. It should not block indexing the rest of files / folders though.

 

What do you see at the end of day? Some of files / folders are not indexed or some other symptoms?

Share this post


Link to post
Share on other sites

@stalk, the suggestion/desirability for Sync to "compress" traffic is being discussed over in this thread in the Feature Requests forum.

 

You may like to consider adding your voice to that thread instead, as such functionality isn't present in 1.3.105, and so is off-topic to the main discussion of this thread.

Share this post


Link to post
Share on other sites

Sure. Here: https://i.imgur.com/3o3bnhG.jpg

... and after a service restart: https://i.imgur.com/y7qTLoq.jpg

 

I'm seeing the same thing with the folder names. Sometimes I see just the folder name, sometimes I see the full path. I have 6 Raspberry Pis running Raspbian/BTSync-1.3.105 and they all have the same problem. Sometimes I get just the folder name when I access the web interface for the first time in a while and hen I refresh my browser I usually get the full path. It's not consistent.

Share this post


Link to post
Share on other sites

Please provide Android apk too.

Google Play gives me an error 403 when I try to download it, been so for a few days now. I can download other apps from Google Play.

Just got myself a new Dlink-DNS320B, crossing my fingers that BTSync will run :)

Have a nice weekend!

Share this post


Link to post
Share on other sites

Thanks. I managed to find the APK on a Chinese website, but not sure if that was a smart move.

bittorrent_sync_1.3.21.0.apk

size 3153512bytes

size on disk 3153920bytes

Share this post


Link to post
Share on other sites
Thanks, it is a match.

 

"Cannot identify the destination folder"

I get that on my android when I try to add a pictures folder that belongs to an app. 

 

I also had an error adding the external sdcard DCIM on a samsung s4 running  kitkat4.4.2, no permission.

Share this post


Link to post
Share on other sites

 

"Cannot identify the destination folder"
I get that on my android when I try to add a pictures folder that belongs to an app. 
 
I also had an error adding the external sdcard DCIM on a samsung s4 running  kitkat4.4.2, no permission.

 

On the unofficial troubleshooting FAQ at http://forum.bittorrent.com/topic/28637-bittorrent-sync-troubleshooting-faq-unofficial/, look under the heading "Android-specific Troubleshooting."

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.