Recommended Posts

Hi,

 

I've been using btsync for months, with no problems.  This is an awesome program, and I thank the developers very much for making my life easier.

 

My main system is a laptop, 64 bit Intel, running Linux Mint 64 bit KDE,

Linux uber 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

 

I've had btsync installed via the PPA at tuxpoldo/btsync

 

Everything has been working fine, without a hitch.  This program makes me smile all the time :-)

 

Today I had an upgrade notice in my upgrade manager, for btsync-common.  I clicked "ok", and the regular update procedure ensued.

 

As usual for updates of btsync, the icon on my panel disappeared.  After an update, btsync usually needs to be restarted, which I did from the console.  My usual command to do this is:

 

btsync start

or

btsync restart

 

This time it did not run, and did not return any messages to the console.  Closer examination revealed that btsync-user was no longer installed.  When I tried to install it with apt-get, I got the message:

 

The following packages have unmet dependencies:
 btsync-user : Depends: btsync-common but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 

I tried "apt-get -f update" and got the same result.  I uninstalled all btsync packages and tried to re-install, but got this message:

 

The following packages have unmet dependencies:
 btsync-common : Breaks: btsync-user (<= 1.15.0-1) but 1.15.0-1 is to be installed
 btsync-gui-gtk : Breaks: btsync-user but 1.15.0-1 is to be installed
E: Unable to correct problems, you have held broken packages.

 

It seems the update is broken.  If I can provide any further information to help with resolution, please let me know.

 

If you think the problem might be on my end (although I doubt this is the case), I will VERY much appreciate any tips to help me get this going again.  Otherwise, I'll just wait for the next update.

 

Thanks.

 

Share this post


Link to post
Share on other sites

I'm having the same issue, although mine is not a reinstall, it's a fresh install on a fresh install of KUbuntu 14.04 LTS.  (I used the same install procedure as I did on my XUbuntu and Ubuntu installations earlier without any problems.

Edited by Issachar

Share this post


Link to post
Share on other sites

The following packages have unmet dependencies:

 btsync-common : Breaks: btsync-user (<= 1.15.0-1) but 1.15.0-1 is to be installed

 btsync-gui-gtk : Breaks: btsync-user but 1.15.0-1 is to be installed

E: Unable to correct problems, you have held broken packages.

 

It seems the update is broken.  If I can provide any further information to help with resolution, please let me know.

 

Please see this post and this post.

Share this post


Link to post
Share on other sites

Thanks GreatMarko.

 

It's beta software, so I tend to assume these kinds of glitches will happen.  I'll wait for a fix which hopefully won't take too long.

 

That said, I'm not a Linux guru by far and I'm gradually migrating from the Windows world and I've got a question about how this works in Linux, (specifically KUbuntu 14.04), if someone will endulge a question that probably has more to do with the operating system than with BTSync.

 

I use BTSync for work and personal.  I'd prefer to test new versions on my personal stuff.  But if I added the tuxpoldo/btsync repository and installed BTSync from there, does this mean every update will be automatically applied when the OS tells me that updates are available?

 

 

Sorry, I realize that it's a faux pas to stray from the topic, but I hope you'll endulge me.  Windows obviously doesn't have anything like that, but it's the kind of value added feature that I could see being part of Linux.  It could just have some unintended consequences for me since I don't really know what I'm doing.

Share this post


Link to post
Share on other sites

Hi Folks!

 

Unfortunately some GUI package manager frontends do a dist-upgrade without asking. But there are good news: Mark Johnson has fixed the problem and I will release a new package in the next few hours.

 

Cheers!


And here it is:
 
btsync-user (1.16.0-1) unstable; urgency=low  * New upstream release 0.16 on btsyncindicator    - Made compatible with new Web UI of BitTorrent Sync      version 1.3.105 (Closes #btsyncindicator/50) -- Leo Moll <leo.moll@yeasoft.com>  Mon, 02 Jun 2014 23:59:52 +0100

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.