crazydip

Btsync Crashes On Startup With Encrypted Ro

Recommended Posts

BTSync 1.3.105 crashes on startup on Linux x86_64 (Debian stable server).

 

Crash happens when BTSync detects that a file update has been detected in an encrypted RO share. Currently this happens within a second of starting btsync.

 

Here is the terminal output using --nodaemon:

SyncFilesController: started periodic scanSyncFilesController [file updated]: Processing file <PATH_TO_HASHED_FILE> 1401206360 603SyncFilesController: Detected updated file "<HASHED_FILE>" (R/O). Checking filehashassert failed ./SyncFilesControllerRO.cpp:365 (16973929)SyncFolderNotify: ".SyncID", event = "IN_CLOSE_WRITE"[OnNotifyFileChange] <PATH_TO_SHARE>/.SyncID, source = NULLAborted

Here is the debug log output:

[20140530 14:23:12.809] SyncFilesController: Detected updated file "<HASHED_FILE>" (R/O). Checking filehash[20140530 14:23:12.810] SyncFolderNotify: ".SyncID", event = "IN_CLOSE_WRITE"[20140530 14:23:12.810] [OnNotifyFileChange] <PATH_TO_FOLDER>/.SyncID, source = NULL

I have replaced sensitive information above with <EXPLANATION_TEXT>.

 

To isolate the problem, the only other machine that has access to the secret (encrypted RW), which means it has BTSync running, is also a Linux x86_64 machine. BTSync is the same version. BTSync does not crash on this machine which has the encrypted RW version of the same secret.

 

I have tried to delete everything in .sync folder as well as all .SyncID files. Everything is setup via config file, webgui is disabled. This setup has worked for months using previous versions of BTSync.

 

The crash began after updating to 1.3.105, but now going back to previous version does not help. Although I have not tested by deleting all .SyncID files and .sync folder contents prior to going back to an older version.

Share this post


Link to post
Share on other sites
I'm having the same problem with 1.4.75 on Debian Wheezy (32 Bit).
Linux debian 3.2.0-4-686-pae #1 SMP Debian 3.2.60-1+deb7u3 i686 GNU/Linux
I set up an encrypted readonly share and everything was syncing fine, but now after restarting btsync it crashes.
 
Log file entries before the crash:
 
(...)[20140918 15:40:14.138] SyncFolderScanner: Adding notifier "/btsync/someshare"[20140918 15:40:14.138] Added path=/btsync/someshare with fd=824[20140918 15:40:14.157] Added path=/btsync/someshare/GBB32F1N3Z6T74354FDD5SN67M6OIEE8I6756UI with fd=825[20140918 15:40:14.191] Added path=/btsync/someshare/Y5Y3W4RN5RTC6U42SF362TSGC4H657F6Y8FM8IA with fd=826(lots of similar entries...)[20140918 15:40:15.475] Added path=/btsync/someshare/Y5Y3W4RN5RTC6U42SF362TSGC4H657F6Y8FM8IA/KGFZEIWT2JTC4B4J3D43I25JTQ/TZXF5WBU23V5Y3QP3X45RAV3GA/DDEPFI345GLN34G5I634VLCSC4/P6VE44YM34W5SI4E53N4544VEE/354G5M3L4P533245TAQ4F2LON4/7ODIXUFA435LBCZPOTA53345IE with fd=1356[20140918 15:40:15.475] SF[CD04]: Loaded folder /btsync/someshare[20140918 15:40:15.475] SF[CD04]: start reading '/var/lib/btsync//0B2111111113AD757DEF73CA924511111111CD04.availability'[20140918 15:40:15.475] SF[CD04]: failed to read '/var/lib/btsync//0B2111111113AD757DEF73CA924511111111CD04.availability'[20140918 15:40:15.554] FC[D873]: start reading DB[20140918 15:40:17.021] FC[CD04]: started periodic scan for "/btsync/someshare"[20140918 15:40:17.021] FC[CD04]: file updated - processing file /btsync/someshare/BN2UISP7VYI34534X5D34X53L45TG4545RLY2WY t:1410623693 s:4096[20140918 15:40:17.022] FC[CD04]: file updated - processing file /btsync/someshare/BN2UISP7VYI34534X5D34X53L45TG4545RLY2WY/5RQVNMSEKT43L3P45424Z5L34U5Q34V52R3545O465G445F64K3Q t:1405023543 s:8314[20140918 15:40:17.022] FC[CD04] (R/O): detected updated file "BN2UISP7VYI34534X5D34X53L45TG4545RLY2WY/5RQVNMSEKT43L3P45424Z5L34U5Q34V52R3545O465G445F64K3Q". Checking filehash
 
Console output:
 
btsync@debian:/usr/lib/btsync-common# ./btsync-core  --config /etc/btsync/debconf-default.conf --log sync.log --nodaemon(...)assert failed /mnt/jenkins/workspace/Build-Sync-i386/SyncFilesControllerRO.cpp:405 (17039435)Aborted
This is a fresh install of btsync. No shares were converted from earlier versions. It doesn't matter if there is another machine running with access to the share, it always crashes. A Windows node with the same encrypted readonly share is running fine.

Just tested, the same thing happens with the glibc2.3 version:

assert failed /mnt/jenkins/workspace/Build-Sync-x86-glibc23/SyncFilesControllerRO.cpp:405 (17039442)
Edited by Ted

Share this post


Link to post
Share on other sites

I'm seeing something similar with the latest Android clients, both 1.4.45 and now 1.4.50.  I have about 7 folders on my phone shared and all sync fine to other devices using RW and encryption keys.  When I try to add the TitaniumBackup folder, it sync's fine to another RW node, but as soon as I add the encryption key node the Android client crashes.  Every time it starts, it crashes in seconds.  The problem definitely has something to do with that folder.  It worked fine with 1.3.109.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.