jbonlinea

"Don't Have Permission To Write To The Selected Folder" Issue

Recommended Posts

Dear all

I'm still new regarding btsync and synology and my skill in "network" and "shell" are limited but not null

I've recentely installed btsyns on my synology ds712+ using the syno community repo. As the repo did not had the laste version I upgradre manually btsync following the instruction on this post :

I then installed btsync on bot my mac and my pc and had a try, everything seemed to work as I feel (even if some few advanced features would be welcomed)

For a while, the bi-directional sync was working smoothly between the mac and the syno.

However now, sync do not occur anymore and in the btsyn gui of the syno it says "don't have permission to write in selected folder" and this for all the synced folders.

I check in Mac os what were the permission for the folder and it is in read and write for everyone in the gui (which should mean chmod 777)

I actually don't like it but I can live with it for few days.

So how a hell btsync can say he don't have the rights, especially when it was working perfectly the day before.

When I saw you released an update recently, I tried to do the update manually (on the synology), following the same tutorial mentionnend above, but it stays on 1.1.48 and say it's up to date.

Actually, the last non-update update solved the problem of permission I had.

However now, maybe 24-48hours after the non-update update, the problem rise again.

Any help.

I wonder things like how can i create a group of user and user for btsync and giving it the right to read and write in my sync folders

I also wonder if the problem could come from my fire wall

anyway all this is un-understandable for me as it worked the day before and no settings change were done

or if there is a trick related to the functioning of bt sync

Please help, its getting on my nerve and if I don't find a relyable and enduring solution, I'll move back to at the end of the day more finished solution, cloudstation.

But I like btsync

Thanks for your attention

Jo

Share this post


Link to post
Share on other sites

...

However now, sync do not occur anymore and in the btsyn gui of the syno it says "don't have permission to write in selected folder" and this for all the synced folders.

I check in Mac os what were the permission for the folder and it is in read and write for everyone in the gui (which should mean chmod 777)

If the syno gui was the btsync instance that said it could not write, wouldn't that mean there was a permission issue on the syno and not your mac?

Share this post


Link to post
Share on other sites

Well...

yes it is the syno gui that says it could not write

thank's for the clue, it could have been relevant but

If I add a file in a sync folder on the mac, it is not uploaded on the syno anymore (but btsync on the mac say "added")

if I add a file in a sync folder on the syno, it is not uploaded on the mac anymore neither

so... still stuck :-)

Share this post


Link to post
Share on other sites

What I am saying is it seems the syno is having a permission error.

Mac[able to add files] -> Syno[unable to download/doesnt have perms]

Syno[unable to write to folder] -> Mac[desn't get anything from the syno]

So login to the syno and chmod 777 the folder btsync is using. or make sure the user that is running btsync on the syno owns the folder you are trying to add files to. If btsync on the syno can not write to the folder it will fail.

What you have described -- to me at least -- seems to be an issue on the Syno and nothing to do with your mac.

Share this post


Link to post
Share on other sites

ok thanks for your reply again.

I think I got you at first, but avoided a long message

I have only one user on the syno, and it has admin priviledges (and it it not the admin user of the system)

I followed this tutorial for security on internet

http://www.synology....ow.php?q_id=478

sorry can't find the english version but say:

- disable admin and guest acocunt

- auto redirect http connection toward https

- use ftp via ssl

- auto block_ip if mistaken password

my syno is configured manually, no use of EZ assistant etc.

only one user of the syno use btsync, indeed

the user has read/write right over the shared folder

from the mac i could sync toward the syno 100% sure

the other way round not sure

with the same login/pass I coud read/write the shared folder through the syno web gui, FTP and a file explorer on win (connect to a network drive) and mac (afp://)

then problem start by their own, i know that's weired.

the btsync gui on the syno says "don't have permission..."

btsync on the mac say "added" or "updated" when it send a file (wich actually doens't goes)

however i can still read/write the shared folder through the syno web gui, FTP and a file explorer on win (connect to a network drive) and mac (afp://)

to try to solve the pb

- I gave read/write to the group my useb belongs from

- i activated nfs file sharing and gave permission ta the client with the IP of the syno

nothing changed

i rebooted the syno as well as btsync

no change

i logged in in ssh with the following arguments

ssh -l root IP_syno

then entered my admin password to login as root and not admin (i read this is waht should be done on syno)

I go to the volume where my shared folder is and I type

ls -l

my shared folder is said to be

drwxrwxrwx

I go back to btsync gui on the syno but no change, even after rebooting btsync

I'm stuck, hell stuck

do you have any clues ?

I don't want to start over from scratch with the syno, re-instal the dsm and copy again my damn 800Go of datas

I went for btsync becuse it seems to be the best solution, the developpers deserve encouragement, it's light and independent and etc, but the manual is really bad, first syncing has to be done with a lot of care and problem apears by magic.

This kind of everlasting problem are un-acceptable for simple advanced computer users whose work has nothing to do with netwok and security issues,n or with computers,

I don't know, maybe I'll move to owncloud or even cloud station and stop struggling over night

and come back to bt sync in a year or two

Maybe one of you have a clue...

Hope one of you can help

thanks for reading

Jo

Share this post


Link to post
Share on other sites

It could be that a file or folder inside the syno share folder is having an issue...

You could try this to look for non rwxrwx perms for directories...


find /path/to/share -type d -not -perm 777 -exec ls -alh {} \;

and this for files, not sure if this work as the find command I am use to is the newest version...


find /path/to/share -type f -not -perm 666 -exec ls -alh {} \;

These commands should show you all the files and folders that do not have the expected perms as well as show you their names it should give you owner:group and the current set of perms.

If that is found to be the issue you will need to look into acls for the folders.

Share this post


Link to post
Share on other sites

thank's for replying again

in the syno, non of the comand works as the argument -not is not recognised so I executed it on the mac local folder (that is/should be synced with the syno)

in the mac, the first comand gives no return, meaning that all the folders has the proper rights

indeed, yesterday, I made sure the folder, and all the folders on the path, where the modification took place had proper rights as well

I also applied, through tue mac gui, read/write right to all files and subfolders

the second return, thousand of lines, indeed.

my folder (and subfolder) contains thousands of file that have as many origin as there are dialec in the word

So what, should I give chmod 777 to all the files wihtin the shared folder ?

As I don't know how to do that in the console, I logged in as root on the mac, and did it through the gui, so all the files are -rwxrwxrwx

do not change nothing on btsync on the syno side, indeed as these files are on the mac, not the syno

not sure/don't think the situation is the same on the syno at large, as I applied these chmod things after the first sync

however i made sure yesterday that the folder, and folders on the path, to the file i edited was in chmod777, still the file is not updater and the newly created ones in the same folder not uploaded

on the syno, I edit the propoerties of my shared folder, not in the "shared folder" panel, but in file station. Basically I applied to all file and sub folders read/write right to everyone

->sync start and occur in both way !!!!!

good

Now I have to close this free for all. On my device, this could be the syno, the mac, or an ectra device that will come in the play, I want that only my user on the mac and my suer on the syno (and not everybody of the group my user belongs from) and the Admin/root (admin for syno et root for the mac) have read right, everybody else should have no access, but if I specify the countrary for a specific file/folder

So If I want to edit the right in the syno to give it all to my user, i can't apply it as the syno return "the changed can't be applied as the admin account "MyUser" has a total control of privileges" (translated from french)

So i create a rule and give no right to everybody, and create an another rule and give read/write right to all the user in the group my user belongs from

--> btsync return

"bit torrent can not identifie the destination folder"

so i deleted the rule saying that everyone has no right and only left the rule saying that the group my user belong from has right

-->working

ok so how do I do to make the damn syno unerstand that nobody has right over this folder but MyUser (and the surper admin indeed)

Is btsync really acting in the name of my user ?

well I stil confused what is the way forward.

one more problem: the syno is creating shared folder for its audio station, photostation, etc and i want to sync these folder as well. however the syno says "shared folders reserved fo system use can't deal with acl"

so i can't get rid of this "don't have the permissions..." in btsync using the same technique as above

any clues

Thank's again

Ps 1: anyway, acl on specific file should not affect btsync behaviour at shared folder level ? or i really don't understand anything

Share this post


Link to post
Share on other sites

I will start off with saying that you do not need to change any perms on your mac, your mac is running btsync just fine. It is solely an issue with your syno -- permissions are not synced through btsync so if you change the permissions of a file on one computer it does not change them anywhere else but that one device.

When it comes to the syno I am not exactly sure as I do not own a syno pretty much all I can tell you is you can stop messing with your mac and other device because it is solely an issue with your syno.

Maybe someone else here will be able to help you with the syno issue, but you may want to try a syno community forum.

Share this post


Link to post
Share on other sites

one more thanks for your repply

yes indeed, the issue comes from the syno side, I do agree

I have re-established the privileged I want them to be on the mac

on the syno, I modified the ACL of the shared folder

all users of the group "user" has all right over the shared folder

guest have no rights

sync works

As I understood that there are internal unix right and external ones, my question is :

Is it safe to let things like this, I mean do not create a ACL rule that say that everyone but the group "user" has no rights over the folder ?

For me it won't be a problem as I can create other syno users belonging from an another group than "user";

thus my user, being the only account of the "user" group, will be the only user of the syno to access the folder.

But what about others users, I mean mac or win users, or even users from outisde the local network ?

So now the point is to secure the folder against outsiders, not other syno users.

Do you get my point and do you know what should be done ?

I'll wait for your reply and then may do a post on syno forum, on the french syno forum, btsync is surprisingly under-documented. you really have to crowl and look for 2 was sync alternatives to find something, and it basically say, use the repo to install btsync on your syno, no mention of the need to activate ACL for the shared folder, etc.

I thin I'll do a post/tuto like "btsync instalation on a syno - an average user experience" because I still beleive btsync is one of the best 2 way sync solution.

Cheers

Jo

Share this post


Link to post
Share on other sites

My understanding is that the syno repo is not one supported or updated by the btsync people, I think it is maintained by a syno member -- I could be wrong -- but I think it would be unfair to blame the underdocumentation of the syno btsync module on the btsync people that have little to nothing to do with it.

Again I am not well read on how the syno works but in a tipical linux environment you have the normal permissions (rwxrwxrwx = 777) those work based on user:group:other. So if the syno creates a physical group when you add a group through their GUI you could use

$ chgrp groupName /path/to/share -R

$ chmod o-rwx /path/to/share

the chgrp should change the ownership of your shared folder -- and every file/folder within that folder -- to the group you want and the chmod will remove the read, write, and execute perms for others, so if you had (rwxrwxrwx = 777) it would now be (rwxrwx--- = 770). This would mean the user that owns the folder and the group that owns the folder would have full access to that folder.

Another method would be to use ACLs, which I am not sure if your syno would support.

$ setfacl group:newGroup:rwx /path/to/share

$ setfacl -d group:newGroup:rwx /path/to/share

Share this post


Link to post
Share on other sites

Hello agian.

I was busy and couldn't go through it this we.

I'll do it this week

I have an extra question

on mac os x, which user is btsync ?

I mean on the behaf of what user is it acting ?

Of which group btsync belongs ?

Is btsync user natively of the same group that the "curent" user on the mac (i mean the user logged in) ?

thank's

and I'll come back soon to your previous post

helps a lot

very grateful

Share this post


Link to post
Share on other sites

well I'm not sure it does.

when you create a new folder, the defaul setting on mac is that this folder is only in read/write for the current user, even if this folder is within a folder with broader read/write rights.

And my observation si that btsync can't sync in this newly created folder unless you change the read/write rights.

It is quite an issue on a day to day use perspective...

any tricks ?

(again not ye ttime to go thhrough the whole of your previous answer but soon)

Share this post


Link to post
Share on other sites

It should run as the current user, but you could do a test my making a new folder and chmod 777 it, then add it to btsync and let btsync add some files from another device. Then you go into the folder through a terminal and type ls -alh .

This will show you the information on all the files/folders, username and groups of all the files.

Share this post


Link to post
Share on other sites

well it does in the activity monitor at least

but, if i create a new folder (anywhere on my harddrive) on the mac and copy paste it in a btsync folder, the upload toward the syno will occur

however if i edit my file on my pc, or move file on the syno, or whatsoever, btsync will do the sync, theoretically, but practically it does not have the right on this folder so nothing happen on the mac

As the curent user on the mac has read/write right over this folder, the only explanation I see it that btsync is not, or at least not only running as the curent user, otherwise the sync would really occur

no ?

I missed something ?

Share this post


Link to post
Share on other sites

This may come a bit late for you, but I got that exact same error when everything but .SyncID was writeable by the btsync user on a Synology box. I couldn't find any log file that specified what file was wrong - will file a bug accordingly.

Share this post


Link to post
Share on other sites

You could try this to look for non rwxrwx perms for directories...

find /path/to/share -type d -not -perm 777 -exec ls -alh {} \;
...

Setting 777 mode means the file becomes writable by the WORLD. Not a good idea.

Use 775 instead, or, better yet, 2775 for the top folder. That sets the SGID bit and if you changed the group of all the files to the group that runs btsync process, then you should be in a good shape.

 

Share this post


Link to post
Share on other sites

I have been running BitTorrent Sync 1.3.94 on a Synology 412+, installed via the SynoCommunity package, for some months without difficulty. With the synology as the central file repository, I've successfully kept files in sync between an always-on MacMini that runs Apple Mail and Hazel rules; and a MacBook Pro laptop, an iPhone, and an iPad. Everything has worked flawlessly until recently, and I can't figure out what has gone wrong.

 

Suddenly I found I was having sync issues with a few of my more-used folders. I deleted them from sync and tried to re-add the folders thru the Synology BTS interface, only to receive the dreaded "you don't have permissions to write to the selected folder" error. I have checked and re-checked permissions on the folders in question, but I can't see any differences between how they're configured, and other folders that i've added in BTS on the synology and which work fine.

I've tried adding test folders via the Shared Folder or File Station interfaces; doesn't seem to matter, still get the above error when I try to add them to BTS. Doesn't matter whether I access the Synology from my MacBook Pro or from the Mini; same error.

 

I'm logging into the Synology over my LAN via a user account that has administrative privileges.

This has to be a permissions issue of some sort, but for the life of me I can't figure out what changed, or where the problem lies. I've had to go back to Synology Cloud Station sync in the interim, but that is slow as Christmas.

Any ideas would be welcomed as manna.

Share this post


Link to post
Share on other sites

I presume double-checking the permissions includes double-checking the owner, so all I can think of to suggest is ditching the SynoCommunity installation for a manual installation. If that doesn't actually fix the problem, maybe it'll be easier to troubleshoot than the community package, and you'll be able to stay completely up to date in any case.

Share this post


Link to post
Share on other sites

Ditching the community installation for a manual sounds like a good idea. I'm something of a command-line novice, so I admit to being intimidated a bit by that process! I made a stab at it but ran afoul of the NAS's root and btsync user passwords, which I didn't have when called for. Not sure I ever set either one up.

 

I'm also not sure what you mean by "checking the owner" (of the files). At least through the Synology web management interface, I don't see anywhere that one can alter the owner, though you can exert granular control of all other permissions for a given file or folder.

Any further advice would be welcomed. I have looked online for these answers fairly thoroughly, but the information is fragmented and a little tough to follow.

 

Many thanks.

Share this post


Link to post
Share on other sites

Logging into your Synology via ssh is the best way to go because you'll have full and direct control over everything, such as file owner. But you'll need to learn some basic file system commands, as well as "top" and "kill". I mostly use the web file browser too, but be prepared to use basic vi commands at some point.

 

I've accumulated a self-help file as a reference to remind me of Synology 213+ installation details. I'm linking to it here as a poor man's guide to Synology installation. It even includes a survival list of vi commands. I won't make any disclaimers, so feel free to sue me if you break something:

 

https://dl.dropboxusercontent.com/u/25817978/JimmysPoorMansGuide-Synology.txt

 

Oh, and always do "ls -al" when listing a directory, lest you forget about btsync's hidden directories.

Share this post


Link to post
Share on other sites

JimmyTheSaint, you are indeed that. I appreciate your help.

 

I am able to login via ssh as "admin"; I have no idea what my "root" user password is; I don't recall being asked to set one up during initial configuration of the NAS, or at any time since.

 

Looking at /etc/passwd in vi, the btsync user's line is already properly configured to end with /bin/sh. It's a good thing, because the file is read-only; I can't edit itNot when logged in as root!

 

Beyond that you've kinda lost me. I also don't know the btsync user's password; don't recall ever being asked to supply one on initial configuration.

 

UPDATE:

 

I managed to ssh into the NAS as root, and I got the latest version of btsync installed, thanks to this thread. The correct version number now shows when I access the btsync webUI to add folders, though in the "packages" section of the WebUI it still shows the old version. No matter. btsync seems to be running properly on my 412+. One problem solved.

 

My remaining problem is that "don't have permission to write" issue that started this all off.

 

Looking at the contents of my home directory where my folders are stored, the folders I'm able to write to with btsync have permissions drwxrwxrwx,while those I can't write to have permissions d---------. So how do I change this, if indeed this is the problem?

Edited by MikeSeb

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.