RomanZ

Latest Desktop Build 1.3.109

Recommended Posts

Please feel free to use build 1.3.109.

Change log:

- Compatibility to upcoming 1.4 builds

- Fix for indexing stuck in certain cases

- Cleanup old peers in Linux WebUI

- Fix for issue of files non-syncing unless fully available

Previous build change log.

Share this post


Link to post
Share on other sites

@pilgrim776

 

That's rather strange. We checked download in our lab - latest Chrome (36.0.1985.125) did not show any warning. Do you run any security software? Possible, some web-scanner?

Share this post


Link to post
Share on other sites

I got the same thing with the latest version of Crome (36.0.1985.125).  It's not a web-scanner that's throwing the error - it's Chrome itself.  The exact message is "BTSync-1.3.109.exe is malicious, and Chrome has blocked it.".  You can click the notice for more info which takes you to this link:

 

https://support.google.com/chrome/answer/4412392?p=ib_download_blocked&rd=1

 

EDIT:  Just tried to download BTSync v1.3.106 with the same version of Chrome and there were no complaints, so it looks like it's just v1.3.109 which Chrome has an issue with.

Share this post


Link to post
Share on other sites

EDIT:  Just tried to download BTSync v1.3.106 with the same version of Chrome and there were no complaints, so it looks like it's just v1.3.109 which Chrome has an issue with.

It's what's known as a "false positive". Most likely as the file is very new, not enough downloads via Chrome have taken place for Chrome to yet be assured the file is safe.

 

However, if you look at the Virus Total analysis of v1.3.109, you'll see that it's safe.

Share this post


Link to post
Share on other sites

If this happens AND you believe it is a false positive AND you don't want to wait then you can recover the download like this:

 

1. Got to chrome://downloads/ (or choose Downloads from the menu button)

2. find the BTSync-1.3.109.exe (it should be at the top of the list)

3. click on the "Recover malicious file" link below it and then when prompted click on "Hurt me plenty".

 

 

Edit: I had this happen when I downloaded yesterday. But just checked after posting and Chrome does not report it as malicious any more.

Edited by andrewb

Share this post


Link to post
Share on other sites

Yep, downloads OK now - but not yesterday.   I have checked yesterday's download against today's.  They have the same SHA1 hash, so nothing has changed with the Sync binary. My Chrome version has not changed either. So, the change is at Google's back end, not in Chrome itself. 

 

I guess this is a dead issue now.

Share this post


Link to post
Share on other sites

The ARM build of 1.3.109 does not display the version number on the GUI.  Please restore this functionality so I can verify what version is on each machine.

Thx

Share this post


Link to post
Share on other sites

The ARM build of 1.3.109 does not display the version number on the GUI.  Please restore this functionality so I can verify what version is on each machine.

Thx

I have a raspberry pi. I upgraded to 1.3.109 and I see the version number

Share this post


Link to post
Share on other sites

I use 1.3.109 only on my Windows 7 notebook and haven't upgraded my other devices yet. When I close the notebook and open it again after a while, I don't see my devices. I have to restart bittorrent sync to see all my other devices. Bug or feature?

 

greetings,

 

merlinuwe

 

 

Share this post


Link to post
Share on other sites

I use 1.3.109 only on my Windows 7 notebook and haven't upgraded my other devices yet. When I close the notebook and open it again after a while, I don't see my devices. I have to restart bittorrent sync to see all my other devices. Bug or feature?

 

I see this using Windows XP too and it's not unique to 1.3.109 either.

It's been happening in previous 1.3.xx/1.3.xxx versions.

 

(I dont recall it happening in 1.2.82, 1.2.91 or 1.2.92).

Share this post


Link to post
Share on other sites

Is there an option to show full folder path (like 1.2.x) instead of only the folder name?

 

See attached image: Right-click on the area between the arrows and check the option(s) you want shown.

post-35384-0-36699700-1407481499_thumb.j

Share this post


Link to post
Share on other sites

Hi,

 

here are some little issues with 1.3.109:

 

I. When I change a file on my local device,

 

1. The tray-icon message "xyz wurde mit Onlinegeräten synchronisiert" appears.

2. Bittorrent sync is syncing.

 

I would prefer the reverse order (after the sync is finished).

 

II. If I have the file ".htaccess" in syncignore, bittorrent sync seems to hang sometimes at this file while syncing. I remarked this by clicking on the "i" (information-icon) in the tab "devices". Not easy to reproduce but often seen in Windows 7 and 8.1. A restart of bittorent sync seem to force the synchronization, but after a few days, the same problem ocures again.

 

And here is a bigger issue (both devices are running 1.3.109):

 

III. Windows 7 notebook: I don't see my debian and windows devices in bittorrent sync. But syncing works ...

Debian 6: It says, that it wasn't connected with my notebook the last 15 hours. But thats not true because files were synced.

 

IV. And here is another:

In notepad++ I got the message, that my (on the server via WinSCP opened) files got changed(!). But the only changes I made, were those from the notebook, not elsewhere. (The time is set correctly on all devices.)

 

 

Greetings,

 

merlinuwe

Share this post


Link to post
Share on other sites

@mike20021969

"losing" other peers after sleep is a known issue. It would be fixed in 1.4.

 

@sandymac

Unfortunately, you are right. Please use workaround for now. Fix should be included in 1.4 release.

 

@merlinuwe

1. Sounds like a bug. Sync should say something like "Synchronizing with ..." when it found changes  and should show popup "sync finished" once it done.

2. I can only say what is happening if I get logs to see what exactly get stuck there.

3. Same as 2. I need logs.

4. Well, notepad++ starts panicking if mtime of the file change occurs - and Sync keeps mimes synchronized. So Notepad++ may show popup even if no actual change occurs.

Share this post


Link to post
Share on other sites

Hello,

 

I do not think "Search LAN" works when you click "Use predefined hosts".

 

Settings:

 

Use relay server when required: OFF

Use tracker server: OFF

Search LAN: ON

Search DHT network: OFF

Use predefined hosts: ON with 2 remote hosts

 

If I add a predefined host with the local name (DEVICE-X) then it will find that host on the LAN, but otherwise it does not seem to look for them.

 

Regards,

 

David

Share this post


Link to post
Share on other sites

I just noticed that, when not syncing, 1.3.109 is consuming 5.7-9.2% CPU on my Linux NAS. As reported in other threads, all the previous versions stayed right around the 13% mark. It's still more than ten times the next closest idling process, but a big improvement if it continues to stay in that range.

Share this post


Link to post
Share on other sites

@mike20021969

"losing" other peers after sleep is a known issue. It would be fixed in 1.4.

 

@sandymac

Unfortunately, you are right. Please use workaround for now. Fix should be included in 1.4 release.

 

@merlinuwe

1. Sounds like a bug. Sync should say something like "Synchronizing with ..." when it found changes  and should show popup "sync finished" once it done.

2. I can only say what is happening if I get logs to see what exactly get stuck there.

3. Same as 2. I need logs.

4. Well, notepad++ starts panicking if mtime of the file change occurs - and Sync keeps mimes synchronized. So Notepad++ may show popup even if no actual change occurs.

 

Hi RomanZ,

 

thanks for your answers, I sent you the logfile of my Windows 8.1 desktop-PC via the feedback-button of bittorrent sync a few minutes ago.

 

Here you see (after an upgrade to 1.3.109 to all my devices), that not all devices are connected. (Only compare the bold formated devices.)

 

FreeBSD (on FreeNAS):

Ordner Größe Verbundene Geräte Optionen backup 164.01 GB in 164775 Dateien 1 von 1 Gerät
 
Austausch 81.91 MB in 548 Dateien 3 von 3 Geräten
 
Mobil 5.53 GB in 2674 Dateien 5 von 5 Geräten
 
Mobil Download ext (ro) 50.08 MB in 17 Dateien 5 von 5 Geräten
 
Mobil Download int (ro) 3.91 MB in 6 Dateien 5 von 5 Geräten
 
@home 410.51 MB in 75 Dateien 1 von 1 Gerät
 

 

Debian 6:

Ordner Größe Verbundene Geräte Optionen Austausch 81.91 MB in 548 Dateien 3 von 4 Geräten
 
Mobil 5.53 GB in 2671 Dateien 5 von 7 Geräten
 
Mobil Download ext 50.08 MB in 17 Dateien 5 von 7 Geräten
 
Mobil Download int 3.91 MB in 6 Dateien 5 von 7 Geräten
 

 

New issue: The syncing of the Mobil device shows a different (!) amout of files (2674/2671).

 

Windows 8.1:

see Attachment

 

Greetings,

 

merlinuwe

post-29402-0-78787600-1407695906_thumb.j

Share this post


Link to post
Share on other sites

@merlinuwe

 

Thanks for the logs. Regarding the .htaccess - did you ignore it on all peers? The asymmetry can happen when it is ignored on only several peers out of all.

 

As for the peers that do not see each other - It is not fully clear for me which peer do you expect to be seen on which other peers (and which are not displayed)? The log indicates that peer where you collect it manages to see 5 other peers.

Share this post


Link to post
Share on other sites

Hi There,
I just updated to .109 via the check now button in preferences in the gui - no problems with this, but it would be nice to have some sort of indication that the update/download is actually happening - Sorry if the post is in the wrong place, was not sure if it should be here or in the wish list.

I am also on the lookout for 1.4 - was invited to beta test but never received anything else?? 

Thanks,
Colin.

Share this post


Link to post
Share on other sites

Updates don't normally show via the check now button for a week or two after each new version.  I think this is to allow any regressions to be ironed out before the majority of users update to the new version, and also has those who do update use the forums, where they are more able to see any issues or bugs that have arisen. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.