pjo65

Rebuild Required For Wd Mycloud Fw 4

Recommended Posts

With WD's latest firmware release (4.x) btsync arm version won't run anymore. To my understanding it needs to be rebuilt for their Debian 64k page size (previously it was 4k page size) firmware.

 

Can BitTorrent help out? Or is source available?

 

 

Share this post


Link to post
Share on other sites

@pjo65

 

I don't think that the issue is in the page size - it should be transparent for the process. However, I presume that there might be some other changes in OS which prevent sync from running.

 

Could you please describe how exactly Sync is not running? Some error message, crash or something else? Did you try to run it with --nodaemon switch to see the app output to console? Can you run it with strace to see which system calls were called before program crashed \ terminated?

Share this post


Link to post
Share on other sites

System simply returns "Killed" (ref.: http://community.wd.com/t5/WD-My-Cloud/Firmware-04-00-00-607-running-btsync-or-unison-instantly/m-p/767995/highlight/true#M18314, 4th paragraph first post). It's thus likely per design by WD but there´s a reference to rebuilding Debian packages to resolve it (ref.:http://community.wd.com/t5/WD-My-Cloud/New-Release-WD-My-Cloud-Firmware-Release-4-00-00-607-7-9-14/td-p/761150 under Important Note:).

 

Running btsync and other 3rd party stuff has thus worked well until the latest fw upgrade.

Myself I have rolled back to earlier fw and can not make the tests just now.

Share this post


Link to post
Share on other sites

I couldn't find any way to PM you denis4inet, but here is the terminal output:

WDMyCloud:/usr/local/bin# ulimit -c unlimitedWDMyCloud:/usr/local/bin#  ./btsync --nodaemonKilledWDMyCloud:/usr/local/bin# lltotal 10488-rwxr-xr-x 1 root root 5609752 Jul 30 03:09 btsync-rwxr-xr-x 1 root root  292852 Dec 12  2013 forked-daapd-rwxr-xr-x 1 root root  213291 Dec 12  2013 lld2d-rwxr-xr-x 1 root root  236879 Dec 12  2013 mDNSResponderPosix-rwxr-xr-x 1 root root   11355 Oct 24  2013 nlock-rwxr-xr-x 1 root root  711896 May 14 16:40 ufsd.ko-rwxr-xr-x 1 root root   44956 Dec 12  2013 upnp_nas_device-rwxr-xr-x 1 root root    7423 Oct 24  2013 wd-btnd-rwxr-xr-x 1 root root   71035 Dec 12  2013 wdAutoMounter-rwxr-xr-x 1 root root 3489106 Mar 12 15:17 wdnotifierWDMyCloud:/usr/local/bin# 

and no dump file found in the directory either.

Edited by aloha808

Share this post


Link to post
Share on other sites

Hi,

I've just bought a WDMyCloud and got same problem when trying to start BTSync. I'm having the same result when trying to run the commands indicated:

ulimit -c unlimited
./btsync --nodaemon
 
I only get the Killed message and there's no dump file present in directory!
 
Please help.

Share this post


Link to post
Share on other sites

Myself I have downgraded to latest fw 3. You'll find the how-to details in WD forum.

WD is obviously killing anything user installs on fw 4 unless it´s rebuild using their environment.

FW4 is not customization-friendly and FW 3 is preferred if you like to add/autorun custom features.

Share this post


Link to post
Share on other sites

Hi all,

 

For now BT is not going to support this particular NAS model. Please use Sync with GlibC 2.3 as solution. It lacks only one function comparing to other builds - it does not subscribe for immediate directory change events, so files changed are detected only during full folder rescan.

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for your answer. Do you mean the WD MyCloud GlibC build is the one that lacks the function you describe in your post? Or the GlibC 2.3?

 

Anyway does this mean that if we want to install btsync on a WDMyCloud we need to stick with firmware version prior to 4.x?

Share this post


Link to post
Share on other sites

@mogarick, @Arty2

 

I apologize for wrong information. The Glibc 2.3 version won't help here. The only way to run Sync would to indeed to stick with older WD firmware.

Share this post


Link to post
Share on other sites

Thank you @RomanZ,

 

Is there any plan for future support of this WD NAS Drive?

The new WD FW update solves a lot of other problems such as read and write performance and it's sad that we BTSync users can't update because of the lacking function you mentioned regarding GlibC that is needed for BTSync to work properly.

 

I'm in love with BTSync but I also need to use it with this drive to have my private cloud working for devices photo backups and laptop folder's synchronization.

 

I hope you can give us a real solution. Thank you in advance for your help.

Share this post


Link to post
Share on other sites

@mogarick

We want to support WD new firmware in future, but I cannot claim any plans / ETAs due to project status (beta). Please stay tuned for the news.

Share this post


Link to post
Share on other sites

Yeah, the issue is that they build new linux kernel with 4k page size instead 64k before or other way round

There are lots of discussions here http://community.wd.com/t5/WD-My-Cloud/New-FW-4-00-00-upgrade-results/td-p/761154/highlight/true/page/3

 

So btsync needs to be recompiled with that new non-standard kernel. but because btsync is closed-source software community can't do this by themselves. I just bought my wd own cloud and it is already have firmware version 4 so I'm trying to downgrade at the moment


unfortunately downgrade hasn't worked for me.

will have to restore rootfs with firmware version 4


one more update

cloud restored version 4 by itself after failed boot from the second RAID partition

 

so looking forward to seeing recompiled version  for this non-standard kernel WD released. Seems like they put sticks into wheels on purpose by releasing version 4 with non-standard kernel


@mogarick

We want to support WD new firmware in future, but I cannot claim any plans / ETAs due to project status (beta). Please stay tuned for the news.

Hi Roman

Please have a look at this source code package from WD http://support.wdc.com/product/download.asp?groupid=904&sid=233〈=en

you can find out linux arm compilers inside, both for firmware version 3 and version

Share this post


Link to post
Share on other sites

@RomanZ,

 

I'll sure be tuned on the issue because I love BTSync and I want it to be compatible again with my WDMyCloud.

 

Thank you for your attention. 

 

@dimazigel

I'm sorry you couldn't downgrade. Did you follow al instructions including the one regarding to edit /etc/version file? 

The process is described in this URL: http://community.wd.com/t5/WD-My-Cloud/Easy-method-to-downgrade-to-previous-version-of-the-firmware/td-p/773073

Share this post


Link to post
Share on other sites

There is no problem with the version file as I hacked installation shell script as suggested in the thread I mentioned in my message. I just commented out version check. I'm just getting lots of errors during running an installation script. I wouldn't bother using btsync at all if WD supported Linux as I use Linux on all my laptops. Maybe I'll try to setup rsync instead.

Share this post


Link to post
Share on other sites

Hi @RomanZ

 

I've just visited the WD forum and noticed there's a new firmware version released on September 24 (version 4.00.01-62​3).

 

Have BTSync Staff has the opportunity to check it out to see if there are something that can make BTSync run again without trouble?

 

Thank you in advance for your attention. 

 

Here's the link to the announcement.

 

http://community.wd.com/t5/WD-My-Cloud/New-Release-WD-My-Cloud-Firmware-Release-4-00-01-62-3-9-24-14/td-p/800509


Hi again,

 

I found a post in WD regarding the rebuild of debian packages for the 4.x version of the firmware in order to support the 64 page size.

Maybe that can help. I'm not an expert in linux stuff. 

 

http://community.wd.com/t5/WD-My-Cloud/Read-the-Instructions-to-rebuild-a-Debian-package-section-of-the/m-p/763276/highlight/true#M17468

 

Greetings.

Share this post


Link to post
Share on other sites

Hi, I've tried running it on the latest FW and it does indeed execute but I can't access the port at 8888...

 

 

/usr/local/bin # ulimit -c unlimited

/usr/local/bin # ./btsync --nodaemon

By using this application, you agree to our Privacy Policy, Terms of Use and End User License Agreement.

http://www.bittorrent.com/legal/privacy

http://www.bittorrent.com/legal/terms-of-use

http://www.bittorrent.com/legal/eula

 

[20141017 11:16:54.523] total physical memory -1 max disk cache 2097152

[20141017 11:16:54.525] Using IP address 192.168.5.140

[20141017 11:16:54.529] Loading config file version 1.4.93

[20141017 11:16:55.575] UPnP: Device error "http://192.168.5.140:49153/nasdevicedesc.xml": (-2) 

[20141017 11:16:55.615] UPnP: ERROR mapping TCP port 15101 -> 192.168.5.140:15101. Deleting mapping and trying again: (501) Action Failed

[20141017 11:16:55.622] UPnP: ERROR removing TCP port 15101: (714) The specified value does not exist in the array

[20141017 11:16:55.634] UPnP: ERROR mapping TCP port 15101 -> 192.168.5.140:15101: (501) Action Failed

[20141017 11:16:55.639] UPnP: Device error "http://192.168.5.142:80/description.xml": (-2) 

[20141017 11:16:55.683] UPnP: Device error "http://192.168.5.137:1400/xml/device_description.xml": (-2) 

[20141017 11:16:55.747] UPnP: Device error "http://192.168.5.148:1400/xml/device_description.xml": (-2) 

[20141017 11:16:55.768] UPnP: Device error "http://192.168.5.139:1400/xml/device_description.xml": (-2) 

[20141017 11:16:55.854] UPnP: Device error "http://192.168.5.108:1400/xml/device_description.xml": (-2) 

[20141017 11:16:55.874] UPnP: Device error "http://192.168.5.113:1400/xml/device_description.xml": (-2) 

[20141017 11:16:55.874] UPnP: Device error "http://192.168.5.120:1400/xml/device_description.xml": (-2) 

[20141017 11:16:56.012] UPnP: Device error "http://192.168.5.126:1400/xml/device_description.xml": (-2) 

[20141017 11:16:56.585] UPnP: Device error "http://192.168.5.10:1164/DeviceDescription.xml": (-2) 

[20141017 11:16:57.591] UPnP: Device error "http://192.168.5.20:1900/cameradesc.xml": (-2)

Share this post


Link to post
Share on other sites

@hawkman

 

Starting from 1.4.82 Sync binds WebUI socket to loopback interface for security reasons. Try running:

 

./btsync --nodaemon --webui.listen 0.0.0.0:8888

 

It will force WebUI to listen on all available network interfaces.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.