Sign in to follow this  
Catsrules

Blank Web Gui Ubuntu 14.4

Recommended Posts

I have broken the web UI on my Ubuntu 14.1 installation of Btsync, and I can't figure out how to get it back.

 

I was playing around with file permissions, because I have Btsync and SAMBA accessing the same folders, this was creating file permission issues with who owns them. But I figured it out, just as I got it working, the WebUI stopped working. I get a password prompt I type in my password, and I get a blank page. I have tried to reconfigure BTsync several times, I have tried to change port number and IP address binding, web user log in and password but nothing has worked so far. I even removed btsync and installed it again, but it looks like there are config files that still remain.

 

Any ideas?

 

As far as I can tell syncing works just fine, I just can't change anything because of the lack of UI

 

Thanks

Share this post


Link to post
Share on other sites

Catsrules,

 

Was it working before you've set permissions? Do I understand it right and you start Sync with a config? If yes, did you define directory_root" there for Web UI? 

 

Also, please, make sure that you have the correct address. It should be   http://xx.xx.xx.xx:8888/gui Is it like this? 

Share this post


Link to post
Share on other sites

Yes it was working before I changed permission, umask of files. Where do I go to define the directory_root? I am using the dpkg-reconfigure btsync command. Would it the very first screen talking about running as daemons and where are the configs? If so then it is /etc/btsync?

 

When I connect to http://serverip:8888/gui I get the login prompt I enter in my user ID and password and then I get a blank page. I have changed the port number and I still get it.
 

I am guessing it has something to do with permissions for the web server but I don't know where the web files are stored.

Share this post


Link to post
Share on other sites

Catsrules,

 

directory_root for web ui is defined in our default config. Once you use dpkg-reconfigure btsync (which is the unofficial Sync package), please, address the issue to this forum topic

Share this post


Link to post
Share on other sites

Catsrules,

 

directory_root for web ui is defined in our default config. Once you use dpkg-reconfigure btsync (which is the unofficial Sync package), please, address the issue to this forum topic

ok thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this