Sign in to follow this  
thatcher

Mac Osx Client Start With --Config Exits Immediately

Recommended Posts

When trying to start the bittorrent sync client with --config, to use the API on Mac OS X Mavericks the client just exits immediately. No output is given on stdout, no log is written in /Users/<me>/Library/Application Support/BitTorrent Sync/sync.log nothing. No hints.

 

If I run the same command without --config it runs just fine and properly starts the client (with UI) as expected. 

 

I'm using the latest  1.3.109, but for sakes of testing also tried a 1.3.106 I found. 

 

See below for relevant details. Help?

 

Thanks in advance!

bash-3.2$ pwd /Applications/btsync/BitTorrent Sync.app/Contents/MacOSbash-3.2$ ls BitTorrent Sync	config.jsonbash-3.2$ cat config.json {    "storage_path" : "~/.BtSyncAPI",    "use_gui" : false,    "webui" : {        "listen" : "127.0.0.1:8888",        "login" : "thatcher",        "password" : "somesecret",        "api_key" : "** my api key**"    }}bash-3.2$ ./BitTorrent\ Sync --config config.json bash-3.2$ 

Share this post


Link to post
Share on other sites

Ok. I found the issue: "storage_path" cannot be ~/, it has to be some absolute path. At least the linux version gaves me a warning. It would be great if that warning can be added to the mac binary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this