Sign in to follow this  
sciurius

Burning Cpu Cycles

Recommended Posts

On my NAS (Synology DS413) btsync consistently uses between 20 and 50% CPU. This is true for versions from1.3.86 (the first I have) until 1.3.109 (the current version).

I have about 25 folders attached to btsync, good for some 30,000 files. I may assume that btsync can handle this easily.

The logfile only shows a couple of incoming connections per second.

 

On another system (15 folders, 20,000 files) btsync uses about 2% CPU, which I consider a normal value.

 

Anything I can do to find out what's going wrong?

Share this post


Link to post
Share on other sites

 

On another system (15 folders, 20,000 files) btsync uses about 2% CPU, which I consider a normal value.

 

 

As i understand - first system is NAS, and second system is NAS too?

 

CPU usage depends from: CPU architecture, number of cores, number of supported instructions (SSE, AES) etc.

Share this post


Link to post
Share on other sites

As i understand - first system is NAS, and second system is NAS too?

No, the other system is a x86_64 desktop.

 

CPU usage depends from: CPU architecture, number of cores, number of supported instructions (SSE, AES) etc.

The DS413 has 1.067 GHz Dual Core-processor and 1 GB DDR3 RAM. It should be capable of handling this btsync load with less than 5% CPU.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this