[Solved] Sync 1.4.72 Force_Https Not Working - No Access To Webui

Recommended Posts

Hi all!


I'm on FreeBSD 9.2 / 9.3 (NAS4Free) and tried to get https access to the WebUI running. Configured a sync.conf file accordingly but until now - no success. When I try "https://MyLocalIP:8888/gui/" the browser (IE, Firefox, Chrome) always shows loading but didn't finish to the WebUI. With http everthing is working.


My sync.conf:

    "storage_path": "/Path/To/btsync/.sync/",
    "pid_file": "/Path/To/btsync/.sync/sync.pid",
    "webui": {
        "listen": "MyLocalIP:8888",
        "force_https" : true,
        "ssl_certificate" : "/Path/To/btsync/keys/cert.pem",
        "ssl_private_key" : "/Path/To/btsync/keys/private.key"
    "disk_low_priority": true,
    "folder_rescan_interval": 600,
    "lan_encrypt_data": true,
    "lan_use_tcp": false,
    "max_file_size_diff_for_patching": 1000,
    "max_file_size_for_versioning": 1000,
    "rate_limit_local_peers": false,
    "recv_buf_size": 5,
    "send_buf_size": 5,
    "sync_max_time_diff": 600,
    "sync_trash_ttl": 30


There are no errors in the log and sync is running - I see it is connected to another peer.


Any ideas ???



Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.