GreatMarko

Latest Desktop Build 1.4.75

Recommended Posts

If it stays bound to IE I'll kill it from all my 7 clients! I stopped already promoting this thing to friends.

Same here. Though I have to admit I still promote it but the 1.3 version. I've already told everyone not to upgrade to 1.4.

Share this post


Link to post
Share on other sites

@zeropluszero

Version 1.3 won't be updated to HTML UI. Though, as you mentioned - we'll support it only for some period of time.

 

@onesolo

If you copy the link, it will show you something like that:

https://link.getsync.com/?f=MySyncFiles&sz=31E6&s=HIHVQMDVRFOPGYLFK4EHUWTDOWB2TSG4&i=C33XK7A3AWUIPJ5CKFBF45SF4VBYRNZQ6&p=CDGEQZYST3QGVJLMBCAJSOJAJBRRNAUR&e=1410607989

 

If you mail it - it should open your default mail client with e-mail template, containing similar link.

 

If all of the above does not happen - could you please collect debug logs so we can take a look what's happening?

Then I have a problem, as I told, none work for me, except the qr code

I'm now on another computer and it work.

Tomorrow going to uninstall it to see if it works...

Share this post


Link to post
Share on other sites

@Herb, @koldKat,

I cannot promise anything at current stage of product development - but please stay tuned for newer versions. You are heard, both management and development are aware of what people on forums say regarding IE.

 

@onesolo

The javascript displaying UI failed to copy link to clipboard or call for default mail client. As I mentioned, I need your logs to find out why.

Share this post


Link to post
Share on other sites

@romanz still the same... how do I get the logs??

I see the sync.log but I don't see nothing inside of it about this bug...

 

 

version: 1.4.75
platform: Windows workstation 6.2.9200 x86
[2014-09-11 12:07:01] total physical memory 4294967295 max disk cache 33554432
[2014-09-11 12:07:03] total physical memory 4294967295 max disk cache 33554432
[2014-09-11 12:07:09] total physical memory 4294967295 max disk cache 33554432
[2014-09-11 12:07:09] Using IP address 192.168.1.109
[2014-09-11 12:07:10] Aes BCrypt algorithm provider has been loaded and initialized
[2014-09-11 12:07:10] failed to set IP_ADD_MEMBERSHIP for 169.254.205.42:0: -1
[2014-09-11 12:07:10] failed to set IP_ADD_MEMBERSHIP for 169.254.96.139:0: -1
[2014-09-11 12:07:18] NAT-PMP: Unable to map port with NAT-PMP.

 

Any other log file about that??

Share this post


Link to post
Share on other sites

@onesolo

 

The log piece you cited is actually part of the log I need. I do not know what else could be found there, but I hope for something that gives a hint for your issue.

 

For the piece you dropped I see couple of suspicious things (though, none is related to inability to copy / mail link):

1. You've got 2 network interfaces with self-assigned IPs (are your DHCP server okay?)

2. Your Sync failed to subscribe to multicast group (no automatic LAN discovery available)

Share this post


Link to post
Share on other sites

Has the ability to generate a one time secret (read/write or read only) been removed?

No, it's still there! ...but it's evolved and improved!

On the "Share" screen, click "Advanced" - you'll then be able to specify exactly how many times the link can be used (and also specify how many days the link is valid for as well!)

Share this post


Link to post
Share on other sites

No, it's still there! ...but it's evolved and improved!

On the "Share" screen, click "Advanced" - you'll then be able to specify exactly how many times the link can be used (and also specify how many days the link is valid for as well!)

 

Hmm... Seeing that now, but doesn't the Share screen give you a link, instead of a secret?

Thanks!

Share this post


Link to post
Share on other sites

The link is the new one time secret with more possibilities like "needs approval" as far as I know.

 

That depends upon whether you tick the "Peers I invite must be approved on this device" option in the advanced options of the sharing window.

Share this post


Link to post
Share on other sites

I know. That's why I wrote "possibilities", because it's possible but not necessary :-). thank you anyway if it was unclear for the questioner.

The "as far as I know" was referred to the fact that I'm not 100% sure if there is still the old one time secret available without link. Sorry for confusion.

Share this post


Link to post
Share on other sites

well this sucks... looks like I can't update :(

 

I'm not getting Win7 or any newer MS RAT-ware OS.

 

...

 

perhapse I can get you guys to start supporting XP again...

 

...

 

there's no way I'm getting anything newer than XP with that thought in mind.

Edited by GreatMarko
Lengthy offtopic ramblings removed

Share this post


Link to post
Share on other sites

(with WinXP you don't have to worry about MS having access to your files and watching everything you do)

That's FUD and you know it.

 

perhapse I can get you guys to start supporting XP again...

I recently argued with a computer salesman on this issue and now even he's unsure about selling newer Windows OS's.

 

Wow. 

 

Good look getting ANY software developing company to again support an operating system that's been EOL'd by the supplier.
 

MS only stopped supporting XP because they can't control their users and "it's too much work for them"

No, they stopped supporting XP because it's THIRTEEN FREAKING YEARS old.

 

I'll leave the rest of your BS uncommented. Keep using XP and BTSync 1.3 then, nobody's stopping you.

Share this post


Link to post
Share on other sites

Tcll, please keep your comments on-topic. This thread is for the discussion of Sync 1.4.75

Lengthy ramblings about how you believe Microsoft want to "control people" are not in anyway related to Sync 1.4.75.

Your post has therefore been edited to retain the salient point of your comment only. Please bear this in mind when making future contributions to these forums.

Share this post


Link to post
Share on other sites

I'm sorry... :(
I was just a little hot-headed when I wrote that as I'd been dealing with alot of crap...
(switching to what's rated the best AV software, while having tonz of issues)
 
I'd love to continue using BTS... it was on the start of becoming a great program...
but you guys want to support the unsecure OS's and leave secure XP (including many additional layers of protection) in the dust.
 
[post truncated]

Edited by GreatMarko
Post truncated due to its subsequent descent into off-topic areas

Share this post


Link to post
Share on other sites

Tcll, Once again, please keep your comments relevant and "on-topic" to the subject matter of the thread.

 

As a reminder, the theme of this thread is a discussion on Sync 1.4.75.

 

Your input on this subject is welcome, and you have now made your point that you wish to see Sync 1.4 supported on Windows XP.

 

These forums, however, are not the place for airing lengthy "off-topic" views on your perceived security of various Windows kernels or your belief that Microsoft want to "control people" - such things in themselves do not relate to BitTorrent Sync 1.4.75, and therefore do not belong here.

 

Last warning - Please drop it.

Share this post


Link to post
Share on other sites

A fresh install of 1.4.75 on Linux (Debian 7.6) fails to work with web gui.  The /workaround/ is to run 1.3.106 first, accept the terms in the web gui, then shutdown 1.3.106 and try 1.4.75 again.

 

No issues with using Firefox on Windows 7 64 bit.... no requirement for IE for me and that's the way I want it.

Share this post


Link to post
Share on other sites

There seems to be many more problems with the Linux version of 1.4.75 -- I added a folder to sync, the remote folder -- actually available on the LAN on a Windows box (has over 25GB) ... as well as other remote locations, but the newly added folder on the Linux box says it is synced, but no files have been added. :(

 

It looks like I'm going to have to revert to an older version at this stage.

 

Edit: stopped and restarted the Windows client, now the Linux client is receiving...

 

Edit: this is so frustrating, it says it is receiving, but it is not taking advantage of the LAN copy and it seems to be stopped even though it says it is still going (extremely slow speed).  The LAN has kicked in now, getting some reasonable speed.

Share this post


Link to post
Share on other sites

Any idea on when/if this will be work with the auto update?

 

As per the Unofficial FAQ:

 

"If you currently use the auto-update feature of BitTorrent Sync, it may inform you that your "Client version is up to date" despite a newer build being available. This is intentional whilst Sync remains in "beta" - new builds are currently announced here in the forums in the first instance. Not every "beta" build is pushed via auto-update, only those considered significant/more stable. Even then these may not be pushed out to existing users via auto update until several days/weeks after they are first announced on the forums"

Share this post


Link to post
Share on other sites

Tcll, Once again, please keep your comments relevant and "on-topic" to the subject matter of the thread.

 

As a reminder, the theme of this thread is a discussion on Sync 1.4.75.

 

Your input on this subject is welcome, and you have now made your point that you wish to see Sync 1.4 supported on Windows XP.

 

These forums, however, are not the place for airing lengthy "off-topic" views on your perceived security of various Windows kernels or your belief that Microsoft want to "control people" - such things in themselves do not relate to BitTorrent Sync 1.4.75, and therefore do not belong here.

 

Last warning - Please drop it.

ok I got it, sorry again >3<

 

yea if it could not require IE, that would be a plus in an update (that saying it works with XP, specifically x64) :)

Share this post


Link to post
Share on other sites

Has there been a change in the compile for btsync v1..4.xx regarding glib23_i386 vs i386?  See this thread.  

 

I have Centos 5.9 i386 with glibcc 2.5-107.

 

  • from btsync 1.1.116 to 1.3.94 I have downloaded and installed the i386 compile (btsync_i386-1.3.94.tar.gz) and this worked fine.
  • from btsync 1.4.72 the same i386 compile would not run and gave an error like:
symbol lookup error: /usr/local/bin/btsync/btsync: undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE

Thanks to @cjvs on the the 'Btsync 1.4.75 (i386) Crash On Readynas Pro' thread I have got running again by using the glibc23 compile for i386 (btsync_glibc23_i386-1.4.75.tar.gz).

 

Which is why I ask why? - was there a change for 1.4.xx and is this the new way?

Share this post


Link to post
Share on other sites

@affinity

Could you please elaborate - what exactly is not working in WebUI on your Debian? It might be a known issue and / or I may propose some workaround.

 

@Tcll

Note, that Sync 1.3 and earlier were never supported WinXP x64 officially (though, most likely were working with no issues). Only WinXP x86. As for the rest - see my previous post, BT is aware on people's feedback.

 

@andrewb

1.4 release contains many changes. Though, as your NAS has glibc newer than 2.3 - the build for i386 should be working fine for you. We'll check what could cause this error and get back to you.

Share this post


Link to post
Share on other sites

The android-app still cant create r/w shares via keys only read-only (or backup-shares). How is the prposed workflow for setting up a full sync between a Android mobile an a headless linux-system?

Plesse re-enable the Generation of keys/secrets for full shares.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.