ctheune

Broken Installation - Keeps Asking For Agreeing With The License

Recommended Posts

Hi,

 

I just got started today and successfully installed Sync on my Mac and a Linux VM - those worked fine.

 

Now I went ahead and installed sync based on http://www.droboports.com/app-repository/btsync-1-0-132 and ended up with a partially working installation: I see the process running and it responds to me in the web UI but it doesn't work.

 

Looking at the introspector I see all javascript requests failing with a 500 error saying

{ "error": "Need to agree with the license", "status": 500 }

 

I did press the button and clicked the checkbox but it keeps coming back and the debug log doesn't show any better errors. :(

 

Ideas?

Share this post


Link to post
Share on other sites

I have the same issue with the ARM install 1.4.75 on a Synology DS212J.

 

I installed following these steps: http://blog.bittorrent.com/2014/02/04/sync-hacks-how-to-set-up-bittorrent-sync-on-a-synology-nas/

 

After firing up the web ui and checking the "agree to terms" checkbox and entering a username/pwd at the prompt I can see a http request made to

 

<ip>:8888/gui/token=<token>&action=setlicenseagreed@value=true@usename=<user>&newpwd=<password>&oldpwd=&t=...

 

The response to this web request looks like this:

 

HTTP/1.1 200 OK
Connection: keep-alive
Content-Length: 82
Content-Type: application/json; charset=utf-8
Cache-Control: no-cache
 
{ "status": 200, "value": { "error": 502, "message": "SE_WU_PASSWORD_MISMATCH" } }
 
and then every subsequent request fails with:
 
HTTP/1.1 500 ERROR
Connection: keep-alive
Content-Length: 60
Content-Type: application/json; charset=utf-8
Cache-Control: no-cache
 
{ "error": "Need to agree with the license", "status": 500 }

 

Anyone have any ideas whats going on with this issue that ctheune and I are having?

Share this post


Link to post
Share on other sites

For Syno NAS case there is my tentative solution:

 

http://forum.bittorrent.com/topic/31586-synologynastentative-solution-to-resolve-cannot-accept-eula-cannot-see-folders-in-add-folder-view/

 

For others platform, I suggest try to execute the btsync directly through ssh, or do not add any user & password in sync.conf file and let the btsync to create the user and accept the eula during first login.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.