[Synologynas]Tentative Solution To Resolve Cannot Accept Eula / Cannot See Folders In Add Folder View

Recommended Posts

Many users like me may encounter problem when installing the latest version of btsync app package that coming from spk source: packages.synocommunity.com . The main problem is the user cannot accept the EULA forever and cause the btsync malfunction. After investigation, I found out that the 1.4.x version of btsync in arm / linux platform may have an issue if running btsync with config file that include user and password information and cause the user cannot accept eula, even checked the box.


Here is the work out on this issue, hope can help you all:


1. Uninstall the btsync to clean up all app folders;

2. Install the btsync from the source : packages.synocommunity.com

3. During installation, enter the btsync device name, user and password, then click next

4. **Important Step** Uncheck "Run after installation", click Next, then click OK

5. Go to Synology control panel to enable SSH if not enabled yet

6. Use putty (windows) / ssh (osx/linux) to login your NAS with user root and admin password

7. After enter ssh, type the command "su btsync"

8. Type the command "vi sync.conf" to edit the file, add "//" to comment the config setting as following sample:




  "device_name": "NAS",

  "storage_path" : "/usr/local/btsync/var",

  "pid_file" : "/usr/local/btsync/var/syncapp.pid",

  "webui" :


    "listen" : "" // ,

//    "login" : "login",

//    "password" : "password"



Please remember in the listen line, add the "//" before the ","


9. Type "ZZ" to save the file

10. Go to Syno app manager, start / run the package

11. Go to web site http://192.168.x.x:8888, enter user name, password x2, check eula

12. Try add folder, if you see all the folder, BINGO!

13. Additional info: If your NAS only have single volume (most of NAS use this setting), you can add the following setting after "password" line and before "}": (beware need add the "," at start of this line). Restart the btsync app afterward. This setting may help you to pick up the share folder more easily.


    ,"directory_root" : "/volume1/"


That's all.....hope can help you all.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.