Error In The Synchronization Of Existing Folders


Recommended Posts

Hi Guys,
I ask immediately apologize for my English. I hope I make myself understood.


I have two QNAP with BTSync to version 1.4.83 Beta, I have a problem if I want to synchronize two folders already exist.

In the "NAS A" and "B NAS" I have 8 folders equal (I did copy and paste by hand). I turned on the "NAS A" BTSync for all 8 folders and waited indexing.

In the "NAS B" I have activated synchronization, using the private key of the "NAS A", for all 8 folders.  But they are always "0 peers" and the synchronization don't part.


Screenshot from NAS B:



But if I sync a folder full of "NAS A" in an empty folder "NAS B" synchronization part and I see "1 peers." The "NAS A" starts to send data to the "NAS B".

I do not understand why?!




Edited by drego85
Link to comment
Share on other sites



How are these NASes connected? LAN / internet? It simply might take a while for them to find each other.

Also, how did you transfer the key / link between them? Could it happen that you made a type while transferring key? What was not working in UI that make you to migrate to config file?

Link to comment
Share on other sites

Hi @Romanz,

the two NAS are connected via the Internet. I waited 24 hours but not yet seen, I added the parameters "known hosts" but still nothing.

But in the "NAS B" I created a new folder, empty, and immediately saw the synchronization started.


The keys I transferred with a simple copy and paste using the GUI, I'm sure I did well with the procedure. I repeated at least twice for all eight folders.


When I left the GUI on the "NAS B", and I wrote this piece of code to the configuration file everything worked!


      "secret" : "ABDEFGHILMNOPQRTSUVZ1234567890", // required field - use --generate-secret in command line to create new secret
      "dir" : "/share/MD0_DATA/deanna", // * required field
      "use_relay_server" : true, //  use relay server when direct connection fails
      "use_tracker" : true,
      "use_dht" : false,
      "search_lan" : true,
      "use_sync_trash" : true, // enable SyncArchive to store files deleted on remote devices
      "overwrite_changes" : false, // restore modified files to original version, ONLY for Read-Only folders
      "known_hosts" : // specify hosts to attempt connection without additional search



I think the GUI crashes when a directory is not empty!

Link to comment
Share on other sites


So when you configure NAS B over WebUI it does not sync, while when you do it over config file - it starts synging, correct?

Yes, correct!

What about NAS A? How do you configure it?


Also, what makes you think that UI (or actually the process?) of Sync is crashing?

In the "NAS A" was to enable the Web GUI. Add folders, known hosts and I copied the key to reading and writing. The key then the use for the "NAS B".

In the "NAS A" and "B NAS" option was turned UPnP, and I verified that the doors were open on the modem Fritz! Box.

Today, however, I disabled the Web GUI on the "NAS A" and "B NAS"! I prefer to keep both UPnP disabled in the network, with the Web GUI Active is impossible to set a port. Automatically changes the port, despite the file sync.conf have set the correct port (eliminating the value 0) and we have disabled the UPnP.

Now I don't use the GUI on both NAS. I configured everything via command line and file sync.conf. The GUI would be more convenient to read the states/log.

Link to comment
Share on other sites

@RomanZ I'll update!

Annoyed at not being able to use the GUI, it is difficult to check the status by reading a log file very long.

I decided to re-enable the GUI, eliminating the previous synchronizations. If I use the key I still have the same problem (both peers are not seen), but if I use the share link all goes well and the synchronization part!

Now I have a problem with permissions/ownership, synchronization is performed by ADMIN user and him group account. But I wish it was made ​​by another user. On the QNAP NAS seems difficult to implement this change.

But I'll open a specific 3d ...



Link to comment
Share on other sites

  • 2 weeks later...

I ran into this as well. Had a shared folder syncing between two machines A and B, and had the exact same contents on a third machine C (OS X). Entered the key on C and chose the existing folder, it is connected, says that it tries to sync but nothing is happening (0 B/s transfer).


Because I have 20 GB in there, synchronizing to an empty folder seems ridiculous since the machine already has the files. Please advise.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.