aauldridge

1.4.76 Issues On Qnap Nas

Recommended Posts

Last night I upgraded 2 QNAP NAS to v1.4.76 of BTSync (from 1.3.106).  I'm encountering different (critical) problems with both installations.

 

The first install is on a QNAP TS-670 Pro.  This NAS has 22 BTSync shares.  After upgrading, the BTSync process stops ~15 seconds after I turn on the service.  I've restarted the service more than 10 times but within a few seconds the process ends without any indication why.

 

The second install is on a TS-212.  This was a new install of BTSync on this NAS and I'm just creating my first shares.  After upgrading, I'm trying to create a share using an existing READ-ONLY key.  After entering the key and selecting the folder, no peers are listed.  When I display the keys of the sync, neither the READ-WRITE or READ-ONLY are the same as the READ-ONLY key that I entered when creating the new share.

 

BTW, last night I also upgraded my two NetGear ReadyNAS 102 to BTSync 1.4.77.  One has 8 shares and the other has 9 shares.   Neither is crashing and I'm able to create a new share using an existing READ-ONLY key.

 

Questions:

1) Is anyone else experience the same problems on their QNAP NAS?

2) Is there anything I can do about these problems other than wait on an updated version?

 

Thanks...  Alan

Share this post


Link to post
Share on other sites

Hi,
with QNAP I've also had several problems (see here: http://forum.bittorrent.com/topic/31852-error-in-the-synchronization-of-existing-folders/, here: http://forum.bittorrent.com/topic/31906-qnap-and-file-ownership/ and here: http://forum.bittorrent.com/topic/31699-random-port-bugged/) at the end with the last version I'm good. But I had to manually install BTSync.

Remember, however, that BTSync is still in beta and some defect is present.

But BTSync is growing well ...

Share this post


Link to post
Share on other sites

Hi Alan

I have the same difficulties on my QNAP 439 Pro II+

Since the ladt update of BTSync nothing works anymore. The system is extremely slow. I can see the jobs, they're out of sync, peers cannot be found anymore. And worst of all: can't manage existing jobs - needless to say that I can't create new jobs

Share this post


Link to post
Share on other sites

Hi guys,

 

I can confirm that I have had problems on my QNAP TS669-L since upgrading from 1.3 to the latest 1.4 version this week. After installing sync, it runs for awhile, then will not sync. I think the process crashes or goes offline - I'm not sure. All I know is that in order for sync to run again, or to access the Sync control panel on the QNAP, I have to either restart the server or switch BTsync on and off in the App Center.

 

It will usually run long enough to do the initial indexing and then sync up any files across the network (5-15 mins). After that, it crashes, but I don't know why or at what point.

 

BT sync has become SUCH a cool part of my network and my NAS - I would *love* to see a fix on this!

 

Anyone?

T

Share this post


Link to post
Share on other sites

I have the same problem with QNAP TS-869U-RP and 1.4.76. The process will after some time stop to respond and a restart of the application is needed. 

Share this post


Link to post
Share on other sites

I'm not sure if it is QNAP or BitTorrent that is dropping the ball on getting an updated package available for the QNAP NAS.  The latest version Sync is 1.4.99 but were stuck on 1.4.76 which is buggy as anything.  The worst part is nobody seems to care.   :(

Share this post


Link to post
Share on other sites

I've used the following instructions on my QNAP TS-670 Pro and QNAP TS-469L (both have Intel based CPUs) to update them from v1.4.76 to v1.4.99 of BTSync.  So far all of the problems that I was having with crashes and syncing read-only shares have disappeared.  Only time will tell if it stays that way.

 

Warning, I'm not a Linux or QNAP expert.  I'm just a guy that was tired of not getting any support and fighting with a crummy version of BTSync on my QNAP NAS devices.  I hope these instructions are helpful for others.

 

Here are the steps that I used to (successfully?) update BTSync v1.4.76 to v1.4.99:

  • Create a share on the NAS named Temp (or just use an existing share)
  • Download the Linux i386(glibc 2.3) version of BTSync from http://www.getsync.com/download (I downloaded and tried the Linux i386 amd Linux x64 versions unsuccessfully)
  • Use 7-Zip (http://www.7-zip.org/) to extract the file "btsync" out of the archive file bittorrent_sync_glibc23_i386.tar.gz
  • Rename the btsync file btsync_i386 and copy it into the Temp share created in step 1
  • Use putty (http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html) to create an SSH connection to my NAS
  • Execute the following commands from putty (these commands are case sensitive):
    • cd /share/CACHEDEV1_DATA/.qpkg/BitTorrentSync  <- go to the directory where BTSync is installed on the NAS
    • cp /share/CACHEDEV1_DATA/Temp/btsync_i386 .  <- copy v1.4.99 of BTSync into the installation folder
    • chown 1000:1000 btsync_i386  <- to change the owner and group of the new version to the same as the existing version
    • command chmod 775 btsync_i386  <- change access of the new version to the same as the existing version
    • ./btsync.sh stop  <- stop BTSync from executing
    • cp btsync btsync_orig  <- backup the original version of BTSync (in case we need to put it back later)
    • cp btsync_i386 btsync  <- install v1.4.99 of BTSYNC
    • ./btsync.sh start  <- restart BTSync
I believe (from what I have read in other posts) that if your NAS is an ARM version that the version you need to download is the Linux ARM version of BTSync and that your installation path will be /share/MD0_DATA/.qpkg/BitTorrentSync rather than /share/CACHEDEV1_DATA/.qpkg/BitTorrentSync.

 

Again, I hope this helps...  Alan

Share this post


Link to post
Share on other sites

Thanks to Alan for the excellent instructions,

but to Tagazok's question, where can we find the 1.3.9 to revert?

 

The 419P II has an ARM processor, not sure if your process would even work.

 

Seems easier to revert then we can wait for a formal release of 1.4.103.

 

I've been looking and can't find an archive of installers,

and the QNAP page on the BTSync download page is broken.

Share this post


Link to post
Share on other sites

Hi

 

I am neither a system engineer nor network Guru - but just a user who happens to use bt sync in between 2 NAS. A QNAP 439 Pro II+ (destination) and an Asustor 608T (source).

 

As I postet a while ago after installing a new release (1.4) my sync concept broke completely down. Nothing seemed to work anymore. I did a lot of try 'n' error but without success. Finally, after some weeks time, I got the new release 1.76 and lots of the experienced problems (empty gui etc.) seemed to be solved. I deleted my 5 sync-jobs and created them from scratch. It then worked for about 2 days, very slow though, but it worked. No, again, I'm facing some of the old problems again:

 

1. no Peers around (I'm being told on NAS1 that NAS2 is offline; and of course on NAS2 I get the info, that NAS1 is offline (even though both NAS are up and running, nothing happens)
 

2. as there was a sync working during the first 2 days, it was amazingly slow (I'm talking about bites od kb; the cabling is cat.6 and the router is a gigaswitch model); I have also controlled my router regarding multitask Jobs - it's activated); there is no firewall limitation on ports.

3. during the 2 days both NAS were somehow receiving and sending (my Intention is to have the Asustor (NAS1) as source and the QNAP (NAS2) as destination. That means it should only be a one way connection.

 

Questions:

- which steps do I have to do to get a fine, working System again?

- what can I do that my 2 NAS do see each other (communcate) permanently?

- how can I get back the Performance that I used to have on Rek. 1.3x?

 

Thank you very much for your Feedbacks. I Need them desperately.

 

Regards

 

Walter

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Sorry to state the obvious, but it seems to me the logicaly way to get support, if you want it, is to submit a support ticket with Bittorrent Sync. They have been great with me , and have been troubleshooting for weeks back and forth! We still have no resolution, but in the mentime I wanted to quell the 'nobody seems to care" speech. These guys are amazing and work hard and do care. Remember- the app is still in Beta. It's not officially supported my QNAP either... But I understand your frustration - cuz it's so awesome :)))

Share this post


Link to post
Share on other sites

I'm struggling with the same problems...

 

After the update to 1.4.76 and the 1.4.103 syncing is not working at all. The connection always gets lost and if there is a connection it's not more than 20 b/s.

 

Is the 2.0 alpha version working better on QNAP NAS? Or where can I find the latest working 1.3.x version?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.