Journeyman

Are You Still Using Btsync 1.3.xx?

Recommended Posts

@icymatter

Then it is not possible to install 1.4 on it. 1.4 is using newer WinPhone API for some new features which is not available on WinPhone8. You'll have to stick with 1.3 for your xperia.

Share this post


Link to post
Share on other sites

I too switched to 1.4.93 a few days ago as it fixed the port issue. Pretty much the same configuration as travellyan (2 mac desktops, 2 mac laptops, one -cheap- always on linux box, one iPad as a bonus). Around 35 GB of data synced, part backup, part cloud storage and part app preference syncing.

 

I cleaned every .SyncIgnore of xattrs related stuff on every shared folder of all 5 computers before doing a clean install on the first laptop. It seemed to work fine, so I updated the others.

 

Everything works, no more xattrs induced headaches, no beef with the interface (I don't get why so many people went completely berserk with it). RAM usage increased slightly on the Linux Box (Raspberry B running Archlinux arm) but idle CPU usage dropped considerably compared to 1.3.109.

Share this post


Link to post
Share on other sites
idle CPU usage dropped considerably compared to 1.3.109.

Can you post specific CPU usage stats? On my NAS, 1.4 increased CPU usage significantly over 1.3.109. Was there a big improvement with 1.4.93 over the previous 1.4's?

Share this post


Link to post
Share on other sites

Though from the trend of these posts I'm definitely in the minority as I'm using 1.4.93, I will echo the majority of the rest. This new version is much more heavy with a crappy interface (Metro) which is exactly the reason why most IT's wont touch windows 8 to begin with. So as its only necessary for me to keep a single 2TB drive in sync with 6 other servers most on networks using meraki hardware so i can enable dedicated scedualing  so this just stays in the background. I don't have to deal with it as much but i will say the ONLY reason I did upgrade was due to the actual tracking of folder structures upon changes otherwise im of the school of dont fix what isnt broken when it comes to betas. Meaning I don't upgrade from a highly stable release unless there's a necessary feature or its been proven first. With that said I do feel the devs are trying to implement our suggestions in the program itself with new features. And just to those users throwing out owncloud you may want to further read here http://www.webupd8.org/2014/10/owncloud-ubuntu-package-affected-by.html  as some of us use ubuntu and updates can be tricky at best let alone with crap like this rolling around though it was easy enough to fix I'm using both for ownclouds other capabilities and as far as file transfer goes especially with slow connections sync utilizing the BT P2P protocol is superior. Just saying....

Share this post


Link to post
Share on other sites

Can you post specific CPU usage stats? On my NAS, 1.4 increased CPU usage significantly over 1.3.109. Was there a big improvement with 1.4.93 over the previous 1.4's?

 

Using iostat, prior to BT Sync update, avg-cpu idle was stable around 68% after 24h. I updated four days ago and iostat now report 74% idle, and it is still (slowly) decreasing. I'll do a one hour period iostat and report.

 

The btsync process itself is idling between 0.0 and 0.9 % of the Raspberry Pi CPU according to htop, from what I remember 1.3.109 was way higher, around 6-10%.

 

I went straight from 1.3.109 to 1.4.93, so I can't compare with previous 1.4 releases.

 

I'm wondering if the lower CPU usage I'm experiencing might be related to the xattrs fix (no matter what I did to prevent the linux box from trying to sync them, they still seemed to trigger some activity).

Share this post


Link to post
Share on other sites

That's not quite correct - this only applies to Windows builds, and only for Win7 (or later). Non-Windows OS's don't require IE9, nor do WinXP/2k3.

...and as the developers have indicated, the dependance on IE9 for later Windows builds won't persist.

 

I think most people in the world are still using Win 7 (or later)...

Share this post


Link to post
Share on other sites

I think most people in the world are still using Win 7 (or later)...

 

Yes, but the point is still valid; IE8 is the default browser on a fresh install of Windows 7. If you don't use IE, and have turned off updates, you could still be running Win7/IE8 - which some forums members are doing.

 

So, the issue is less which version of Windows you're running and more about what version of IE is installed.

Share this post


Link to post
Share on other sites

I just upgraded from 1.3x to 1.4 on OSX. And I have to agree the new interface is horrible.

 

The old one looked native. And even if it's more work to give each platform it's native interface, I think it's the way it should be done.

 

There's a reason why each OS' interface is different. So each OS deserves a native application UI. Otherwise, the result is just ugly.

Share this post


Link to post
Share on other sites

Issues: 


1.The UI is slow and a lot difficult to understand when compared to the older version . The older version had a small learning curve but i was over with it pretty soo.


 


2. I upgraded to 1.4 on 2nd gen atom pc running windows 7 on 2GB ram . The lag on the machine is so much that it cannot be used to sync large amount of data. 


 


3. CPU consumption is a lot more , dont know about the ram usage.


 


4. Read only keys not accepted from 1.4 to 1.4 (i am using keys and not links). I am using a broken to backup my laptop (nearly 1tb of content added) so all keys were read only . The netbook is  used a seeder . I had downgrade to 1.3 to use it on a slower netbook.


 


5. Out of Sync issues


 


6. The Android UI is much harder to understand . Difficult to sync a folder on phone as R&W to laptop . Everything is confusing. 


 


Does 1.4 display the amount of data that needs to be downloaded or uploaded folder wise ? No one seems to have mentioned this


Share this post


Link to post
Share on other sites

@aBs0lut3z33r0

Yes, you can ask Sync to show the "Peers" column in preferences, click the peers and see which peer needs which amount of data to be uploaded / downloaded.

 

Could you please share more details about your issues #2-5 to our support so we can help you to resolve them?

Share this post


Link to post
Share on other sites

I have put in a ticket to Netgear tech support to ask about when they are upgrading their 1.4 build for the readynas. Until then I have gone back to a version 1.3.89 on all my boxes. It just WORKS! I don't actually mind the UI in 1.4 but I do hate that it just drops peers, cannot sync reliably etc etc.

Share this post


Link to post
Share on other sites

I am also continuing with 1.3.

 

May be I am stupid as hell but everytime some software decides to make UI change to make it more "intuitive" ..  doing pretty much anything on these softwares becomes exponentially difficult for me. So these days I just wait with older versions as long as I can...

Share this post


Link to post
Share on other sites

To the OP :

Yes.

 

Why?

I have never and still cannot get any btsync system above 1.3x to work. Perriod.

 

Do I like the UI of 1.4x?

It's ok.

 

More then 1.3x?

Meh. They both have their appeal.

 

Use-case for 1.4x :

Uninstall 1.3x. Search and delete all .sync folders, temps and app data (windows).

Install 1.4x. Laptop, create some syncs. Disable anything not LAN.

Backup machine, copy in the RO keys. Disable anything not LAN.

Waiting for something.. anything to happen...

Uninstalling 1.4x. For the second time. Next time better work for that will be the last time.

Share this post


Link to post
Share on other sites

May be I am stupid as hell but everytime some software decides to make UI change to make it more "intuitive" .. 

I know what you mean.  It seems like when someone strays from what is conventional, it is never intuitive.  And in this case, the convention has already been established.  Hence, the changes in 1.4 are counter-intuitive.

 

 

To the OP :

Yes.

 

Why?

I have never and still cannot get any btsync system above 1.3x to work. Perriod.

I know what you mean.  I've got hundreds of gigs synced and I don't want to have to re-sync them because 1.4 is messing everything up.  Me and 4 pages worth of members are waiting for the day that it's safe to update.  And by safe, I mean when it's back to the reliability that it once was.  I'm glad for the software that I once loved.  It's awesome that it's free.  But a lot of us have to keep using 1.3 as long as it's better than the updated versions. 

Share this post


Link to post
Share on other sites

Based on my experience the last 4 days I can say with certainty that version 1.4 is a total disaster.  I am honestly not sure how a build without the ability to even perform its central feature ( sync )  made it out of their QA department...   

Share this post


Link to post
Share on other sites

after some absence I cam back here, and saw this post. I also installed 1.4 very early, was so disapointed by the interface and limitations I went back to 1.3, but only using it as is, I do not plan to increase usage. evaluating  replacements.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.