[Solved] Web Ui Doesn't Save Listening Port


sirio81
 Share

Recommended Posts

I installed 1.4.91 x86_64 on a debian wheezy.

It lost all my old settings, but that's not so problematic for me.

 

I need to set a precise listening port because of firewall reasons.

I do it but once I close the settings windows and enter again, it shows a new random port.

I also noticed that if I uncheck "Listening port", it checks it againg.

 

I've been double checking file ownsership and permission.

 

I also enabled debug but I see nothing in the log.

Link to comment
Share on other sites

Here's an example

{  "device_name": "myPC",  "listening_port" : 50263, // 0 - randomize port  "use_upnp" : flase,  "download_limit" : 0,  "upload_limit" : 2048,  "webui" :  {    "listen" : "0.0.0.0:8888" // remove field to disable WebUI  }}

Save this to a file, e.g. sync.conf

Start btsync using this file

  ./btsync --config sync.conf

 

Check

./btsync --help

 

To generate an example file with comments

./btsync --dump-sample-config > sync.conf

then edit sync.conf

 

Every line that starts with // is a comment.

Every line between /* and */ is a comment.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share