[Solved] Sync Update To 1.4 Runs On Install, Crashes On Restart


MisterRider
 Share

Recommended Posts

Hi everyone,

 

I have just updated from 1.3x to the newest 1.4 version. I am running 2 computers on Win8 64bit, one computer on Win 7 64 bit and one on win 7 32 bit. All 64 bit computers have exhibited the following problem:

 

- I install bittorrent sync, run it, and it runs fine.

- I restart the program (or computer) and I get the error that BTsync has crashed (do I want to send the logs etc)

- if I reinstall the program, it works fine again - until I stop and restart it

 

This behavior does not exibit on the WIN7 32 bit machine. Can anyone help?

Crash log attached...

 

Thanks!
T

 

 

---

BTsyncError.zip

 

---

This post and its issue are a continuation from the post at:

http://forum.bittorrent.com/topic/30145-sync-crashes-on-start-up-with-windows-7-64-bit/

 

Link to comment
Share on other sites

  • 2 weeks later...

Hi everyone,

 

To follow-up: BTsync support solved my problem. I had been running the 32 bit version of BTsync 1.3 - and when I upgraded to 1.4, I installed the 64 bit version. This was causing the crash. I proceeded to simply uninstall the 32 bit version, reboot, and BTsync worked as normal.

 

Hope that can help!
T

 

-----

The email reply from support:

 

images.jpeg

Sync Support (Sync by BitTorrent, Inc.)

Oct 20 09:58

Dear Tim,

Thanks for the files. From what you sent, I can see that:
- Program Files (x86) contains 1.3.93 version of Sync
- Program Files contains 1.4.91 version of Sync.

The log in storage folder indicates that 1.4.91 runs, not 1.3. Though, the screenshot you've sent me in initial mail indicates that Sync 1.3.93 attempts to run (and gets intercepted by Windows UAC). This data allowed me to find out what happens in your scenario:

When you install Sync - you install x64 version of Sync. It installs to Program Files and runs itself, everything is fine. Though, your auto run (or shortcut on a desktop?) points to Sync in Program Files x86. When you reboot, OS starts 32 bit version of Sync - it checks the registry key and sees that Revision key is different from 1.3 and attempts to change it (this is the place where UAC intercepts old Sync). After you agree to change the revision, 1.3 tries to load DB - and crashes as DB is too new for it.

It is a good question on how this situation occurred, but to fix it you need:
1) Delete BitTorrent Sync in Program Files (x86) folder.
2) Run Sync from Program Files and uncheck-check "Start Sync on Startup" checkbox, it should fix auto run.

Please let us know if it helps!

Sync Support Team.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share