Latest Desktop Build 1.4.93


RomanZ
 Share

Recommended Posts

Hello RomanZ, thank you for taking time to respond to our problems :)

I can confimr no issue using "$" sign in folders name or files name, at least with my tests. But i do continue to have issues regarding the temporary "*.sv$" files that corrupt my files ;( Is there any chance that behaviour will be reported in the known issues so the dev could work on it ?

 

Thanks !

Link to comment
Share on other sites

Some GUI things:

 

I was wondering if it was intentional to restrict the minimum size of the window? On a netbook with 1024x600 as a resolution it is very annoying that the window can not be fitted in the screen.

 

The vertical scrollbar is not pinned to the right side of the window but to the rightmost columns right side. This makes you are unable to scroll vertically unless you are looking at the last column.

 

Last, 'action' column takes up a lot of space when it is really a context menu especially it's only displayed for the active row. Does not make much sense - at least now, not sure if you have any future plans ..

 

Also it takes up like 10 times longer to fire up the new interface sometimes it even hangs for a while.

 

On the bright side, I'm yet to experience any sync problems even between multiple android, a linux and a windows client and well, that's the most important I guess :)

Link to comment
Share on other sites

@eltopo

Update turned on for everyone. Just tested my Raspberry PI - it shows the notification that update is available.

 

 

 

 

I still don't see the update notification at my Raspberry Pi's webgui. The browsers I tried are Chrome 39 / Firefox 33 / Opera 25 and IE 11, on Windows 7.

 

The place I checked is "Preferences" / Settings dialog, it says "Version 1.3.109 Up to date". What else do I need to force btsync to check new version?

Link to comment
Share on other sites

In earlier 1.4.x builds, the minimum width you could reduce the UI window to was >768 pixels. As such, those using screens smaller than 769 pixels wide (i.e some Windows tablets in portrait orientation, etc) had the UI window overflowing the width of the screen with no way to reduce the width. In 1.4.93, the UI window can be resized to a minimum width 768 pixels. From what I can tell, however, the minimum height you can reduce the window to hasn't changed.

 

That's a fair point - and I agree, it would be much better to have the "Share" and "Three Dots" icons always visible on each row in the UI rather than just appearing on "mouse over" (this becomes especially important on touch-enabled devices)

 

The "row highlight" you refer to when you "touch" a row is the same affect as if you "mouse over" a row. The the current row remains highlighted as long as the mouse remains over it - this is essentially the same as a touch action - i.e. "touching" a row moves the mouse cursor to the current row where it remains in the same fashion a "mouse over" would.

Thanks GM - I still do not understand why the developers have decided to restrict the minimum size of the window - it seems there are MANY people out there like me who would want to shrink the window down but leave it on the desktop - your restrictions are stopping us do that.  It is OUR screen after all, not the developers and we all have our own ways of doing things - this decision is restricting that unnecessarily in my opinion.

Thanks for acknowledging my point about the menu on the right hand side - I look forward to seeing an 'improvement' here in future releases.

I understand the 'mouse over' but do not understand why when clicking with the left button of the mouse that the line highlighted with the 'mouse over' does not remain highlighted in the same way it does when touching on a touch screen - it is this difference in behavior with mouse click that I was reporting, not the 'mouse over' sorry if I was not clear the first time.  I (for one) would like to highlight a line with a click and leave it highlighted as other programs do, but I respect the fact that this is not like other programs and does not work in the same way - a shame really, as the whole point of Windows way back when it was introduced was to enable the millions (if not billions) of computer users to interact with their computers in pretty much the same intuitive way regardless of the program (sorry, app )  I do not believe this software is intuitive at all, and given the number of questions on the forums it looks like there a re quite a few others who agree.  In fact I would go so far as to say the new GUI actually makes it more complicated than it was (but again that is only my opinion)  

Lets hope the abundant feedback you are getting is digested by the developers - as I have said before, this program appears to solve a lot of issues for people needing/wanting sync services without the cloud.  If it were more user friendly I suspect there would be millions more using it.  Do keep up the good work!

Link to comment
Share on other sites

@zeropluszero

I've read whole history of your issue with "*.sv$" file. It looks pretty much similar to what other community members complain with MS Office - sharing violation when accessing temp files. We are working on the fix for this issue, though it is not there yet.

 

@fejese

Thanks for the constructive feedback - will deliver to designers!

 

@rockhill04

Could you please share more details? Is it ".conflict" duplicate files or something else?

 

@eltopo

There is an issue in 1.3 WebUI client - it does not connect to update server. This bug was fixed in 1.3. Please update manually.

 

@daishi4u

Maybe I was too brief. I wonder, what makes you think that something is missing in size calculation? How do you determine it prior to comparing to one shown by Sync?

 

@colinabroad

Thanks for the feedback. Can't promise any changes now. As for touch screens - it leaves highlighted because you tapped there and the "mouse" actually hovers on Win8 platforms where you tapped last.

Link to comment
Share on other sites

Hi, this is my 1st message in this forum.

 

I created a login just to ask something really important to me and almost everyone who lives in Brazil / speaks portuguese.

 

In this topic is written:

 

"Known Issues in 1.4.92: (...) - Files containing certain characters in their names (such as accented letters) may not sync"

 

Is this issue solved? It can just broke every backup/sync system I've installed until today...

 

PS: I am using bittorrent sync as a sync plataform to my personal and business needs, and suggesting it to several friends. Read about this issue send a chill down my spine.

 

[ ]s

Dario

 

 

@dariomor

Unfortunately the issue is still there. I've added the known issues to the topic starter.

 

 

(...)

 

 

Thank you @RomanZ for your answer, but...

 

As I said, this issue can broke the sync & backup systems I am using.

 

And the description is not enough explained.

 

Is there a thread where this behaviour is clearly described? I want to know wich characters or situations can trigger this bug. This will help me decide if I will stick with BTSync or fly away.

 

Another important information is when it will be fixed. ETA?

 

[ ]s

 

Dario

Link to comment
Share on other sites

@RomanZ,

 

Thank you for the explanation.

 

Me and my users works on windows most of time, and latin chars like é, ç, à, õ and ô are used everyday to construct filenames. I am not sure if they are non-ASCII. In our specific ASCII Table they are all on upper ASCII... 

 

But all the sync schemas I developed I use at least one computer in cloud (cheap VPS) running Debian+BTSync to guarantee all time and fast sync of any file edited in any synced computer.

 

So, I am still afraid. "only with non-ASCII chars when syncing such files from Linux" looks like hits me directly!

 

Just hoping this week and the next one all my btsync installations, already upgraded to 1.4, runs correctly.

 

Until now I did not see skipped files on syncing.

Link to comment
Share on other sites

Why report the size if you don't know how to calculate it then?

Sent from my SCH-S738C using Tapatalk

 

Wrong folder size matters.

If you are syncing 100 GBytes data but BTsync reports only 10 GBytes you should check debug log to find what "improperly" named file is stopping your folder indexing ....

 

Question to developers:

Why base code on ASCII when we are on Unicode era since decades?

Link to comment
Share on other sites

Wrong folder size matters.

If you are syncing 100 GBytes data but BTsync reports only 10 GBytes you should check debug log to find what "improperly" named file is stopping your folder indexing ....

Question to developers:

Why base code on ASCII when we are on Unicode era since decades?

I know it matters, that's why I brought it up, read the previous part of the conversation

Sent from my SCH-S738C using Tapatalk

Link to comment
Share on other sites

Encrypted nodes don't sync with this version in Windows 7. Read only nodes sync intermittently with this version in windows 7. RW nodes sync once and then report as synced whether or not this is true. RW nodes report "locked" files even if there are no files open on either machine. All types of nodes report the wrong size depending on the weather and the cycle of the moon. "Sync status" reports no peers when "peers" reports 2 of 2. I could go on...

Link to comment
Share on other sites

@RomanZ Thanks for acknowledging the problem. Any ETA on the next version? Is it worth trying to roll back to 1.3 until then?

 

Edit: I'm aware that 1.3 and 1.4 aren't compatible and I would have to resync. Is it worth resyncing all that data or is the new version coming out in the next couple weeks?

Link to comment
Share on other sites

@RomanZ Thanks for acknowledging the problem. Any ETA on the next version?

Please see RomanZ's previous posts in this thread:

 

ETA for build is still vague - see my previous post.

...and said previous post:

 

We plan to fix it next week, though I'm still can't guarantee the ETA.

So, therefore, it's likely that there will be a new build this week - but that's not guaranteed, as there's no public roadmap/release schedule whilst Sync remains in Beta.

Link to comment
Share on other sites

Found new problem with latest version (didn't noticed it in previous 1.4.72 or 1.3):

[20141029 00:27:24.327] SF[AAC7]: Error downloading file IMIT_Files/cache/weather.cache.59: WriteToDisk: Permission denied

CentOS 6.5, x86, BTSync running as nobody, sync as readonly with "rewrite any changes". All sync forlders are writable, disk isn't full, file already exists and seems like there should be no issue to replace it (owner: nobody, writable). Any ideas? :)

 

At the same time on "master" server:

[20141028 23:31:49.977] FC[AAC7]: LoadTorrent: wrong number of pieces for file /vhosts/***.com/IMIT_Files/cache/weather.cache.59 without metadata, resetting it

P.s. By the way, what does it mean (CentOS 6.5 x64):

PnP: Device error "http://192.168.0.30:2869/upnphost/udhisapi.dll?content=uuid:9b431f51-59fa-4906-96a4-9119d0ece586": (-2)
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share