RomanZ

Latest Desktop Build 1.4.93

Recommended Posts

Hey @b0rman,

 

The "permission denied" is pretty straightforward error, though counterpart on another peer looks really suspicious. I suggest sending your debug logs to us so we can inspect it thoroughly. 

Share this post


Link to post
Share on other sites

Hey @b0rman,

 

The "permission denied" is pretty straightforward error

 

Actually I can't see any issues why there is a "permission denied" issue. Can You figure it out?

Share this post


Link to post
Share on other sites

@b0rman

I mean - usually permission denied means that user which runs sync simply can't write file to a folder as OS restricts that (either folder belongs to a different user, or current user has no write permission).

Share this post


Link to post
Share on other sites

@b0rman

I mean - usually permission denied means that user which runs sync simply can't write file to a folder as OS restricts that (either folder belongs to a different user, or current user has no write permission).

Usually - yes. But problem is that it was OK on 1.3.x and 1.4.x older versions. BTSync is running as nobody:nobody, files and folders owner is nobody:nobody, it's writable and if I'll delete files with such problems, they will be created (synced) again and everything will be OK. But after couple of minutes or hours there will be new (same or another) files with same problem.

Share this post


Link to post
Share on other sites

@b0rman

Yep. I suspect that second log and the messages that happen nearly same time can be the key to your issue. That's why I need your logs from both peers.

Share this post


Link to post
Share on other sites

Actually I changed version to older one and delete all my shares but getting same issue with out of sync but without errors about permissions and so on. Plus I got same problems on my Windows machines in local network :( Have to investigate it.

 

For now i found that when I add new RO share, it starts to index it and freeze after couple of megabytes. When I restart bysync it try to index it  again and freeze again but after more megabytes. And so on...

Share this post


Link to post
Share on other sites

OK.
1st: I found that if there are files with some kind of ~ and $ in name - it will cause "Out of sync" on Windows. But it can't explain why files like WRL2260.tmp can't be synced.
 
2nd: If I'll try to sync data to RO share with "changes rewrite" - it will cause "Out of sync". Seems like it can't index files on RO share. Debug log seemse OK, but such index doesn't increase synced files size:

[20141029 17:36:26.081] SF[299F]: Torrent /vhosts/xxxxx.com/IMIT_Files/jquery/js/ui/i18n/jquery.ui.datepicker-bg.js status:137 error:<NULL> meta:1 conns:0 io:0


As for me, RW insted of RO can fix 2nd issue case. It's a bit risky for me, but OK for now.

1st issue isn't critical (jusy annoying "Out of sync"), because all other files seems to by synced good.

But waiting for a fix, of course.

Share this post


Link to post
Share on other sites

OK.

1st: I found that if there are files with some kind of ~ and $ in name - it will cause "Out of sync" on Windows. But it can't explain why files like WRL2260.tmp can't be synced.

Have you checked what exclusion rules you've currently got in your .sync\IgnoreList file?

Share this post


Link to post
Share on other sites

Have you checked what exclusion rules you've currently got in your .sync\IgnoreList file?

 

Default. Didn't ever change it on windows (1st noticed on Windows only, didn't check it on Linux nodes)

 

UPD: OK, I see, somehow there are different IgnoreLists on my Windows machines. Same IgnoreLists fixed 1st issue, thanks!

.DS_Store.Spotlight-V100.Trashes~*ehthumbs.dbdesktop.iniThumbs.db._*

vs

* Out of sync state here

.DS_Store.DS_Store?._*.Spotlight-V100.Trashesehthumbs.dbdesktop.iniThumbs.db

BTW, 2nd issue i noticed on 1.4.93, then I downgrade to 1.4.92, 1.4.83 and 1.4.72 (that one worked before without an issue or I just didn't notice it) but got same problems even when I totally reinstalled every version.

Share this post


Link to post
Share on other sites

@b0rman

The RO share with enabled option "Overwrite files" can cause out of sync state only if it does not accept some files - like xattrs or something liked that. What are the OS involved?

@rockhill04

This usually happens when remote PC does not download the data by some reason. I suggest checking next things on your PDSSERVER:

1) free space

2) ignore list (if any of files from Mac on screenshot are gets ignored

3) if PDSSERVER is RO peer - check the "Overwrite changes preference"

Share this post


Link to post
Share on other sites

@b0rman

The RO share with enabled option "Overwrite files" can cause out of sync state only if it does not accept some files - like xattrs or something liked that. What are the OS involved?

 

 

Linux, CentOS 6.5. Any solution?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.