russelltechnology

Disable Auto-Update

Recommended Posts

Does anyone know of a way to disable the auto-update feature via api, I know how to change most other settings but haven't found a variable for this yet. I have had issues with the auto-update in the past and know that when I have the GUI turned off I don't have to worry about it prompting users so that is my work around for now.  Thanks in advance. 

 

I have looked around but have not been able to find anything thus far, so I apologize if the answer is already out there.

Share this post


Link to post
Share on other sites

@timmah87

Well, config file might not have API key - then Sync will simply run in config mode - and still you can use the parameter to prevent auto-update. 

 

As for the crash - sounds interesting. Could you please share your config file (pad only secrets, please)?

Share this post


Link to post
Share on other sites
{

    "check_for_updates" :  false,

    "storage_path" : "C:\\Program Files (x86)\\BitTorrent Sync",

    "use_gui" : false,

    "webui" : {

        "listen" : "127.0.0.1:####",

        "login" : "btsync",

        "password" : "##",

        "api_key" : "##"

    }

}

 

I just retested it and the initial load doesn't crash on version 1.4.75.0 (subsequently crashes on 1.4.103.0). Will put debug.txt in there and test again.

Share this post


Link to post
Share on other sites

@timmah87

use_gui relates to UI in separate window, it does not prevent WebUI - and notification in webUI. Looks strange. Did you have a chance to collect dump?

 

Wait for a second with dumps - there is something suspicious in your config. Why do you save data to program files? It is very likely UAC will prevent Sync from writing data there. Try to move storage to another location.

Share this post


Link to post
Share on other sites

My conclusion after mucking around with it today, "check_for_updates" flag or not, 1.4.103.0 doesn't like being in a Windows service. I have dumps, would you like me to email them to support?

Share this post


Link to post
Share on other sites

@timmah87

Yep, mail dumps - we'll take a look. Though my bet is that sync gets "Access denied" somewhere. Please try moving storage to some less protected location.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.