frank@btsync

[Solved] Windows File With German Letters Not Synced

Recommended Posts

Hi,

 

maybe I'm using an exotic constellation :(

btsync is running in ubuntu vm, this vm is using files from an old xp vm (on same laptop), filesystem NTFS

btsync should sync this data to other ubuntu systems and an raspberry pi

Now I noticed that all files using german letters (äöü...) are not synced :angry:

If I rename one of this file not using german letters file is synced immediately.

 

I read this hint on support page:

 

Syncing between different system encoding. Check if the file names have any special symbols and check that the files are in UTF-8, the encoding that Sync understands

 

Ubuntu can use this files and filenames without any problem, why btsync agent can use this file for syncing, running on same ubuntu system?

Files with german letters and hosted by an ubuntu system on EXT filesystem, can synced without any problems

 

How can I sync files with german letters from NTFS from my old xp vm?
Should I ran btsync agent on xp for this files? Will this help for german letters?

If this help, how can I reuse read+write-key on xp system from my ubuntu vm? I can't use xp as another peer, because ubuntu and xp using same directory !!!

I don't want to create a new key and delete old peer connections, which will have to resync again all other peers :wacko:

 

any help is welcome

 

Frank

Edited by frank@btsync

Share this post


Link to post
Share on other sites

 

Sync works with UTF8. There is an issue in Linux filename validator which caused Linux client inability to sync non-ASCII chars. It is fixed for now, so it should be available in next update. ETA for build is still vague - see my previous post.

 

ok, thanks for the hint

hopping for soon ETA

 

for me a critical bug :wacko:, if not all files are synced and no error seen anywhere

actually a death sentence for any sync software :ph34r:

Share this post


Link to post
Share on other sites

thanks for the info, hoping for the release-software!!!

 

...same issues here. Verified with Linux/Ubuntu 14.04 and Linux/QNAP, too.

 

I think, this is broken by design since filenames and paths do not have an encoding; the OS only deals with sequence of bytes. Individual applications may choose to interpret them as being encoded in some way...

 

it's not allowed, for my opinion, to assume, filenames could/should/etc be in "UTF-8"-encoding.

 

The only not allowed-byte-Value in Filenames is NUL, isn't it?

 

---

 

Impossible to use btsync for any data until this is fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.