RomanZ

Latest Desktop Build 1.4.103

Recommended Posts

Dear community,
 
Sync 1.4.103 is now available on download site. Here is direct link. It is NOT available via auto-update yet, but a direct candidate for auto-update. This build is candidate for auto-update.
 
Change log:
- Fixed issue with files not syncing ("out-of-sync") in some cases. 
- Fixed issue with sync preventing some apps (MS Office, Autocad, etc.) from saving files into synced folder.
- Added "/webui" command line parameter to run WebUI on Windows in default browser.
- Fixed issue with older files replacing newer files in some cases
- Fixed issue with blank UI caused by corrupt settings
- Fixed command line validation
Previous public build (1.4.99) change log can be found here.

Important Notes on Sync 1.4
Downgrade to 1.3 is not possible after installing Sync 1.4.
(If you wish to downgrade - please uninstall Sync removing all settings, then install 1.3 and configure all folders from scratch)
 
Important Notes for Sync 1.3 Users
Windows XP and Server 2003 clients using Sync 1.3.x will not receive auto-updates to 1.4, but can still update to 1.4 manually.
 
Known issues
- UI is tiny on high resolution displays [Workaround]
- Sync may continually re-index SMB shares [Discussion]
- Renamed files are logged as New Name → Old Name (instead of Old Name → New Name) [Discussion]

- Checkboxes once selected may move out of alignment on OSX Yosemite [Discussion]

- Sync icon may not update when switching between light/dark themes on OSX Yosemite [Discussion]

Share this post


Link to post
Share on other sites

Same problem with OUT OF SYNC as on previous versions for me. No luck :(((((((

Same files, same shares, same sizes, fresh install - Out of Sync on same place.

 

UPD: OK, it synced but it took plenty of time to sync and it was always "Out of sync" state. Will test it for sure! :)

UPD2: It took hours to index/sync 100MB on RO node - useless update for me :(

Share this post


Link to post
Share on other sites

Hmm, so it seems possible that starting btsync with the new /webui parameter and then wrapping the program in a Windows service gets us past the finish line on running AND managing btsync under Windows without having an active user session; or are we still missing a component here?

Share this post


Link to post
Share on other sites

So far no out of sync for me. i have 19 files all pdf that are no syncing. we have 7 peers. all updated.

i have ask the sourve of those 18 files.. to remove them and then re add them in 30-40 minutes to see if they sync

 

Folder 1 is 102 gb - 7 peers

Folder 2 is 33 gb - 5 peers

Folder 3 is 21 gb - 2 peers

 

I will test tonight with CAD to see

 Do i need to add the exemption of .dwl and .dwl2? is it necessary with this built?

Share this post


Link to post
Share on other sites

To quote Professor Farnsworth „Good news, everyone!“.

 

The encrypted share synced just fine after an update of all Clients to the new version. All I had to do was to stop BTS and install 1.4.103 over the existing installations.

The only odd behaviour I noticed was that out of 5 Clients, 2 did nothing after starting the Bittorrent_Sync.exe to update. Upon investigation I discovered that the EXE used 0% CPU and in both cases 220K RAM. I had to kill the process and another launch installed BTS just fine.

This is looking good!

Share this post


Link to post
Share on other sites

So far no out of sync for me. i have 19 files all pdf that are no syncing. we have 7 peers. all updated.

i have ask the sourve of those 18 files.. to remove them and then re add them in 30-40 minutes to see if they sync

 

Folder 1 is 102 gb - 7 peers

Folder 2 is 33 gb - 5 peers

Folder 3 is 21 gb - 2 peers

 

I will test tonight with CAD to see

 Do i need to add the exemption of .dwl and .dwl2? is it necessary with this built?

 

How is the speed? Mine is extremely slow. CPU usage is low on any node, same as Ethernet link and HDD.

It took hours to index/sync 100MB on slave node!!!

Share this post


Link to post
Share on other sites

OK, now I have "Out of sync" not even on RO shares but on RW also!

I took 2 nodes and share 8 folders: 4 RO, 4 RW. I set up share IPs manually, disabled LAN discovery, DHT, relay an so on.

After restart for couple of second everything is great, speed is OK and state is "receiving/sending" but than speed goes down and everything is "Out of sync". Logs are absolutely the same as I posted on "Out of sync" issue tread.

Also sometimes it's "No peers" state and then, in a second, "Out of sync" :(

Also lots of "[20141112 00:55:54.404] TorrentFile: unloading torrent by timeout
[20141112 00:55:54.404] TorrentFile: unloading torrent by timeout
[20141112 00:55:54.404] TorrentFile: unloading torrent by timeout
[20141112 00:55:54.404] TorrentFile: unloading torrent by timeout
[20141112 00:55:54.404] TorrentFile: unloading torrent by timeout
" errors in log (non-debug) on slave

Share this post


Link to post
Share on other sites

Also found that:

1. If totally delete share folder from RO node (remove files) and try to sync from scratch than everything will be OK. But if after such sync You'll delete share from BTSync on RO node and will try to sync it from master to same folder - it will be Out of sync.

 

2. If there is one share with "real" Out of sync then all other "good" shares will be Out of sync at the end. If You'll delete that "real" Out of sync share, than other "fake" Out of sync folders will sync OK in a couple of minutes/seconds.

 

3. http://forum.bittorrent.com/topic/32511-use-predefined-hosts-not-working/

 

4. Sometimes there is "Pending request" when trying to add new share on slave. But there is no request on master. So You have to delete share from slave and from master, re-index on master and re-add it on slave. 100% I got it if I set predefined hosts.

 

About 1 and 2: Seems like there is limited number of file sync slots (it was 100 in previous versions and 180 now) and if every slot used by "bad file" that can't sync for any reason (or without it like in 1.4.* :( ) than there will be Out of sync error on any share folder.

If slots count is more that "bad files" than those "bad files" will be set to another slots after timeout and everything could be OK - that's why Out of sync problem sometimes can be solved  after lots of hours of wait.

 

Also there is a temporary (for couple of seconds) Out of sync state when file with other than btsync process owner appears.

 

BTW!!! Noticed such error in log:

[20141112 02:59:50.615] 31.42.4x.xx:45039: did not pick any blocks. blocking peer temporarily

[20141112 03:00:30.644] 31.42.4x.xx:45039: did not pick any blocks. blocking peer temporarily
 

This IP is set as my master node on slave node shares. So if You'll block it, than it can cause "Out of sync"!

 

 

OS Linux, CentOS 6.5. Master x64, Slave (RO) x86

Share this post


Link to post
Share on other sites

@b0rman

 

1. Make sure that RO peer has "Overwrite changed files" preference set. If it is off and you delete / modify files - RW peer will go out of sync, this is known case.

 

2. Sounds logical. There is some file that cannot be transferred on "real out-of-sync" that can't be transferred that makes other out-of-sync. I need debug logs to find out what is the file.

 

3. Does your route table routes predefined hosts IPs outside of VPN channel?

 

4. This indicates connectivity issue. Peers need ability to contact directly to approve / decline requests. If request is not coming / can't be approved - root cause is definitely inability to connect.

 

@rockhill04

You can put temp Autocad files into ignoreList to prevent them syncing, though Sync should not prevent Autocad from saving files in .103 build.

Share this post


Link to post
Share on other sites

1. Yes, "Overwrite changed files" set

2. OK, may I'll send logs soon

3. Yes. VPN channel is set to connect to local IPs only.

4. Why? At same moment ping is stable, speed with simple scp (rsync) is 25Mbps and more.

Share this post


Link to post
Share on other sites

Hi,

 

 I have some suggestions/issues:

 

1. FreeBSD: See attachment. This messages don't dissappear, even not after some restarts.

 

2. All releases: In the gui there is shown a date of synchronisation named "Synchronisierung-Datum". When I click on the peers-Link, there is also some information shown with the same name "Status Synchronisierungs-Datum vor xyz Stunden". When this should be the same information: There are different informations shown. I think, it shows the last connection and it should renamed to "Letzte Synchronisation vor xyz Minutes/Hours".

 

3. Android: "Kollegen" should be renamed to "Peers" as in the other releases. (My "colleagues" (in german: "Kollegen") work togeather with me at my workplace. ;-))

 

4. Why is there no phrase like "6 of 7 peers"?  This is inconsistent.

 

5. Concluding: Why can't I get information about the other peers like on the releases of other operation-systems? This is inconsistent.

 

6. What does "Nicht synchron" mean to me? I'm waiting a lot of time but this status does't change to "Synchronisiert". (Do I have to do something?)

 

7. I have some Apps that show me, that my Android-device is getting hotter. It consumes to much processor-time while using Bittorrent Sync.

 

8. It would be very useful to see the used IP and port in the menu "Identitäts-Details".

 

9. A button to force syncing (for all devices) would be preferable.

 

10. As you see, I have a complex network of peers. How can I be sure to have the same amount (and up-to-date) files on all my devices? The information about the size of *all* files and the green status-icon is not sufficient. An access to a database-extract, where only the *differences* between the peers (files with different file-sizes, file-dates etc.) are shown would be helpful. 

 

11. Debian 6 32 bit, FreeBSD 64 bit: When I look a folder ("Austausch") at the windows 7 32-bit release, I see a peer (SyncNode EU1) shadowed, because its offline.  The same peer on debian 6 and FreeBSD 64bit is not visible at all. But: An other folder (Mobil) is shown by the same releases as shadowed.

 

12. The new web-interfaces (1.4.x) are so slowly.

 

13. There is no tool-tipp for the bell icon shown in the upper right corner.

 

14. Some weeks before I reported some issues with files with german umlauts ("öäüÖÄÜß"). (Other users have reported something similar with special file-names or file-types.) How have you ensured, that these problems don't exist anymore? If you have made some testfiles, I would like to get them to test the situation in my complex environment.

 

15. The colums are configurable, but these settings are forgotten (after Browser-restart?) in Debian and FeeBSD. (It hat nothing to do with a restart of the applications.)

 

 

 

Greetings,

 

merlinuwe

post-29402-0-83968800-1415806495_thumb.j

Share this post


Link to post
Share on other sites

I do find this release a little bit slow too ...

Also, i'm not sure the temporary files are totally fixed ? As i try to save a file (let's say 500 Mo) at the same time the Sync is syncing it,

the temporary *.sv$ file fail to write the *.max file resulting in destoying the original file ...

Share this post


Link to post
Share on other sites

it is like it has a timer on some files... in my case with CAD, i have excluded dwl and dwl2 on the ignore list. but the dwg takes a little longer to sync. 

i had to reset one of the peers and load one folder from scratch....for some reason that computer had the most syncing problems. i will see how it performs today and relay feedback.

if logs are needed, let me know.

Share this post


Link to post
Share on other sites

@rockhill04

Well, we've found and fixed not all of the "not syncing / out of sync" issues, only one. Can I get debug logs for analysis? Super slow is very likely just results of inability to sync.

 

@zeropluszero

A bit slow - the UI you mean or sync speed? Temp file are fixed in terms that Sync does not open them and should not prevent the app  to write data to it. If you want them to prevent syncing - add to IgnoreList.

 

@merlinuwe

#1. I confirm the bug, reproduced in my lab. Will fix eventually.

#2-3. Ok, I'll let localization team know - thanks for noting.

#4-5. I guess you mean that for Android? It is not implemented yet.

#7. Encryption and hashing are pretty heavy operations for ARM CPU - and can load it while indexing files or sending them to other peers. Was it inadequate hot (like, heating when being idle) - or Sync was working actively?

#8. Makes sense. We'll consider it for future releases. 

#9. No button needed. Just imagine that Sync is pushing this button all the time.

#10. If peers are different - it won't be green check mark. At least out of sync (of course, if Sync is aware of it).

#11. Did not get it. Could you elaborate?

#12. We are working to make the web-interface lighter and faster.

#13. Confirmed. Will fix.

#14. Our QA tested it thoroughly in 1.4.103 - test included  German, Japanese, Chinese and bunch of other languages.

#15. We'll see if it can be addressed. 

 

And - big thanks for such a detailed feedback!

Share this post


Link to post
Share on other sites

@ RomanZ, my temporary files *.sv$ are on the ignore list and are not synced. But as i wrote earlier, when Sync is syncing a *.max file (usually a big one, taking time to proceed), rewriting that very file produce a software error, it cannot rewrite the sv$ to max, and destroy it.

That would be great if sync had a way to prevent this as this scenario happens frequently !

 

(Regarding the slow sync, i meant the sync process, not the UI, it takes times to find a modified file and sync them after, maybe like Rochill04 said )

Share this post


Link to post
Share on other sites

@RomanZ

 

4.-5. (yes)

 

7. Bittorrent Sync is working actively but does not get ready with syncing in an appropriate time. It shows "Kollegen 5, Nicht synchron" (I waited hours for synchronizing 3,83 GB of data. And also the syncing of a small folder with 22,42 MB is waiting the same long time. But there is nearly nothing to sync.) Sometimes, it gets the status "synced", but after a reboot of the device, the same long syncing process comes again. (The device is a Samsung Galaxy Tab 3 7".) Bittorrent Sync's energy save mode is "off".

 

My other devices see 6 and 7 peers in opposite to my android, which sees only 5 peers.

 

On the other side, the speed of indexing is ok. It indexes from time to time for a few seconds and after this the state "Kollegen 5, Nicht synchron" is shown again.

 

11. Sorry for my poor english. I give you some screenshots. In the file "Debian6 in Web 02.png" you see a red arrow which *shows* to "SyncNode EU1" (lightgrey). This server is only seen by my Webserver with Debian 6. The same Folder "Mobil" is on my FreeNAS, but this (LAN-)server doesn't see "Syncnode EU1" (but SyncNode EU2, witch is from the same provider).

 

[bTW: Also my Windows 8.1 32 bit installation of Bittorrent Sync doesn't show "Syncnode EU1".]

 

 

15. (For me, it's easyly reproducable).

 

 

New: Android shows for "Kamerasicherung" (camera backup) "Kollegen 0, Synchronisiert". (How can Bittorrent Sync know that, when it is not connected?)

 

For the translators of the Android release: After a comma, the word "synchronisiert" is written in small letters. Also write ", nicht synchron" instead of ", Nicht synchron".

post-29402-0-32236000-1415904011_thumb.p

post-29402-0-12538400-1415904012_thumb.p

post-29402-0-78962200-1415904012_thumb.p

post-29402-0-69198700-1415904013_thumb.p

Share this post


Link to post
Share on other sites

Hello Guys,

 

A few questions about this latest version:

 

1-About the swarm: now that peers have to be approved, will they upload from the entire swarm or only the device they are approved on?

 

2-I have sent secrets that didn't need approval but my peer ended up having to be approved nonetheless  Once approved it worked fine, so it seems we have to approve peers anyway. Missed something here?

 

3-Can we still make Encrypted RO secrets by changing the first letter? (It's on another thread for the previous version).

 

Thanks,

Mas73.

Share this post


Link to post
Share on other sites

this release seems miles and above the slowest I've used so far.

 

ubuntu 14.04 x64 machine running as the destination, with ~12 windows pc's syncing in accross the WAN via a static IP/port mapping.

 

the webui takes ~10 minutes to load, pc's are showing "out of sync", speeds that used to run at 1 MB/s (per client) are running at ~50KB/s, then dropping to nothing. Haven't seen one single file sync in since the update.

 

Any ideas what is going on?

Share this post


Link to post
Share on other sites

1-About the swarm: now that peers have to be approved, will they upload from the entire swarm or only the device they are approved on?

It's optional whether when sharing a link you require the device it's used on to be "approved" by you. You can share links/keys without requiring approval.

In the case where you are requiring approval, only once those devices have been approved by you will they then be able to access/share data from the folder you're sharing with them.

 

2-I have sent secrets that didn't need approval but my peer ended up having to be approved nonetheless Once approved it worked fine, so it seems we have to approve peers anyway. Missed something here?

You may have inadvertently generated/copied a link/QR code with the "Peers I invite must be approved on this device" option selected.

You can of course share keys the old-fashioned way instead by clicking a folder's preferences icon (3 dots) and selecting "Copy Read Only Key" or "Copy Read & Write Key" from the menu, instead of using the "Share" button.

 

3-Can we still make Encrypted RO secrets by changing the first letter? (It's on another thread for the previous version).

Officially, the generation of encrypted RO keys is currently only supported via the API, but as you indicate there are workarounds available to generate these keys without the API

Share this post


Link to post
Share on other sites

Hi All,

I upgraded yesterday to 1.4.103 and now I am still getting the locked files issue on main PC.  in fact it it currently reporting minus one locked file! There are no files locked at present and all files HAVE been synced to the second machine, so once again it is a UI reporting issue, NOT a sync engine failure.  I repeat my request from earlier posts to name the 'Locked files' in order that we can find them and work out why they are being reported as locked.  Would you like logs RomanZ/GM ?  as I think you think this is solved.

2 computers syncing two folders each ~130+Gb one win7 one win8.1 plus one small folder being (correctly) synced across the world to another win7 PC.  This is amazing software guys, so keep up the good work!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.