slco

Bt Sync Losing Files, Keeping Folders

Recommended Posts

I just copied a bunch of folders with files and folders with more files inside into my shared folder. Was alarmed to learn that once the shared folder sync'd with one peer, all the files disappeared but the folder structure remained.

 

Log files have lots of this:

[20141213 18:45:37.212] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/24.klix"[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.212] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34.motor protection.b" - 2[20141213 18:45:37.212] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34.motor protection.b"[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.212] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34a.motor protection.b" - 2[20141213 18:45:37.212] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34a.motor protection.b"[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.212] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34a.motor protection.c" - 2[20141213 18:45:37.212] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34a.motor protection.c"[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.212] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.213] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34b.unbal.protect.b" - 2[20141213 18:45:37.213] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34b.unbal.protect.b"[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.213] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34b.unbal.protect.c" - 2[20141213 18:45:37.213] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34b.unbal.protect.c"[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.213] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34c.pump.controlr.b" - 2[20141213 18:45:37.213] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34c.pump.controlr.b"[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.213] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34c.pump.controlr.c" - 2[20141213 18:45:37.213] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/34c.pump.controlr.c"[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.213] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/GE.logo" - 2[20141213 18:45:37.213] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/GE.logo"[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 deleted[20141213 18:45:37.213] TorrentFile: 0x000000010489a200 created[20141213 18:45:37.213] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/bup/1993/ClipArt.EPRI/.bb.wkshp.Scans/3:93/L24.solid.st.strtr.b" - 2

also:

[20141213 18:45:50.337] TorrentFile: 0x000000010092c200 deleted[20141213 18:45:50.337] ScheduledTask:ConnectMorePeers invoked:timer reason:LoadTorrent failed[20141213 18:45:51.343] TorrentFile: 0x0000000100949200 created[20141213 18:45:51.343] TorrentFile: Failed to create empty suffix for file "/Users/Shared/2013-4/2013-1099s.pdf" - 2[20141213 18:45:51.343] FC[7408]: LoadTorrent: failed to load torrent for file "/Users/Shared/2013-4/2013-1099s.pdf"[20141213 18:45:51.343] TorrentFile: 0x0000000100949200 deleted[20141213 18:45:51.343] TorrentFile: 0x0000000100949200 created

 and tail:

$ tail sync.log[20141213 18:50:16.880] saved history: 1002 events[20141213 18:50:16.903] SyncFolderScanner: Removing notifier "/Users/Shared"[20141213 18:50:17.004] SF[7408] [85FD]: peer lost[20141213 18:50:17.864] SyncFolderScanner: Removing notifier "/Users/me/Pictures/evo pics"[20141213 18:50:17.967] SyncFolderScanner: Adding notifier "/Users/me/SpiderOak Hive/LSL-Accounting/for zoho"[20141213 18:50:18.069] SyncFolderScanner: Removing notifier "/Users/me/SpiderOak Hive/LSL-Accounting"[20141213 18:50:18.173] SyncFolderScanner: Removing notifier "/Users/me/SpiderOak Hive/LSL-Accounting/for zoho"[20141213 18:50:18.174] SyncFolderScanner: shutting down working thread...[20141213 18:50:19.984] SyncFolderScanner: shut down[20141213 18:50:19.984] Shutdown. Saving config sync.dat

Any help here?

Share this post


Link to post
Share on other sites

@slco

The log entries you pasted indicate that Sync wants to sync files - but cannot find them. The end of log just demonstrates the graceful sync shutdown.

 

This information is not enough to find out what actually happened. I suggest checking next things:

 

1. What OSes are present in your mesh? Any windows?

2. Are files just "gone" or they were moved to .sync/Archive folder? If they are in Archive, it means they were deleted by Sync because other instance of Sync decided to delete them. Otherwise - they were removed by other app.

Share this post


Link to post
Share on other sites

Thanks Sync Support,

 

1. All Mac OS, in the most recent case using two Mac OS 10.8.5 and 10.6.8 -- aha, first clue. I thought they were both running 10.8.5.

 

2. On the 10.8.5 mac, there are several folders and files in .sync/Archive --I haven't compared the list there with the missing files list. On the older one, there's no .sync folder at all.

 

Think I'll go back up and upgrade the older Mac to something current and try again.

Share this post


Link to post
Share on other sites

@slco

Your Mac 10.6.8 is very likely the culprit. It has a major difference comparing to newer MacOS X: it has no notification mechanism to let Sync (or any other apps) know that files has changed. Sync behaves slightly different when change is detected by notifier or by folder rescan - and this difference sometimes might lead to issue you described.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.