JJMcKay

Deleting A File Leaves A 0 Byte File Of Same Name On The Other Device's Synced Folder

Recommended Posts

Whenever I delete a picture on my PC, it indeed removed on my Android device, yet a 0 byte file of the same name remains. The same occurs in the other direction as well i.e. if I delete a file on my Android device, a 0 byte file of the same name remains.

 

Has anyone else seen this behavior? Is there any way to fix it?

 

P.S. Yes, all of this is taking place in a synced folder I have synced on both devices using BitTorrent Sync.

Share this post


Link to post
Share on other sites

I'm having the same problem. My setup is three android devices on v1.4.63.0 and one win8.1 PC on V1.4.103, one XP PC on V1.4.103 and a raspberry pi server with 2tb hdd always on, V1.4.103.  

My setup has been running fine for the past year or so and I've regularly updated the software, however about a month ago I noticed the 0kB files appearing in my photo directories.

If I delete or move a picture on any of  my devices it is replaced with a 0kB file of the same name on all devices. The 0kB files are a pain to remove as they keep coming back. Strange thing is I just tried deleting a pdf file in a normal folder and this deleted ok and the deletion was synced to all of my devices correctly.

Yesterday I uninstalled Sync from all my devices and reinstalled it but the problem is still there.

Edited by nrgbod

Share this post


Link to post
Share on other sites

Hi RomanZ. I'm not sure what you mean by "Is the issue reproduction stable?"

 

 

I am running 1.4.103 and the bevavior happens consistently.

 

As for the mode of my Android device, it is a Galaxy Note 2 from a disconnected Verizon number that I essentially use as a small tablet with Wifi and with Airplane mode on.

Share this post


Link to post
Share on other sites

JJmcKay, by "Is the issue reproduction stable?", RomanZ essentially means "does it happen every time", which your reply would indicate that it does.

 

By "android mode", I suspect RomanZ means whether you're running Sync in "simple" mode or "advanced" mode (check via Settings -> Advanced within Sync)

 

A couple of further things that might help narrow down the source of your issue;

 

1) How many devices are you syncing this between? Another user, nrgbod, has reported a similar issue above, yet they're syncing between a multitude of devices. Is your issue present if you only have your PC and Android device connected, and nothing else?

 

2) Does this issue occur regardless of filetype (extension), or does it only occur when you delete specific filetypes on your PC?

 

3) If would probably be useful for the team to know what version of Android itself you're running?

Share this post


Link to post
Share on other sites

I've managed to narrow the origin of the 0kb files down to my Samsung Note 10.1 tablet running Android 4.1.2 with sync V1.4.63.0

When sync is running on this machine any move or deletion of .jpg files from any folder on any of my machines results in a 0kb file being created. When I turn sync off on the Note the 0kb files are not created on any of the machines.

My Samsung S4 phone with Android 4.4.2 and sync v1.4.63.0 with exactly the same synced folders does not cause 0kb files when it is switched on.

I also tested moving .doc, .pdf and .exe files when the Note Sync was running and 0kb files are not created unlike with the .jpg's.

Share this post


Link to post
Share on other sites

Upon further inspection, it seems to happen to just image files as nrgbod corroborates.

 

My issue is only between two devices: the pc and the note 2. I even disabled Samsung's built-in Gallery app. I'm afraid to uninstall it but I'll be getting a Nexus 6 here soon so we'll get to see if that might be a Samsung related issue.

Share this post


Link to post
Share on other sites

2. What is the mode of your android device?

 

Sorry for that. I meant "Name", the typo + text autocorrection made my question a bit cryptic. I have asked about the name as it reproduces only on certain subset of devices - and never pops up on others (for example, it does not repro on Galaxy Sx in my lab).

 

Thanks for reporting - I don't need any more data at the moment. If I'll need something else to debug the issue - I'll approach you.

Share this post


Link to post
Share on other sites

Just wanted to report that I've been having the same problem with a Samsung Galaxy Note running 1.4.63 and multiple PCs running 1.4.103.

 

Even deleting the files on the phone side only sometimes helps fix the problem.

Share this post


Link to post
Share on other sites

Same issue here. Problem seems to be since an update between October and the latest.

My devices:

Samsung Galaxy S2 and Note 10.1 2013 , both running on Jelly Bean

As explained by the OP moving images or deleting images on the hand held devices will cause several 0 B image files to be created once you start to sync with your Pc! Deleting these files manually doesn't seem to always work. Bitsync will just recreate them again next time you sync.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.