JoeJoomla

Cannot Resume Sync After 'out Of Sync' Message

Recommended Posts

Hi there,

 

I set up syncing for the home folder on a Mac OS 10.8.5 which is 117.3 GB in size. After 109.29 GB of transfer an 'Out of Sync' message appears. I can't seem to get it to finish this initial sync.

 

I've restarted the application on both machines. I've also restarted both machines.

 

Is there something else I can do to get this to complete?

 

Thanks!

Share this post


Link to post
Share on other sites

Update: Since I was concerned that the home folder wouldn't finish syncing I decided to do smaller folders which are inside the home folder. I picked the 'Music' folder and set it up to sync.

 

I left the original home folder in the sync list and all of a sudden it says that the sync is complete. There is a checkmark next to the folder on both machines but the folder size is listed as 109.29 GB. When I measure the home directory directly on the computer it measures 117.3 GB.

 

Now I am confused. What should I be doing here?

 

Edit: Shortly after I posted this, the receiving computer shows 'Out of Sync' message while the sending computer shows a checkmark in the status column.

Share this post


Link to post
Share on other sites

Update: (I guess I'm talking to myself here) I have another Sync folder that is 15GB in size that suddenly decided it is 'Out of Sync' I don't seem to be able to get that one going again.

 

Am I the only one with this problem?

Share this post


Link to post
Share on other sites

Not just you, I've got this problem.  About 10% of my folders have it.  I can delete the share and start over, but after a while it happens again.  This has been an issue with all of 1.4.xx for me.

Share this post


Link to post
Share on other sites

Thanks for your reply Journeyman.

 

I am deleting the smaller share and starting over. Since this is just on my LAN it's not a big issue but I need to know that I can depend on this system in order to continue using it.

Share this post


Link to post
Share on other sites

Hi There guys, This used to be a problem for me, but I am all sorted now.  The thing to do is to double check the actual file numbers synced - preferably with a different program (I use freefilesync)  and look for ALL instances of !sync across both computers (just use search in explorer)  With BTSync turned off delete ALL the !sync files you find (they are files created by BTSYNC as it does its work)  I would advise you start again from your one main computer and COPY all the files to the second one - then set up the sync and let BTSYnc do its work indexing.  From what I can gather you should not be syncing folders within folders across these two machines as you are already syncing the main folders - this I have been told could cause problems.  Its OK to sync a 'nested folder' to a different machine, but not to a machine where the top folders themselves are already synced.  I suspect you are not getting replies as these problems are well covered in the forum - you just need to know the right key words to find the threads! - good luck, its a great program underneath, you just need to get used to the way it works.

@journeyman - have you tried 1.4.106 ?  I have not had this problem since about 1.4.9something - but used to get it a lot with a three way syncs (I don't do any more than 2 way these days just in case)

Share this post


Link to post
Share on other sites

Hi There guys, This used to be a problem for me, but I am all sorted now.  The thing to do is to double check the actual file numbers synced - preferably with a different program (I use freefilesync)  and look for ALL instances of !sync across both computers (just use search in explorer)  With BTSync turned off delete ALL the !sync files you find (they are files created by BTSYNC as it does its work) 

...

@journeyman - have you tried 1.4.106 ?  I have not had this problem since about 1.4.9something - but used to get it a lot with a three way syncs (I don't do any more than 2 way these days just in case)

It's funny you mentioned FreeFileSync.  I bumped into that yesterday as I was looking into an alternative to BTSync for a LAN backup utility.  I really like it.  I have about 700GB that I was backing up with BTSync but by the time it all synced up, I'd get another "Out of Sync" error.  (Currently on 1.4.106 and had many of those errors.)  After several months of that, I am fed up.

 

In an effort to stay on topic, I still have a few WAN folders using BTSync that (currently) don't have the "Out of Sync" error.  I'll keep your post in mind for when those start to behave badly.  Thank you for the tip!

Share this post


Link to post
Share on other sites

Hi Guys,

As a backup I still use FreeFileSync as I am unable to make a three way sync work and I don't like the way BTSync creates a mesh of peers anyway - I would MUCH prefer a Master file set being linked to the slaves without the slaves linking as well, but as the mesh is a core part of the way BTSync works this is not likely to change.  It is great for some and good for others.  BTSync of course does its work in real time which is what people need for syncing (freefilesync does not yet work in real time to my knowledge) - I simply use BTSync to make sure my laptop and deck computer are the same at all times and I can switch work or play between the two seamlessly - the backup of those files is (and should be in my opinion) independent of the two working machines and therefore does NOT need to be meshed or backed up in real time.  It is interesting you are still experiencing the out of sync issues - did you get to try 1.4.10005 test version - this fixed these issues for me.  However, you have three times the size of data to sync than me - but then how much of it is changing all the time, I have files constantly changing throughout the day - and the software seems to keep up with it all (for me, so far!)

Share this post


Link to post
Share on other sites

I'm afraid the Out of Sync issue appeared for me again today for no apparent reason.  1.2KB, 7 files, no subfolders.  3 of 3 peers connected.  No !Sync files to delete either.  *So confused*

 

Not sure if the experimental build offer is exclusive, but if not I'd be willing to give it a try.  Just thought I'd throw that out there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.