slawson2000

0K And Disapearing Files...

Recommended Posts

We have a problem. Some of the files we have are disappearing. The file name is left, but the file shows 0k and it is empty.

I just did a search for empty files and found about 15 file that this has happened to.

Apparently, it appears that it mostly happens with files that are renamed or moved (cut and paste).

I think I have ruled out it being a single computer issue as the files have been added from different computers.

All computers (5 in all) are running the most current versions of BitTorrent Sync and all are running Windows 7 or 8.

I tried Customer Support after I could not find a similar issue in the forum. Apparently they no longer provide help, only to Pro and Ad-Free (not sure what that means).

Anyway, any ideas?

Share this post


Link to post
Share on other sites

I found that if the clocks are out of sync on two peers by more than 25s then a new file saved to the slower machine will get truncated to 0bytes. Perhaps you could check their clocks to rule that out?

Share this post


Link to post
Share on other sites

The clocks on all computers are set to auto sync to the same site. I thought there might have been an issue with one computer being on DSL instead of Cable, but it happens with files generated on that computer as well.

It seems to happen when either saving, renaming, moving, or copy/pasting the files... File that are there seem to stay, but I am not 100% sure.

Share this post


Link to post
Share on other sites

I tried Customer Support after I could not find a similar issue in the forum. Apparently they no longer provide help, only to Pro and Ad-Free (not sure what that means).

Now Sync team provides support to everyone. There was some confusion and you've submitted your case to BitTorrent Client app, not to Sync app. Later, when it was figured out, you were informed about it and your ticket was redirected to Sync team and reply was provided. 

Share this post


Link to post
Share on other sites

Helen,

This is somewhat true, I followed the links provided to submit my problem. After I received the initial response I posted here. By the time the confusion was worked out, I could no longer edit my posting.

For all others, it should be noted that the Sync team has found the issue and the fix will be coming out in a future update.

Thanks.

Share this post


Link to post
Share on other sites

slawson2000,

 

Thanks! 

As for the issue itself, to put if simply - in most cases the problem is caused by temp copies of the documents (where the app saves your editions when a document is opened and being edited). Sync cannot make friends with them :) 

Share this post


Link to post
Share on other sites

I have tried to include any and all temp files in my exclusions list. I thought that would have fixed it. Anyway, when is this fix coming out? It is destined only for the 2.0 crowd or will 1.4.111 get it as well?

Share this post


Link to post
Share on other sites

slawson2000,

 

causes that come from Sync's code were fixed in Sync 2.0. However, there might be some other reasons, which need investigating with logs and details on the problem. 

See the guide on Sync 2.0 for collecting logs 

Share this post


Link to post
Share on other sites

At the moment, I am on the shelf regarding 2.0. With the limitations on the new version (especially the number of folders) I am still trying to figure out how make it work for my data structure. I am not sure I want to restructure all my data just to use a program. Anyway, that is another issue.

So if the causes are not going to be fixed in the 1.4.111, what do I need to do to collect logs for the 1.4.111 and get it to the appropriate people?

Share this post


Link to post
Share on other sites

slawson2000,

 

This issue was analyzed and fixed in Sync 2.0 and cannot be delivered to 1.4 version anymore. Please try 2.0 to see if in your case the problem remained. Thank you

Share this post


Link to post
Share on other sites

I also encounter the same issue several times. The solution is to turn off BT Sync while you are working on that computer. Note pausing sync will not avoid this issue. You must turn it off completely.

 

If the issue happens, don't be panic. You can still find the original file from the ".sync\Archive" folder.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.