RomanZ

[Legacy] 1.4 Beta Desktop Build 1.4.111

Recommended Posts

Dear community,

Sync 1.4.111 is now available on auto-update or via direct link.

Change log

- Possible Out-Of-Sync issue fix*

- Minor core fixes

* The "Out-of-Sync" can only be fully fixed in 2.0 thanks to core changes introduced in 2.0. If 1.4.111 does not resolve your out-of-sync, upgrade to 2.0 is advised.

Important Notes on Sync 1.4
Downgrade to 1.3 is not possible after installing Sync 1.4.
(If you wish to downgrade - please uninstall Sync removing all settings, then install 1.3 and configure all folders from scratch)

Important Notes for Sync 1.3 Users
Windows XP and Server 2003 clients using Sync 1.3.x will not receive auto-updates to 1.4, but can still update to 1.4 manually.

Known issues
- UI is tiny on high resolution displays [Workaround]
- Sync may continually re-index SMB shares [Discussion]
- Checkboxes once selected may move out of alignment on OSX Yosemite [Discussion]
- Certain models of Android mobile devices cause deleted files to return with 0-size
- Sometimes Sync gets stuck with out-of-sync state [Discussion]

Share this post


Link to post
Share on other sites

The change from "Enter a key or link" to "Enter a key" makes no sense. A link is still accepted, but a user who finds that he can't get the normal link clicking to work is sure to be lost. As was my friend: I watched him click "I already have 1. 4" many times and Chrome simply did nothing.

 

I told him to try to paste it into "I have a key", but I would never have thought to do that if I hadn't seen it phrased properly in 1.4.106! Really weird to see this given that it's *keys* that are sort of phased out, not links.

Share this post


Link to post
Share on other sites

your statement Roman that you are not planning to make any more changes to 1.4 brings up the question:

do you still need feedback on 1.4.111 or should we all just give up on any further development of this version?

I am happy to continue to provide feedback - but there seems little point if all development is stopped and only V2.0 and on will be fixed from now on.

It also begs the question: Will 1.4.111 continue to work and be available for free or will it stop working (or the tracker servers for instance stop working) at some time in the future?

I suspect many would appreciate an honest and open answer to this second question - perhaps from epounds?

Thanks,
Colin.

Share this post


Link to post
Share on other sites

@rstarkov

Was fixed in 2.0.

 

@colinabroad

There are many changes in 2.0 comparing to 1.4 in terms of core and fixes. Majority of issues reported on forums and via app feedback were addressed in 2.0, so indeed it is unlikely that you encounter something new in 1.4

 

For the 1.4 - as it was mentioned by @kos13, we can't shut it down, it can work even without a tracker and relay servers. Existing tracker and relay are fully compatible to 1.4. Also, 1.4 will be available on syncapp.bittorrent.com for downloading.

Share this post


Link to post
Share on other sites

The Android APK on the direct link for this build is truncated and broken (I wonder if BTSync was used to copy it across ;)). Results in parse error when trying to install. Had to go to the direct link for build 110 to grab v1.4.65.

 

(Yes, I had to roll back coz, in BitTorrent Inc.'s infinite wisdom, they decided to destroy all the syncs I'd setup in v1.4 - including my mobile's backups - when it auto-updated to v2.0. Thanks for that. No intention of upgrading to v2.0 just yet / maybe never / might just ditch BTSync completely, as I have over 10 syncs on my main PC. Thanks again!..)

Share this post


Link to post
Share on other sites

Web UI on [Linux]  x64 doesn't work for email and link sharing, the qr code seems to work, but nothing happens using "email" or "link"...

Share this post


Link to post
Share on other sites

Does this latest build still have a check  box for  "Overwrite changed files" for RO files that have been changed on RO machine.  I can't seem to find that in this build.  Could you help me with this.

Thanks

Maxgle from CA

Share this post


Link to post
Share on other sites

I've reverted to 1.4.110 but there's a problem sending email shares. When a sharer who hasn't got BTS clicks to install it, it downloads version 2.0. Is there a fix or a workaround to download 1.4.110 instead?

Share this post


Link to post
Share on other sites

Hi

 

I think I have a long dated synchronisation misfunction, that seems to come and go, and that for the first time I can reproduce in BTSYNC 1.4.111 in relation with the Android application 1.4.65.0.

 

The appropriate place to post this comment is closed, but it seems to me that this behaviour may not be fixed in version 2.

 

Are you interrested in the description and the debug log?

 

In the positive could you tell me where to post them?

Share this post


Link to post
Share on other sites

@affinity

You have to copy links and keys manually in Linux due to poor integration with OS services.

 

@Maxgle

Yes, it has. Could you please send me a screenshot of your folder preferences?

 

@panoptes

We have a single server which translates https:// to btsync:// links - so when it gets the link it proposes to download latest version available automatically.

I cannot propose any simple workarounds here.

 

@mumen

What makes you think it is not fixed in 2.0?

Share this post


Link to post
Share on other sites

@romanz

 

I already posted this precise question that seemed to dissapear monthes ago, maybe with an upgrade, but it surprisingly came back, recently on an even stronger mode. It looks like it is a recurrent problem in BTS and you asked me the logs I come back today to give you because it is possible now. Considering the fact, from my readings here, that some people seemed to have the same type of problem in version 2, I don' have to search very long to emit my hypothesis, don't you think ? unleast, (I did not read the forum before posting since one or two weeks) this seemingly very complex behaviour problem have been solved since then, which is what you are going to tell me now, before answering me if you want me to cooperate with you to give a clue to a problem in version 2, even from a version 1. Right ?

Share this post


Link to post
Share on other sites

@mumen

The version 2.0 has a bunch of fixes directly related to out-of-sync issue, so the vast majority of OOS reports in 1.4 are note relevant to 2.0 anymore.

 

Although, it your logs are collected properly - it will be possible to identify if issue was fixed or not. I'll drop you a link to upload logs and will check if it was fixed.

Share this post


Link to post
Share on other sites

RomanZ, ok, I'm ready to provide you description and the 2 logs. Confirm, please the methodology

 

I turn on BTS debug mode, shut off BTS, restart it, reproduce behaviour, shut off BTS and then collect the "sync.log" and "sync.log.old" in ..\AppData\Roaming\BitTorrent Sync. Right ?

 

On the android, there is no possibility for a log, right ?

 

I wait for your confirmation and your link.

Share this post


Link to post
Share on other sites

@mumen

The link was sent already. Methodology is correct. For android just send a feedback and agree to attach debug logs (they are always at debug level). In android's feedback mention something that will help us to find it and link to your issue (forum topic link or your nickname would be enough).

Share this post


Link to post
Share on other sites

@RomanZ

You might want to have one more 1.4 release that performs a check against whether the current platform can run the latest version before taking them by the hand and leading them to download and replace their current, working version with something incompatible. Something like an OS version check. Such a test should also make its way into 2.0 in case it happens again.

Also, your download links in the 1.4 help pages have gone 404.

Mac OS X 10.6.8 on a MacPro1,1

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

@hugligan

Should be working fine (with minor cosmetic issues) on Yosemite. What exactly is not working?

 

@GJames

Well, actually Sync does checks if current OS is going to support 2.0 or not. So, Sync is only displaying update for Windows with core 6.1 and newer. Although. it seems that this is not true for non-supported OS X. Thanks for reporting, we'll fix it. This does not require client update, it is more related to the update server.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.