Sync 2.0 Supported Versions Of Windows


Recommended Posts

What versions of Windows does Sync 2.0 support?

 

I installed Sync 2.0 on a Windows Vista machine, but it is failing to sync.

Looking at the download page here, it only lists Windows 7 or later.

 

(Note: Sync 2.0 did install on Vista with no error messages.  If it is not supported, it should at least throw an error).

Link to post
Share on other sites

Can I take this to mean that Vista will never work for Sync 2.0 (and you need add a message to confirm that during an install attempt)?

 

@narold, the general feeling I get from the devs is "maybe we'll add Vista/2k3 support later".

 

As you may or may not be aware, when Sync 1.4 initially launched, that too didn't run on XP/Vista/2k3, but support was subsequently re-added back in.

 

I'm hopeful (although I haven't received any firm guarantees) that support for at least Vista and 2k3 will return to Sync 2.0 at some stage (XP is considered obsolete by Microsoft themselves, so BitTorrent could be forgiven for no longer supporting that particular OS, however in the case of Vista/2k3 these operating systems continue to be supported by Microsoft, and so it would make sense for Sync 2.0 to be able to run on these platforms just as earlier versions of Sync already do)

Link to post
Share on other sites

Hi

 

I get a not a valid win32 executable error on windows server 2003 trying to install 2.0.0.82.  1.4.0.x worked on server 2003 with the hack to use a different browser.  Is there any plan to have an executable that installs on server 2003 so we can upgrade all our installs?

 

Thanks

Link to post
Share on other sites

Its a big problem for our company in completing any upgrade.  We're very interested in using sync commerically but our master server would have to be our win2003 server.

 

If we go to a subscription, how will this affect our request to support 2003?  I've read that subscription support requests will be treated as a priority.

Link to post
Share on other sites
  • 2 months later...

@Mike2700

 

I had a similar issue except for me it's not the master server that is using Windows 2003 it's some of our clients .

What I did to fix the issue is not elegant but it's working great and is stable.

 

 

To Summarize:

 

In Windows 2003, using Virtualbox, I've built a VM with a minimal install of Debian.

Then in windows 2003 I've shared the folders needed to be synced with btsync.

In the VM I've mounted the windows 2003 shares.

I've installed Btsync and connected to the mounted shares and voilà!!

Btsync 2.0 is now working for windows 2003 or Windows XP -_-

 

Note that for some weird reason, this set-up is even more stable than using 1.4.111 with Windows 2003 :huh:

Link to post
Share on other sites
  • 3 months later...

Is it possible that Windows 2008 std (Non R2) isn't supported?

I am having these errors:

 

2015-09-14 16:27:25] SSLEH[0x0000000008233d80]: hello packet { share:A40523629553E1FD23E5D4B7FA2ACB88C95C40A8 } has been sent
[2015-09-14 16:27:25] SSPI[0x000000000ca82920]: Create SSPI encryption holder
[2015-09-14 16:27:25] SSPI[0x000000000ca82920]: Handshake: failed to acquire credentials handle, error - 0x80090331
[2015-09-14 16:27:25] SSPI[0x000000000ca82920]: Handshake: failed to acquire credentials handle, error - 0x80090331
[2015-09-14 16:27:25] PD[43E5] [5184]: Checking tunnel connection to peer, transport: uTP, endpoint: 10.10.244.130:47813
[2015-09-14 16:27:25] SSLEH[0x00000000080da8a0]: hello packet { share:A40523629553E1FD23E5D4B7FA2ACB88C95C40A8 } has been sent
[2015-09-14 16:27:25] SSPI[0x000000000ca821b0]: Create SSPI encryption holder
[2015-09-14 16:27:25] SSPI[0x000000000ca821b0]: Handshake: failed to acquire credentials handle, error - 0x80090331
[2015-09-14 16:27:25] SSPI[0x000000000ca821b0]: Handshake: failed to acquire credentials handle, error - 0x80090331

 

I saw those same error message on another post regarding Vista so that's why I wonder if it's the same with win2008 (non R2)

http://forum.bittorrent.com/topic/34644-upgraded-to-2x-nothing-works/?hl=%2Bhandshake%3A+%2Bfailed+%2Bacquire+%2Bcredentials+%2Bhandle%2C+%2Berror+%2B0x80090331

 

It's the first time I have to install btsync on a windows 2008 std (Non R2) so before I go further into my diagnostic I will need to know if it could be an OS incompatibility or not?

Thanks!

Link to post
Share on other sites
  • 6 months later...

I realize that a few people are also wanting this to work, but I have a server machine running Windows Vista.  I wanted to check this thread real quick to see if anything was ever done about making 2.x available for that platform?  I currently can't install it, is there a workaround to making it work?

 

Thanks in advance,

Kevin

Link to post
Share on other sites

Sorry, Sync 2.x is not available for Windows Vista. A list of supported operating systems may be viewed here.

The last version which could run on Vista was 1.4 Beta. You can sync folders from a 1.4 installation with a 2.x installation, although not all features/functionality will be available.

You'd therefore be highly recommended to upgrade your server to a more modern, supported, operating system

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.