Ckoo

Synology Nas Isn't Working

Recommended Posts

2.0.81 (from memory only) was working flawlessly on my Synology Cedarview devices.

 

2.0.85-1 works for a while and then crashes as a service.  Restarting the service restores service for a while but crashing has been consistent.

Share this post


Link to post
Share on other sites

Just installed 2.0.85 Cedarview on a DS1813+ and it started syncing the 2.0 folders right away.

 

I'll keep an eye on it for reliability, but it's looking good so far.

 

Thanks!

Share this post


Link to post
Share on other sites

After 2.0.85 successfully sync'd my two 2.0 folders today on the Synology, at some point it stopped working.

 

I tried to connect tonight, and got nothing.  I checked the package in Synology and the status was Stopped.

 

I restarted it, and it seems fine again, but based on the note by @linenoise, there may be a crashing issue.

 

I've turned on debug logging in case it happens again.

Share this post


Link to post
Share on other sites

I second that. I am willing to try test builds, or to verify that 2.0.85 really is not working on qoriq.

 

Any news for qoriq? Would like to use Sync.

 

Kind regards 

 

Alex

Share this post


Link to post
Share on other sites

Installed 2.0.85-1 on DS214 — Click BitTorrent Sync in Package center to set up and get message "Sorry, this package cannot be accessed when connected via QuickConnect."

 

Is there another way to activate and set up a remote Synology NAS? 

Share this post


Link to post
Share on other sites

Yes please: need help with qoriq build (of any version). I have a DS213+ on which I've been happily runnin btsync 1.4. But the upgrade to v2 series did not go well. Having tried both 2.0.85 and 2.0.81, I've seen the same problems:

 

- btsync hangs after a while. the web UI does not respond. I conifgured DS213+ to automatically reboot once a day.

- btsync only syncs with one of my two laptops.

 

To elaborate on the 2nd issue...

I have 3 defices: DS213+, Macbook and Ubuntu laptop. Each has 2 folders under the "default folder". Macbook and Synology seem to be in sync. The Linux laptop syncs with Macbook, but not with Synology.

 

Here's what I see in DS213+ log (/usr/local/bittorrentsync/var/sync.log):

[20150316 22:53:35.145] assert failed /mnt/jenkins/workspace/Build-Sync-Synology-213/TunnelConnection.cpp:286[20150316 22:53:35.146] assert failed /mnt/jenkins/workspace/Build-Sync-Synology-213/TunnelConnection.cpp:286[20150316 22:53:36.156] Incoming connection from 192.168.1.6:46698[20150316 22:53:36.162] Incoming connection from 192.168.1.1:56750[20150316 22:53:36.162] Incoming connection from 192.168.1.6:46700[20150316 22:53:36.165] Incoming connection from 192.168.1.1:56752[20150316 22:53:37.306] Incoming connection from 192.168.1.6:31267[20150316 22:53:37.331] Incoming connection from 192.168.1.6:31267[20150316 22:53:44.604] assert failed /mnt/jenkins/workspace/Build-Sync-Synology-213/TunnelConnection.cpp:286[20150316 22:53:44.605] assert failed /mnt/jenkins/workspace/Build-Sync-Synology-213/TunnelConnection.cpp:286

192.168.1.6 is my Linux laptop trying to sync. On the Linux side the log looks like this:

[20150316 22:37:13.062] Incoming connection from 192.168.1.5:30426[20150316 22:37:37.987] Disconnect: Timed out[20150316 22:37:39.288] Incoming connection from 192.168.1.5:30426[20150316 22:37:40.291] Incoming connection from 192.168.1.5:54330[20150316 22:37:40.993] Disconnect: Timed out[20150316 22:37:41.440] Incoming connection from 192.168.1.5:30426[20150316 22:37:43.000] UPnP: Device error "http://192.168.1.5:5000/ssdp/desc-DSM-eth0.xml": (-2) [20150316 22:37:43.291] UPnP: Device error "http://192.168.1.36:1400/xml/device_description.xml": (-2) [20150316 22:37:43.354] UPnP: Device error "http://192.168.1.24:1400/xml/device_description.xml": (-2) [20150316 22:37:49.478] Incoming connection from 192.168.1.5:30426[20150316 22:37:51.265] Incoming connection from 192.168.1.5:54332[20150316 22:37:51.268] Disconnect: Connection closed

192.168.1.5 is the Synology DS213+ NAS.

 

Please help.

Share this post


Link to post
Share on other sites

Today i've updated my DS213j to 2.0.93 (from 2.0.85) via "manual install" on the DSM. Now I have no more write-rights. What can i do?

 

afhn60.png

Share this post


Link to post
Share on other sites

Exact same situation here: manual updated DS112j (from bittorrentsync_88f6281_2.0.81-1.spk to bittorrentsync_88f6281_2.0.93-1.spk). Now Btsync UI status column shows "Don't have permissions to write to selected folder". 

 

Though: If I go ahead and start to "Add a folder", navigate to one of these folders (that Btsync has permission errors with), I can successully create a new folder in there (!). So I think it's not really a file system permission problem.

Share this post


Link to post
Share on other sites

Exact same situation here: manual updated DS112j (from bittorrentsync_88f6281_2.0.81-1.spk to bittorrentsync_88f6281_2.0.93-1.spk). Now Btsync UI status column shows "Don't have permissions to write to selected folder". 

 

Though: If I go ahead and start to "Add a folder", navigate to one of these folders (that Btsync has permission errors with), I can successully create a new folder in there (!). So I think it's not really a file system permission problem.

 

I found a workaround!!

 

  • "disconnect" (don't delete!!) the folder you sync in btsync.
  • stop "btsync" in the paket center.
  • Delte the ".sync"-Folder in the folder you want to sync
  • start "btsync" in the paket center
  • re-connect/re-add the folder you want to sync in btsync

 

everything's fine now here.

 

May someone test it, too?

Share this post


Link to post
Share on other sites

Hello all.

I'm on DS414 (armadaxp architecture). 2 weeks ago I updated BTsync 1.4 to 2.0.85-1 without a problem.

 

Today I tried to update to 2.0.93-1, but the package install failed.

I had to reboot my DS, after which the package center displayed that 2.0.93-1 is installed, but it doesn't run as it should (doesn't display the GUI).

 

Further attempts with 2.0.93-1 fail as well, reinstalling 2.0.85-1 gets refused.

Any ideas on how to get BTsync up and running again? Can I uninstall without losing my shared folders?

Share this post


Link to post
Share on other sites

Hello all.

I'm on DS414 (armadaxp architecture). 2 weeks ago I updated BTsync 1.4 to 2.0.85-1 without a problem.

 

Today I tried to update to 2.0.93-1, but the package install failed.

I had to reboot my DS, after which the package center displayed that 2.0.93-1 is installed, but it doesn't run as it should (doesn't display the GUI).

 

Further attempts with 2.0.93-1 fail as well, reinstalling 2.0.85-1 gets refused.

Any ideas on how to get BTsync up and running again? Can I uninstall without losing my shared folders?

 

 

I'm having exact same problem here. Unfortunately I saw your post 3 minutes after installing 2.0.93 >.<

 

°° Update

After waiting for a while, I restarted my Syno. I did it through DSM interface and it warned me that some installation was going but I forced it. After (long!) reboot, the package manager said version 2.0.93 was installed but web interface was not working. I had to manually start the package and now everything seems fine.

Edited by TheFlow

Share this post


Link to post
Share on other sites

I found a workaround!!

 

  • "disconnect" (don't delete!!) the folder you sync in btsync.
  • stop "btsync" in the paket center.
  • Delte the ".sync"-Folder in the folder you want to sync
  • start "btsync" in the paket center
  • re-connect/re-add the folder you want to sync in btsync

 

everything's fine now here.

 

May someone test it, too?

Didn't work for me. Still getting the same error, this time in the connect screen.

Share this post


Link to post
Share on other sites

Am I missing something here? 

I have been struggling with BTSync on my 6 PC's, 3 tablets & 10 phones for about a year - it seemed to be the BEST solution for my needs with V1.4 regardless of cost.  Finally gave up after the 2.0 release which has never worked for me and have purchased a Synology NAS.  This comes with software that syncs across ALL devices, albeit in a slightly different master/slave scenario (which I prefer), but it works.  Without any dramas.  On Apple, Android, Windows - across an office LAN as a network and across the World sharing files with several others.  Yes, you have to pay for the hardware and storage, but you have to do this for BTSync as well.  Why on earth would ANYONE want to use BTSync on a Synology NAS??? the NAS itself comes with software that beats BTSync EVERY TIME ! (unless of course you want to set up a mesh that you cannot rely upon!) I wish I had found this NAS a year ago, they are NOT expensive, even for home use, I was STUPID to think I could use the drives in my existing computers with BTSync to 'save money'  I only have 350Gb of data - for my entire business, it only cost me £300 to buy the NAS and 6GB of 2xRAID drives - insignificant compared to the subscription BTSync want for software that does not work!

I look forward to the 'torrent' of replies!!

Share this post


Link to post
Share on other sites

Am I missing something here? 

I have been struggling with BTSync on my 6 PC's, 3 tablets & 10 phones for about a year - it seemed to be the BEST solution for my needs with V1.4 regardless of cost.  Finally gave up after the 2.0 release which has never worked for me and have purchased a Synology NAS.  This comes with software that syncs across ALL devices, albeit in a slightly different master/slave scenario (which I prefer), but it works.  Without any dramas.  On Apple, Android, Windows - across an office LAN as a network and across the World sharing files with several others.  Yes, you have to pay for the hardware and storage, but you have to do this for BTSync as well.  Why on earth would ANYONE want to use BTSync on a Synology NAS??? the NAS itself comes with software that beats BTSync EVERY TIME ! (unless of course you want to set up a mesh that you cannot rely upon!) I wish I had found this NAS a year ago, they are NOT expensive, even for home use, I was STUPID to think I could use the drives in my existing computers with BTSync to 'save money'  I only have 350Gb of data - for my entire business, it only cost me £300 to buy the NAS and 6GB of 2xRAID drives - insignificant compared to the subscription BTSync want for software that does not work!

I look forward to the 'torrent' of replies!!

Hi. I've used the synology software for some time.

 

What you have is a lot of bugs, incompatibility between versions (upgrading is a nightmare) and a brutal usage of Server space. I have to manage a server used by 10-11 users, and after a while I had to give up with the (unnamed) synology software.

Also that software have almost no support at all. Go to the synology forums and enjoy the desperate cry for help of the other users.

Actually I'm testing the BTsync software in the 1.4 version (since the 2.0 don't work on qoriq) and even is is barely working at least is not buggy as the synology one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.