Set Webui Port On Windows For 2.0

Recommended Posts

How do I set the webui port for Windows for version 2.0? When I run an instance with /webui, it runs on port 8888. If two users run, it tries to bind to port 8888 twice, and the second one fails.

Share this post

Link to post
Share on other sites

You can set/change the WebUI port by specifying it in a config file, and executing Sync with that config file.
i.e. your config file should look a little something like this:

  "storage_path" : "/Users/<username>/AppData/Roaming/BitTorrent Sync",
  "webui" : {
    "listen" : ""

Save it as, and then execute sync with a /config <path_to_config_file> command line switch. You'll only need to do this once in order to import the new WebUi settings into Sync.

One final comment; running multiple concurrent instances of Sync isn't recommended or indeed officially supported.

Share this post

Link to post
Share on other sites

I'm using btsync on linux so I don't know how the config file situation is on windows, but on linux there is still a config file.

In that you have to / can set the WebUI settings (port, auth, ...), path for db storeage and other things.


What is not possible anymore with 2.0 folders is to config the shared folders themselves inside the config file.

If you set up folders inside the config file they can only be 1.4 ones and the WebUI will be disabled. That's probably what you read regarding 2.0 vs. config file.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.