Btsync 2.0 Gui Not Accesible On Freebsd X86_64#


Recommended Posts

i wonder if is just me, but i can't get the gui to work on FreeBsd X64. I'm trying to get btsync to work on Nas4Free, and yes i can get 1.x btsync version to work just fine.


what i can't get to work in 2x version, more precise the GUI doesn't seem to respond, my browser just waits for a response for a long time and nothing comes back.


here's what i did:


1. download the latest version of btsync 2.0 from just re-execute all these steps today (March 7, 2015).

2. untar and start using this command line:

 # ./btsync --webui.listen

3. everything starts up fine, i can see these things in .sync/sync.log


Link to comment
Share on other sites



Just tried to update 1.4 on my FreeBSD x64 box to 2.0 and can't hit the web gui no matter how I try.


I'm open to running a test build to see if it fixes the problem.


And I followed this topic so hopefully when I fix has been rolled out, Helen@ will ping this thread.

Link to comment
Share on other sites

GUI is working. But I'm unable to link the new device to my identity. After entering the key manually it says 'connecting...' forever. I couldn't find any suspicious entries in btsync.log. Also the log indicates that the device successfully establishes connections to other devices. I'll keep investigating.

Link to comment
Share on other sites

i was able to link the device just fine and i did transfer files without problems. one thing i _may_ have done differently is i started from scratch: deleted the old btsync install folder and configs (the .sync folder) installed the new version and added the device with my iphone

Link to comment
Share on other sites

I ended up creating a new identity in the BSD box and linking the other devices to this identity. It was a bumpy ride though. Sometimes linking didn't work with one device but with another. My Linux box wouldn't link at all in the beginning, then on the third round it suddenly worked. Activating my Pro license didn't work on the BSD box but later on the Linux box.


Right now everything seems to be linked and rolling. Fingers crossed.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.