Recommended Posts

My NAS (215j dsm 5.1) is woken up each 20 minutes by bittorrent sync (latest release 2.0).
 
I added to sync.conf  "config_refresh_interval", "config_save_interval" and "folder_rescan_interval" with high values but without effect.
 
After searching for a day in logs I found a pattern in the wake-up of the NAS and an error in the bittorrent sync.log. 
 
A few seconds after the following error (in the sync.log) the message "internal disk woke up from hibernation" is posted.
 
[20150311 22:26:38.156] UPnP: Device error "myIP:5000/ssdp/desc-DSM-eth0.xml": (-2)
[20150311 22:26:38.299] UPnP: Device error "myRouter:49152/description.xml": (-2)
 
What is causing this error and how could I solve this?
 
Thanx

Edited by alexx

Share this post


Link to post
Share on other sites

I´ve three months asking same...and nothing... 

 

My actually btsync.conf has agregated that 3 lines with 43200 interval, and NAS never sleep...I have to stop and play manually...a big shit..

 

If anyone could paste their btsync.conf ...

Share this post


Link to post
Share on other sites

Do you also have the upnp error messages? I have set my NAS to go to sleep after 10 min and it does. Only it seems to wake up after 20 minutes by bitTorrent sync.

Share this post


Link to post
Share on other sites

Hi All, Just wanted to ask if anything else was mentioned about this issue, I do have the same issue with Harddrive being woken up every 20minutes. 

 

Synology: DS215j

Version: 2.0.105-1

 

Starting to use BTSync more and more, but would really like hibernation on the internal HDD on Synology, Dont like wear and tear, 

Share this post


Link to post
Share on other sites

Dear all,

i have the same issue on 415play and 112j.

Folder_rescan_interval is set in the sync.conf and also in the gui, but each 10min i´ve got a refresh. This didn´t work in 2.3.3 and also in 2.4.1.

Please repair, otherwise it makes no sense.

mfg

NaCkHaYeD

Share this post


Link to post
Share on other sites

Dear RomanZ,

i am Standing at the beginning, so what i see is, i set Folder_rescan_interval to 86400, but inside the webgui, i see last synch 600s ago. This seems to me, that the Default Setting is used.

Anyway, i also set the other value to.

P.S.: if i open the Settings.dat via vi, i see my value 86400 inside, so something went wrong.

with regards

NaCkHaYeD

Edited by NaCkHaYeD

Share this post


Link to post
Share on other sites

@NaCkHaYeD It is okay. Note, that your NAS peer keeps connection to other peers that still DO have 10 minutes rescan interval. So if they notice some changes - they'll let your NAS know and do actual Sync (and, of course, wake up HDD). So your HDD will sleep if nothing is actually changing also on other peers.

Share this post


Link to post
Share on other sites

Dear Roman,

 

no other Peers doesn´t Keep Connection to me.

i installed the same Version of btsynch on both of my NAS Systems. Both are connected through a VPN Tunnel. On both Btsynchs i disabled "use relayserver", "use trackerserver", "search local lan". Only predefined host are enabled, where NAS 1 got IP of NAS 2 and NAS 2 got IP of NAS 1. So hopefully, i only have one bi directional communication through the VPN Tunnel.

If both btsynch running, everytime i got last synch after 10min, which seems to me, that my Setting of 86400s is ignored by the Default value of 60s

mfg

NaCkHaYeD

btsynch1.gif

btsynch2.gif

btsynch3.gif

Share this post


Link to post
Share on other sites

@NaCkHaYeD Settings look good. Disregardless to what UI says - does your NAS manage to hibernate its HDDs? If no - I can think of also disabling "enable_journaling" setting and writing "0" to debug.txt (you'll need to SSH to your NAS).

Let me know if all these measures allow your HDD to sleep.

Share this post


Link to post
Share on other sites

@RomanZ

Dear Romanz,

I have recently bought a DS216j and installed Sync 2.3.8-1. I have the same issue as NaCkHaYeD, dstroy, and others : disk of my DS never goes to hibernation when Sync is active (while it does when Sync is stopped). I tried all the settings on the page you linked (older_rescan_intervalconfig_refresh_interval, config_save_interval, md_update_interval set to 21600, enable_journaling set to false, and "Enable debug logging" unchecked) but that does not work, the disk still never goes to hibernation.

Hope you can help to fix this issue.

Thanks

Share this post


Link to post
Share on other sites

Dear Romanz,

did you also check the debug.txt. In my case, there was 8000000 instead of 0. This causes the hibernate failure at last.

At the Moment i am running the 2.3.7-1 Version of BTSync, on a DSM 5.2-5644 Update 5 (415play), DSM 5.2-5644 (115j).

I don´t really know at the Moment, if this is a normal, or a Special Version from April 2016.

with regards

NaCkHaYed 

Share this post


Link to post
Share on other sites

@Fran92

Put zero to debug.txt and restart Sync. If that doesn't help, then there's possible some files stuck and keep trying to get synced, see  sync queue in peer list - the might be some files in up/download queue. 

@NaCkHaYeD You can keep 2.3.7 if it works for you, it's ok. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.