Corrupted Files


zenxtang

Recommended Posts

I am having an odd problem with Sync version 2.0.85 (Win 7 Pro 64 PC to a Win 8.1 64 PC). I sent a client some files that were compressed in a multipart 7z archive, and they seem to have received a corrupted part. When they went to extract the files, two of the them would not exact. I have seen this happen before with bad FTP connections so I asked the to give me check the CRC for the files and the 7z part. 7Zip listed the files' CRCs correctly, but the part itself had the wrong CRC. I tested the file on my end and had no problem. I asked the client to delete that part so the new one would resync, by Sync still considered both sides in sync. I tried renaming it, but nothing more happened. I finally created a new archive with those files and that worked. A few days later same thing happened with different files. Having used torrents for years, I would have expected Sync to notice the mismatch and corrected the mistake. The debug logs don't show any out of the ordinary and I can't figure out how to reproduce the problem. This is clearly a bug that needs squashing, or a feature that needs to be added for all users, including the free ones. Any suggestions would be appreciated. Thanks.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.