teh_g

Sync Does Not Have Permission To Access This Folder

Recommended Posts

I recently upgraded from 1.4 to 2.0 on my Debian server box. When attempting to recreate my 1.4 sync folder in 2.0, I am getting the error "Sync does not have permission to access this folder".

 

I double checked, and Sync does have permission for this folder. The daemon is running as the same user it was in 1.4. If I make a 1.4 style sync folder, it appears to have no issue reading the data and no error is thrown.

 

Unfortunately this is my "target" box for some one way syncing from a remote host, so I need to be able to add the key from my remote server. Even using the 1.4 style key, it throws permission errors.

Share this post


Link to post
Share on other sites

I couldn't get this to work for read-only sync, either. Connecting to the folder using 2.0 version sync in a two-way mode works fine (clicking 'Connect), but for some reason when trying to connect to an existing folder using 1.0 version sync or using a read-only sharing link, I get the permissions error. Pretty annoying, as I'd prefer my backup device NOT to be able to sync changes back to the source device(s).

Share this post


Link to post
Share on other sites

teh_g,

 

I see you've created a zendesk ticket? 

 

If I make a 1.4 style sync folder, it appears to have no issue reading the data and no error is thrown.

 

Even using the 1.4 style key, it throws permission errors.

Sorry, I got confused. Do you mean that on your Debian:  if you add the folder (via "shift+add folder) on Debian, it doesn't show the error. But if you add this folder via 1.4 key shared from another peer, you see this error? 

 

@all, 

are the peers where you see the error linked to other devices as "my devices'? And you are adding 1.4 RO key through "manual" connection menu and right after you add it, you get the error? 

Share this post


Link to post
Share on other sites

I have the same issue here with my Ubuntu server 14.02.2. I just upgraded my old 1.4 installation to the 2.0.85 ( from http://debian.yeasoft.net/add-btsync-repository.sh ).

 

When I use the webui to the server, I can add new folder as long as it is a sub-folder under my directory_root-folder. I can also add any other folder (with proper permissions of course) if I use the "Add classic folder". But when I try to add folder which is not under the directory_root, I get an error message: "Sync does not have permission to access this folder" (same folder works when I use classic)

Share this post


Link to post
Share on other sites

I have the same issue here with my Ubuntu server 14.02.2. I just upgraded my old 1.4 installation to the 2.0.85 ( from http://debian.yeasoft.net/add-btsync-repository.sh ).

 

When I use the webui to the server, I can add new folder as long as it is a sub-folder under my directory_root-folder. I can also add any other folder (with proper permissions of course) if I use the "Add classic folder". But when I try to add folder which is not under the directory_root, I get an error message: "Sync does not have permission to access this folder" (same folder works when I use classic)

 

Hmm, I still have permission issues. I can't set the directory_root to the parent folder.

Share this post


Link to post
Share on other sites

teh_g,

 

I see you've created a zendesk ticket? 

 

Sorry, I got confused. Do you mean that on your Debian:  if you add the folder (via "shift+add folder) on Debian, it doesn't show the error. But if you add this folder via 1.4 key shared from another peer, you see this error? 

 

@all, 

are the peers where you see the error linked to other devices as "my devices'? And you are adding 1.4 RO key through "manual" connection menu and right after you add it, you get the error? 

Missed this reply, sorry! I do have a ZenDesk ticket already.

 

Here is how I have my setup:

Source - Ubuntu

Target - Debian

 

I had my Debian machine as a backup using a read only key from the Ubuntu machine. After upgrading, I removed the old 1.4 style share and attempted to make a 2.0 share between the two. In Ubuntu, I had no issues and it happily created and indexed. When I try to use the share link from Ubuntu on Debian, Debian states that I do not have permission to write to the destination folder.

 

As a test, I tried adding the exact same folder using the 2.0 system, this did not work. Adding a legacy folder (via Shift+Add Folder), allowed me to add that folder and have it indexed.

 

I would use the 1.4 folder system until this is resolved, but if I try to add the 1.4 key from Ubuntu to Debian through the manual connection, it throws the permission error as well.

 

I am not using the my devices option.I could give that a try.

 

Edit: Actually, I can't try that, since I can't add the folder I want as my target folder.

Share this post


Link to post
Share on other sites

Edit: Actually, I can't try that, since I can't add the folder I want as my target folder.

You can if you link your devices in "Disconnected" mode. Otherwise the folder will be created in default location.

 

Also, pay attention to the following:

1) if sync was going through several updates (1.4 -> 2.0.x-> 2.0x, etc) I would suggest deleting old installation (including its config folder) and installing Sync from scratch

2) delete older .sync folder (with ID, Archive, etc) from shared folder

3) make sure you rung 2.0.93 

Share this post


Link to post
Share on other sites

You can if you link your devices in "Disconnected" mode. Otherwise the folder will be created in default location.

 

Also, pay attention to the following:

1) if sync was going through several updates (1.4 -> 2.0.x-> 2.0x, etc) I would suggest deleting old installation (including its config folder) and installing Sync from scratch

2) delete older .sync folder (with ID, Archive, etc) from shared folder

3) make sure you rung 2.0.93 

 

I cleaned up the folders as a part of my own troubleshooting. I will upgrade once >2.0.93 is available from the Debian repo. I am on 2.0.85 now.

Share this post


Link to post
Share on other sites

@all,

 

just to be sure, for those who haven't done it yet, can you please check and tell me under what user the updated Sync runs now and if this user actually has RW permissions to sync folder? 

Share this post


Link to post
Share on other sites

@all,

 

just to be sure, for those who haven't done it yet, can you please check and tell me under what user the updated Sync runs now and if this user actually

has RW permissions to sync folder? 

I know my user has the proper permissions. Same user is running sync 2.0 as previously. I may downgrade for now, until we are sure of a fix. 

Share this post


Link to post
Share on other sites

Hi all,

 

btsync support was able to provide a resolution!

 

In the config file for btsync, remove the "directory_root" or "dir_whitelist" parameter from the config. This parameter specifies the location where Sync can create folders. You could also modify it to include the specific folder you want to sync.

 

If you are using the tuxpoldo repo, I have put it an issue to hopefully resolve this going forward: https://github.com/tuxpoldo/btsync-deb/issues/182

Share this post


Link to post
Share on other sites

Hi all,

 

btsync support was able to provide a resolution!

 

In the config file for btsync, remove the "directory_root" or "dir_whitelist" parameter from the config. This parameter specifies the location where Sync can create folders. You could also modify it to include the specific folder you want to sync.

 

If you are using the tuxpoldo repo, I have put it an issue to hopefully resolve this going forward: https://github.com/tuxpoldo/btsync-deb/issues/182

Greetings All,

 

The fix described above also corrected my Ubuntu servers running 12.04 & 14.04 that could not write outside of the /mnt directory after upgrading to sync 2.0.

 

Many thanks.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.