Sign in to follow this  
Sitron_NO

[Solved] Files Locked, Log Says "file Exists, But Failed To Get Mtime 13"

Recommended Posts

I have a folder I am sharing with some peers. I added several files (copied them into the folder), and all went well.

 

The syncing completed, but I get a message that 8 files were locked. Those files has not been opened or edited after I copied them into the folder. When I checked the logfiles, I saw these lines:

[20150316 18:22:14.264] FC[FBE6]: LoadTorrent: file /opt/[removed]/Årsmelding 2012.pdf exists, but failed to get mtime 13[20150316 18:22:14.275] FC[FBE6]: LoadTorrent: file /opt/[removed]/Årsoppgjør 2012.pdf exists, but failed to get mtime 13[20150316 18:22:14.286] FC[FBE6]: LoadTorrent: file /opt/[removed]/Årsoppgjør 2013.pdf exists, but failed to get mtime 13

Is this a bug, or is it something I can do to fix it?

 

I use btsync 1.4.1 on a Ubuntu 14.04 server (64 bit)

Share this post


Link to post
Share on other sites

I still have this problem, and when I add more files to my directories, some of them get locked, for some reason. After turning on debugging, this is stated in the sync.log:

[20150415 17:32:34.866] FC[68EE]: load torrent request, will try to load torrent for file "/opt/exports/nfs/home/sitron/Pictures/Sortert/2015.04.03 - Portretter i Hundehallen/Public/Primus/Stående_Web/Primus_Stående_Svart_Hvit.jpg"[20150415 17:32:34.866] JOURNAL[68EE]: LoadTorrent: file /opt/exports/nfs/home/sitron/Pictures/Sortert/2015.04.03 - Portretter i Hundehallen/Public/Primus/Stående_Web/Primus_Stående_Svart_Hvit.jpg exists, but failed to get mtime 13[20150415 17:32:34.867] Disconnect: No such torrent:[20150415 17:32:34.873] FC[68EE]: load torrent request, will try to load torrent for file "/opt/exports/nfs/home/sitron/Pictures/Sortert/2015.04.03 - Portretter i Hundehallen/Public/Primus/Stående_Web/Primus_Stående_Svart_Primusfarger.jpg"[20150415 17:32:34.873] JOURNAL[68EE]: LoadTorrent: file /opt/exports/nfs/home/sitron/Pictures/Sortert/2015.04.03 - Portretter i Hundehallen/Public/Primus/Stående_Web/Primus_Stående_Svart_Primusfarger.jpg exists, but failed to get mtime 13[20150415 17:32:34.874] Disconnect: No such torrent:

What can I do to fix this?

 

Share this post


Link to post
Share on other sites

Some more (useful?) info:

- I am running btsync 2.0 on Ubuntu 14.04 LTS server (64 bit).

- Rebooting the server or restarting btsync does not help.

- I have verified (with lsof) that the files are not opened by any other programs.

- I have deleted some of the "locked" files, and the file is removed from the filesystem. However, btsync still says the files exists (it does not), but it failed to get mtime 13

- All of the files (both locked and unlocked files) have been copied from an Dropbox-folder

 

I assume this is a bug, and this is a sufficient bug-report? I have no problem doing some tests or whatnot, just let me know!

Share this post


Link to post
Share on other sites

Is there an other way to post a bug, like a bug-tracking-system?

 

Yes - Open a support ticket and reference your thread here (please note, when opening a ticket priority is given in the first instance to users of Sync Pro).

 

However, before you do, you may like to consider "touching" the files in question to update their mtimes to see if this resolves your issue first.

Share this post


Link to post
Share on other sites

Resolved!

 

The reason for this error was a problem with permissions:

After btsync had indexed the directories and files, the permission on the parent folder was changed, excluding btsync with any permission.

 

Since btsync could not read the contents of the directory, it could not read the file, nor discover it was changed or even deleted.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this