mosteo

Btsync 2.0 Possible Memory Leak?

Recommended Posts

I want to see if any of you is seeing this, I'm surprised at not finding anyone else affected.

 

I've recently observed in two computers running ubuntu 14.04 LTS / 14.10 each that btsync-daemon consumes increasing memory amounts. As an example, this instance:
 

 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                                                                                                
25897 jano      39  19 7347848 6,448g   5916 S   0,0 55,5 453:18.24 btsync-daemon

 

 

Uptime is 14 days in that particular computer. Also, the number of files is

 

$ find ~/btsync | wc -l
197625

 

 

Which according to some estimates I've seen about each file taking 300-400 bytes of ram should give (being generous):

 

$ echo $((`find . | wc -l` * 512)) | numfmt --to=iec
97M

 

 

So anything as much by far.

 

btsync is the yeasoft package:
 

 

$ wajig policy btsync-core
btsync-core:
  Installed: 2.0.93-1
  Candidate: 2.0.93-1
  Version table:
 *** 2.0.93-1 0
        500 http://debian.yeasoft.net/btsync/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status

 

 

This particular computer SO:

 

$ uname -a
Linux miles 3.16.0-31-generic #43-Ubuntu SMP Tue Mar 10 17:37:36 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -a
LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch
Distributor ID:    Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:    utopic

 

 

btsync is launched manually, with this command line:

 

/usr/lib/btsync/btsync-daemon --nodaemon --log ~/.btsync/${host}.log --config ~/etc/btsync/${host}.conf

 

 

where the config file is:

 

//!/usr/lib/btsync/btsync-daemon --config
{
    "storage_path" : "/home/jano/.btsync/",
    "disk_low_priority" : true,
    "lan_encrypt_data" : true,
    "rate_limit_local_peers" : false,
    "folder_rescan_interval" : 600,
    "webui" :
    {
        "listen" : "127.0.0.1:8888",
        "login" : "jano",
        "password" : ""
        ,"allow_empty_password" : true
    }
}

 

 

Any ideas? Will debug mode provide more info about this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.