azim58

Limit Memory Ram Used By Bittorrent Sync In Linux

Recommended Posts

Is there some way that I can limit the amount of memory (RAM) used by bittorrent sync (btsync) in Linux (Ubuntu).  I am syncing about 500 GB of files from one machine to the Linux machine.  However, about 90% of the RAM is being used by btsync during this process (which will take many days).  I usually only remote to this Ubuntu computer instead of directly controlling it, and when 90% of the RAM is being used, the computer becomes very unresponsive.  Is there some way that I can limit the amount of RAM used by btsync?  I would be willing to slow down the sync process if I can limit the RAM.

Share this post


Link to post
Share on other sites

Hmmm. . . this didn't seem to work.  I tried setting both of those values to 1 and then restarted btsync, but the RAM still climbs up to 90%.  Note that in Linux I can't just go to advanced settings and click more options.  I had to create a btsync.conf file, as described here:

 

http://nickology.com/2013/05/06/bitorrent/

 

After getting the text for the conf file by typing "./btsync --dump-sample-config" I then added the lines to set the recv_buf_size and send_buf_size like this:

 

,"recv_buf_size" : 1
,"send_buf_size" : 1

 

However, the default is 10 Mb and the lowest I can set the value is 1 Mb.  I then started btsync while passing the config file as a paramter.  At 1 Mb the RAM still climbs to 90%.

Share this post


Link to post
Share on other sites

azim58,

 

An how many files are in the folders? Are the folders physically located on the machines? Can you please send logs to the support

 

 

 in Linux I can't just go to advanced settings and click more options.  I had to create a btsync.conf file,

 

For web ui use this script  to change the parameters right in settings. the syntax will be
 

python btsync_edit_settings_w4.py /path/to/.sync/settings.dat set <parameter_name> %value"

and check with get 

Share this post


Link to post
Share on other sites

Bittorrent sync is using up all of my ram (90%) on a linux machine when trying to sync 500 gb from a Windows computer to an external drive on a Linux computer.

There are 1,690,755 files and 140,126 folders which total 411 GB.

 

I tried to send the log files to bittorrent sync, but the log files were too big.  They were about 100 MB, but the website would only accept log files that were about 20 MB.

Share this post


Link to post
Share on other sites

azim58,

 

got them, but do you have logging enabled? that looks like non debug logs. And one more thing - memory dump: 

while sync is running and rating memory in terminal run 
 

gcore -o /path/to/core.filename <pid_of_sync>

upload that core file as well. thank you.

Share this post


Link to post
Share on other sites

I'm not sure these power user options are working as intended or they are not documented correctly. Both recv and send are 128 by default, which in theory should be 256mb plus some amount of application overhead, yet i'm seeing well over 700mb being used just for resilio sync while not preforming any sync operations.

Share this post


Link to post
Share on other sites

AFAIR, btsync uses a few kB of RAM for every single file it has to manage, additionally to the recive and send buffers and other data. That adds up for millions of files... same problem here on my NAS.

Share this post


Link to post
Share on other sites

I had Sync on a VPS with 512MB of RAM and syncing about a half a dozen files of about 2GB average in size. Sync crashed often.  When the VPS was increased to 1GB of RAM, the crashes stopped. When I was investigating crashes, rlsync was using more than 350MB of RAM. I was not expecting this, considering a good chunk of NAS' only have 512MB of RAM.

Developers need to design specifically for embedded devices, they don't have the resources PC's have.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.