RomanZ

Latest Desktop Build 2.2.0 - Major Changes Inside!

Recommended Posts

Dear community,

 

Sync 2.2.0 is now available! Jump into our blog post for quick review of major changes introduced.

 

You can get it via official download site or using direct links below. Build is not yet pushed to auto-update.

Direct Download Links:

A regular list of what's new, improved, changed, and fixed in this version is available in the change log.

 

Also, here is latest Android 2.2.0 APK

Share this post


Link to post
Share on other sites

Wow, it looks like there are some great changes in v2.2.0. And it's especially pleasing to see that there's now a perpetual license option.

 

One thing I've noticed immediately in v2.2.0, though, is that one of my 4 computers is listed twice in the My Devices view. In the past one of my computers got duplicated in that view after upgrading from the 32-bit to 64-bit version. Then a recent update introduced the ability to 'Hide' devices in the My Devices list so I was able to remove that one.

 

But the most recent duplicate I'm seeing now wasn't caused by reinstalling on an existing device, as far as I'm aware. And it appears that with v2.2.0, the ability to hide/clear devices from the My Devices list has now been removed. How can I delete the duplicate in v2.2.0 ?

Share this post


Link to post
Share on other sites

@Moe, the extra/duplicate one is offline/non-existent of course. In versions prior to v2.2.0 if you hovered over devices other than the current one you're on, an 'X' would appear, allowing you to delete that other device. But now in v2.2.0, any device other than the current one is greyed out, and when you hover over them no 'X' (or anything else) appears.

Share this post


Link to post
Share on other sites

@eldrin

It reproduced in my lab with Free version of Sync - indeed, in this case there is no cross button and all devices look to be grayed out. Is it your case or you are using Trial / Pro?

Share this post


Link to post
Share on other sites

@RomanZ

 

Here is a screenshot. Notice that all of the devices that are not the one I'm on, are greyed out. Hovering over any of them doesn't do anything. In the screenshot, I'm hovering over the duplicate 'ASPIRE' device.

 

https://imgur.com/pG37Yli

 

EDIT: I see that you updated your previous reply while I was posting. Yes, I'm using Free at the moment.

Edited by eldrin

Share this post


Link to post
Share on other sites

@RomanZ

 

Nothing really (apart from being able to see what devices are online), but was just making sure the list of devices known to Sync was accurate. Seeing a duplicate simply bugs me a bit.

 

I do still wonder how this latest duplicate occurred.


EDIT:

 

Now that I think of it, that machine ('ASPIRE') I recently upgraded to Windows 10. But because of some hardware and driver incompatibilities that would cause Windows 10 to freeze, I restored a complete system backup I'd taken just beforehand, to take it back to Windows 8.1. Throughout that process I never reinstalled or did anything with BitTorrent Sync.

 

Should upgrading to Windows 10 have created an extra device of the same name?

 

By the way, I thought of something useful I do use the My Devices list for -- to check the version installed on each device. Also, one could see some other information like IP address and disk space. Having each device greyed out and non-selectable is inconvenient.

Edited by eldrin

Share this post


Link to post
Share on other sites

@eldrin

Well, it might happen that at some point your Aspire machine has changed the PeerID - which caused duplicate computer. Its hard to say now without having full debug logs. Didn't you change any hardware? When Sync detects hardware change, it re-generates PeerID as it suspects to be copied to another computer and wants to avoid PeerID duplication.

 

Thanks for clarifying your use case about "My devices". Actually, "My Devices" considered to be a Pro feature in all 2.x releases. As its main purpose is to transfer service data (like, list of folders and their keys) between your devices automatically is not working in Free version, we decided to disable it to avoid users being confused.

Share this post


Link to post
Share on other sites

Didn't you change any hardware? When Sync detects hardware change, it re-generates PeerID as it suspects to be copied to another computer and wants to avoid PeerID duplication.

 

No, I didn't change any hardware. It appears that upgrading to Windows 10 was enough to cause Sync to create a new ID for that computer. So I predict that other Sync users who upgrade their OS will have the same thing happen to them. But as for whether this will cause them any concern, and whether they'll even get in touch with BitTorrent about this, that's another matter. Most users will not even notice, I guess.

Share this post


Link to post
Share on other sites

Thank you very, very much for listening to the concerns of the user base on the Pro licensing model.  It's a rare thing these days and deserves a lot of respect.

 

As a minor gripe, are we able to get the NAS/Other Devices clients kept more closely in check with the desktop and mobile releases?   Are these builds you guys do or are they handled by other groups?

Share this post


Link to post
Share on other sites

As the unofficial Debian/Ubuntu PPA seems to be abandoned I have using the latest 2.x (server) btsync package and upgrade by simply replacing the /usr/lib/btsync-core/btsync-core binary with newer version. This has been working fine before version 2.2. With version 2.2 it just does not start up anymore... no log entry at all. Before I start debugging, did anyone encounter the same issue? If so, did you find a solution?

 

Would Bittorrent consider creating an official deb package?

Share this post


Link to post
Share on other sites

As the unofficial Debian/Ubuntu PPA seems to be abandoned I have using the latest 2.x (server) btsync package and upgrade by simply replacing the /usr/lib/btsync-core/btsync-core binary with newer version. This has been working fine before version 2.2. With version 2.2 it just does not start up anymore... no log entry at all. Before I start debugging, did anyone encounter the same issue? If so, did you find a solution?

 

Would Bittorrent consider creating an official deb package?

 

It seems that some configuration file keys have changed, e.g.:

 

folder_defaults.use_dht

 

Run btsync directly to see the errors. Simply removing that configuration key worked for me.

 

Since the PPA seems to be abandoned indeed, maybe I should post my nice systemd multi-user BTSync configuration :).

Share this post


Link to post
Share on other sites

BTS 2.2 free edition.

About 1TB data in 5 folders.

2+1 nodes in the replica set.

1.30-1.49GiB RAM used.

GUI almost unusable on a 4core 2GHz CPU with 8GiB memory.

GUI unusable on a 2core 1.5GHz CPU with 8GiB memory.

Windows 10.

Is it normal?

Share this post


Link to post
Share on other sites

I have one question:  After installing the 2.2.0, the "enable debug logging" option is on by default.  Is this intended?

Yes! We've cleaned up redundant messages in debug logs significantly to avoid HDD space consumption and enabled them by default. Having that, we greatly increase chances of capturing issues if they happen.

 

Hmm looks like perpetual licenses can't be purchased online yet.

Thanks for reporting - we are fixing it...

 

As a minor gripe, are we able to get the NAS/Other Devices clients kept more closely in check with the desktop and mobile releases?   Are these builds you guys do or are they handled by other groups?

We are working to get NAS builds closer, although there always will be some delay to get them delivered to official stores as it depends more on NAS vendors.

 

Would Bittorrent consider creating an official deb package?

We'll consider that for sure. For now I suggest mentioning official package in Feature Requests forum.

 

BTS 2.2 free edition.

About 1TB data in 5 folders.

2+1 nodes in the replica set.

1.30-1.49GiB RAM used.

GUI almost unusable on a 4core 2GHz CPU with 8GiB memory.

GUI unusable on a 2core 1.5GHz CPU with 8GiB memory.

Windows 10.

Is it normal?

How many files do you have? Could you please run "perfmon /res" and see which system resources are bottlenecked? CPU? Mem? HDD I/O?

 

Share this post


Link to post
Share on other sites

Since the PPA seems to be abandoned indeed, maybe I should post my nice systemd multi-user BTSync configuration :).

 

Also had issues, but somehow I can start only directly now, not anymore via "sudo service btsync" :-( Would you mind posting your configuration?

Share this post


Link to post
Share on other sites

After purchasing a Sync Pro Individual License yesterday, I followed the instructions and imported the license key onto just one of my computers. In theory, the license is supposed to automatically propagate to my other linked computers. But this hasn't happened.

 

Today I've turned on one of my other linked computers (already upgraded yesterday to v2.2.0), which can be seen as online and connected (and definitely linked) by my primary computer running Sync, but the license has not been automatically applied to that other one. It still thinks its running the Free version.

Share this post


Link to post
Share on other sites

@eldrin

Should propagate automatically. We'll retest in lab. Just to make sure I understand your setup correctly:

1) 2 peers 2.1.x, linked with My Devices.

2) You upgrade both, install PRO license to one and it does not propagate?

 

@hungarianhc

Try it now, its fixed.

Share this post


Link to post
Share on other sites

@RomanZ

 

4 computers in total. As of yesterday morning, all 4 were running v2.0.128 FREE. They had all been linked together under a common identity during the Trial period when I originally installed v2.0.

 

Yesterday I upgraded all 4 of them to v2.2.0 FREE. Then, after that, I purchased a PRO license. So far I've imported the PRO license onto 1 computer. The other 3 are all still showing FREE, even after restarting.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.