farago

Synology - 2.1.3 Fails With "sslv3 Alert Bad Record Mac"

Recommended Posts

2 Synology servers


  • DS214+  Armadaxp
  • DS1813+  Cederview

Did manual upgrade to on both to 2.1.3  - sync log shows fail with "sslv3 alert bad record mac"


Have returned to 2.0.1 clean install - all is working as before - nice and speedy


Working for now - will stick with 2.0.1 until this is sorted out by folks with more knowledge than me


Suspect this has something to do with OpenSSL


Let me know if you have any ideas


Share this post


Link to post
Share on other sites

Here is reply from Sync Team:

 

  • Please use 1.4 classic folders if you use Sync 2.1.3-2.1.4 to transfer your data. The thing is that these builds contain certain ssl bug which was fixed in Sync 2.2 so you can install Sync 2.2 on all your devices or stick 2.0.1 version (if you have NAS with ARM processor - you can use ARM version of the Sync 2.2 Linux build of the app: https://www.getsync.com/platforms/desktop). I'm sorry for inconvenience!

    Kind regards, 
    Sync Support Team

 

Looks like best (safest) option for me is to stick with 2.0.1 till 2.2 is available for both servers.

  • DS214+  Armadaxp
  • DS1813+  Cederview

If someone has a better solution please let me know. Thanks

Edited by farago

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.