antimojv

Problem Installing Btsync 2.2.2 On Raspberry

Recommended Posts

I have some problem to use this deb:

 

http://forum.bittorrent.com/topic/41242-latest-desktop-build-222/

 

 

Previously i was using the version from this thread:

http://forum.bittorr...age-39?hl=linux

 

Upon a 

 sudo dpkg -i ./bittorrent-sync-pi-server_2.2.2_armhf.deb

there was an error

d
pkg: error processing ./bittorrent-sync-pi-server_2.2.2_armhf.deb (--install): trying to overwrite '/etc/init.d/btsync', which is also in package btsync 2.0.0-2

bysynch won't start.

 

I have tried

sudo apt-get remove btsync

btsync won't start

 

I have tried (bad idea i lost all folder configuration....)

sudo aptitude purge btsyncsudo dpkg -i ./bittorrent-sync-pi-server_2.2.2_armhf.deb
 
But now i have:
sudo service btsync startCouldn't start BTSync (no /etc/btsync/config.json found)
Then again
sudo dpkg-reconfigure bittorrent-sync-pi-serverCouldn't start BTSync (no /etc/btsync/config.json found)
 
I create the file /etc/btsync/config.json using the output of
btsync  --dump-sample-config
Then  
sudo service btsync startStarting BTSync for pi
 
give no error but btsync won't start at all :(
 
 
Any help?
Is there a manual to install this .deb correclty? (may be i'm doing some mistake)
 

Share this post


Link to post
Share on other sites

Yes, that's what I did, too.

Just use the download and unzip it to get the executable.

If you want to execute sync at startup, you could create a cronjob.

Tip: There is a nice tool for scheduling tasks and cronjobs. It's called gnome-schedule.

You can get it from the standard sources, just use apt-get install and it runs fine on the pi.

Extract the download to /home/pi/programs/sync/

And add a job with the command: ./programs/sync/btsync

which is run at reboot.

Share this post


Link to post
Share on other sites

Guys let's not forget that there is a .deb package for the pi http://forum.bittorrent.com/topic/41316-latest-desktop-build-223/

There is also a blog post on it http://blog.bittorrent.com/2015/09/04/sync-wd-raspberry-pi-2/

 

If you want the latest binary: Do what mintwurm said. Install the .deb package and then download the ARM binary and replace the btsync binary in your installation folder with the new one.

 

http://help.getsync.com/customer/portal/articles/2137820

 

It's also always good to take a look at help.getsync.com to see how to setup the configuration file of BitTorrent Sync

Share this post


Link to post
Share on other sites

@Moe, interesting. I didn't know that there was a special build for the pi.

 

What is the difference between the "normal" sync build for ARM and this build for the pi ?

If you install the ARM version on a pi, are you going to run into trouble at some point ?

Share this post


Link to post
Share on other sites

Nothing special. It is the way it's packaged.

The .deb file has also the /etc/init.d/btsync script in it etc - You can take a look yourself if you want to.

It is the ARM binary packaged so it's "easier" for users to install.

 

I myself just took out the init script and have my own install/update/backup script on my Pi

 

But the .deb has the ARM package inside of it.

Share this post


Link to post
Share on other sites

@antimojv, @marklochrie

You used packages from here: http://forum.bittorrent.com/topic/18974-debian-and-ubuntu-server-unofficial-packages-for-bittorrent-sync/page-39?hl=linux

This is unofficial package.

 

And it is highly not recommended to mix 2 different of packages. I would advise to remove both now and install whichever you would like to follow.

Share this post


Link to post
Share on other sites

Hello all,

 

I am also trying to update btsync. First of all I stopped the service through "sudo service btsync stop". I downloaded the newest version and tried to change the name of the older file to replace it with the newer one, but I can't change the name of the older file, I get a permission error. The permission should be 755.

Any Idea what can I try?

 

Thank you

Share this post


Link to post
Share on other sites

@haitzo

Who is the file owner? Try doing it from root name. Also note, that "btsync" package is unofficial one and simple binary replacement won't fully work here. I advise to read this post for more details. In general the topic where it stays is dedicated to the package you used.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.