Sync Sending Files Through

Recommended Posts

I setup sync between two nodes and despite turning off relay and tracker (on both nodes) and restarting the sync service,  all data is sent to according to TCPView.  


Very concerning.  


Can someone please let me know what is going on?

Edited by mcoliver
Link to post
Share on other sites

Here is a help article that lists all information regarding what is being accessed by Sync:


That hostname looks like it is part of this paragraph:

Connecting to relay server to transfer data if direct connection is not possible:

TCP and UDP port 3000 to (via direct IP,,,


Can you also check in the preferences of the shares that all checkboxes are unchecked?

To do that, go into your Sync GUI and right click on your share and open up the preferences and there you will see if it is using Relay or Tracker server.

Link to post
Share on other sites

Thanks Moe.  The problem is that Sync is not respecting the fact that I disabled "use relay" and "use tracker".  


If those settings are set on any node (send or receive), but especially if it is set on both of the only two nodes in the sync, the data should not flow through the relay.  


Settings below.  Running BTSync x64 on Windows 10 x64



Link to post
Share on other sites



The settings you show on the screenshot are defaults. They are copied every time you add folder and has no any immediate effect when you change them.


If you open your folder preferences, you'll also see "use tracker" and "use relay". Could you please try to disable them also for all your folders and see if it helps?

Link to post
Share on other sites

Alright!  Thanks.  That did the trick.


I would like to suggest that you make that Default Settings window more descriptive of the fact that it is in fact setting defaults for future folder additions.


I interpreted those settings as override settings that would affect all shared folders and override individual folder preferences.


Thanks for the feedback and response.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.