[Solved] Download-Url For Qnap-Package With Invalid Server-Certificate

Recommended Posts

tried to download the "brandnew" 2.2.1-qnap-package


=> wrong server certificate [firefox]

=> did you're server got hacked???


"wget" shows:the same:

--2015-10-12 00:22:40--
Connecting to||:443... connected.
ERROR: cannot verify's certificate, issued by â/C=US/ST=Arizona/L=Scottsdale/, Inc./OU= Daddy Secure Certificate Authority - G2â:
  Self-signed certificate encountered.
ERROR: no certificate subject alternative name matches
        requested host name âdownload-cdn.getsyncapp.comâ.

To connect to insecurely, use `--no-check-certificate'.

...loading the current "stable"-file works fine:

wget -O btsync.tar

--2015-10-12 00:24:24--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4784187 (4.6M) [application/octet-stream]
Saving to: âbtsync.tarâ

btsync.tar                     100%[=====================================================>]   4.56M  1.37MB/s   in 3.3s

2015-10-12 00:24:28 (1.37 MB/s) - âbtsync.tarâ saved [4784187/4784187]


Share this post

Link to post
Share on other sites



It's just an issue with domain certificate. Fix your link to "" instead (or try re-downloading as I already fixed link at Help Center).


Thanks for bringing it to our attention.

Share this post

Link to post
Share on other sites



two solutions to the problem:

1) update root certificates on the NAS 

2) download from http, not https, via wget. Or download through browser via https, and put to NAS. 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.