Android Timestamp


Recommended Posts

First of all, seems like BT Sync is the best kept secret in tech today:)

I stumbled upon BT Sync googling for a specific solution, but I think I can use Sync every day anyhow.


1. My original problem. On a new Android device, I copied all my media files from an older device via several cloud providers (Google Drive, Onedrive, dropbox), using several (paid for) Android apps to keep them in sync. Problem: The timestamps are reset as new files! This kills many features of many apps that need to know the age of the stuff.


So, the question:  If I get BT sync on the new device, and old device, and Windows-10 desktop (which has synced folders to Gdrive, 1Drive, Dropbox) will BT Sync (after deleting the erroneous stuff from the new device) copy/sync everything to the new Android device, retaining the original timestamps?

If so, does my desktop need to be involved? Can the two android's accomplish this? (Not that I don't want my desktop 'involved', but want to know how this works.) On the flip side, do I need the old Android to accomplish this with bt sync?


2. Going forward: Can I replace all my Android syncing apps, (FolderSync, DropSync, etc.) with BT Sync? Can I sync win-10 Desktop folders with my Android devices remotely without any cloud??


3. Groups. Can I have a group (about 30 people) all sync some folders on our desktops (Windows & Linux) and devices Android and ios? (That's at least 60 machines.) How does pricing work in this scenario.


Woops. I went off topic. Am too excited.



Link to comment
Share on other sites

Hi nat,

Anwering your questions:

1) "My original problem"

1.1 Yes and no. BTSync preserver files (but not folders) mtime on all OSes except Android. On Android itself mtime may be reset to current time by OS itself. Sync keeps true mtime in its database to prevent resetting it on all connected peers.

1.2 Currently, you need desktop to be involved to start with 2 android devices. But later you can remove desktop from equation and androids will work fine.Though, it is still highly advised to have some "always online" non-mobile peer: on android, Sync usually sleeps and wakes up once per selected period (30 mins by defailt) to check for other peers and changes it needs to Sync. If 2 devices are waking up all the time in different timespans - they'll never sync.

2. Yes, you can Sync remotely without cloud. Though note, that in P2P technology you'll need at least one peer to be online to actually get data from.

3. Yes, you can. If you are using Sync for personal needs and don't need Selective Sync on desktops - you can use Sync Free (Selective Sync or business use requires a PRO license).

Link to comment
Share on other sites



BTSync preserver files (but not folders) mtime on all OSes except Android. On Android itself mtime may be reset to current time by OS itself. Sync keeps true mtime in its database to prevent resetting it on all connected peers.

I have since researched this Android problem. Interestingly enough, on External SD cards Android does NOT have this flaw. (ES File Explorer, cannot retain timestamps on internal Android storage, but does so for secondary external sd storage.)


The other points sounds promising

Thank you much.


Link to comment
Share on other sites

  • 3 months later...

Sorry to revive an old thread.  Just wondering whether anyone has any update on this.

I absolutely love the concept of using BTsync for wirelessly transferring photos from my Android phone to my PC, but BTsync still seems to alter the timestamp data on my files when it does so. "Date Created" is changed to the date of the file transfer, whilst "Date Modified" is kept the same as the original.

Is there any way to configure BTsync to keep the original date created timestamp?

The only other solution I've found is an app called photosync (, but it's somewhat buggy and doesn't seem to be very regularly maintained by the developer. But at least on photosync there's an option to keep the original date created and date modified timestamps.

Link to comment
Share on other sites


On PC, when syncing into empty directory, Sync uses standard system calls, that alter creation timestamp as file is being created on the system from scratch. I suppose that if you copy a file from one location to another on your PC, the copied file will also change its creation time. 

Link to comment
Share on other sites

  • 2 years later...

Hello everyone,

I am having a strange issue. I have been using Sync successfully with my nexus 6p and xiomi mi max 2 for the last 2-3 years. Nexus 6p had 128 GB internal memory (no SD card) and mi max 3 had a 64 gb scandisk microsd card.

I was having no issues with timestamps. I know for sure because I have a personal productivity system in which I use timestamps to create a first in first out list. In fact, I was using a tool called bulk file changer to manually edit modification timestamps so I could reorder the files as I want. 

All was working well.

6 month ago my nexus 6p died, and 2 months ago the sandisk microsd card died. So I moved to mi max 2 with a new Samsung EVO microsd card.

Since then, timestamps are no longer getting synced. I can see the bulk file changer updated modification timestamps in the Sync App (for all files), but not on the filesystem.

I have tried Fat32 and exfat file systems for microsd but could not get back the the old desired behavior.

This is quite strange as the functionality was working for me before for nexus 6p and mi max 2 sandisk card. I suspect it's a permission issue.

Note: its the same mi max 2 phone - only sd card changed.

As you can see in the screenshots, for file 274, in the sync app its showing the correct date i sent in bulk file changer (the actual modification date). But in the file manager its showing the date when it was synced to the sd card.

If anyone can share any insights on getting it to work again I would be grateful.

Thanks in advance.


Link to comment
Share on other sites

Hey Thanks for looking into it.

Let me Clarify

Modification timestamp Sync:

Nexus 6P Internal : Was Working

Mi Max 2 + Scandisk microsd Card (FAT32) : Was Working

Mi Max 2 + Samsung EVO microsd card (Tried on fat32 + exfat) : Not working

The Mi Max 2 device is the same. So yes, the screenshots are from the same device taken 30 seconds from each other this morning. Device was not formatted or resetted. Just the microsd SD card was changed.

29th May, 6:30 AM is the desired modification time (I had set this manually to prevent the pages order messing up) 

10/07/18 is the undesired timestamp.

Thanks a lot.

Edited by Manuj
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.