Right Clicking Files Hangs File Explorer On Network Shairs [Bug]


Recommended Posts

I found a bug in BTSync that is causing Window File explorer to hang for 30+ seconds when right clicking on files on a network share.   
It appears to be the "Share with BitTorrent Sync" contect menu

 

 

 

When I disable the BTSync's context menu using ShellExView http://www.nirsoft.net/utils/shexview.html

My right click works just fine and does not hang file explorer.

 

 

I have been having this issue for almost a year now on multiple computers running windows 7. Today I tracked it down to BTSync by trial and error.

I just updated to the latest and greatest BTsync 2.2.7(160) with the same result.

 

File Explorer only hangs when browsing to a network location \\server\shaired folder. Local drives, memory sticks and mapped network drives, are not affected.

Link to post
Share on other sites

As far as I can tell this is any file server doesn't matter the load, or fold or file size.File explorer hangs just as long on a 2TB video folder as a 1KB text file.

I have duplicated this issue on multiple clients windows 7 clients on separate networks and multiple servers.  I am 90% sure this affects windows 10, but I have not tried it for along time.

 

Servers I have tried.

 

Freenas 9 Server CIFS

Ubuntu 14.04 SMB server

Windows Server 2013 Share

Windows Server 2008 Share

 

These servers hardware ranges from a cheap single 1TB drive to 4 Enterprise 1500RPM drives in RAID 10.

Link to post
Share on other sites

Catsrules,

 

Thank you for the report and details. We managed to reproduce it on Windows 7. BTW, do you have Kaspersky on your machines? 

Excelent, glad I am not crazy :)

I look forward to a fix in the future.

 

I do not have Kasperdky on any of my machines. I have a mixture of AVG Free and Eset.

Link to post
Share on other sites

@Catsrules

While we are working to get this issue resolved - could you please try to disable AVG and ESET on-access file scan and see if it improves the situation? In our lab, it reduced delay twice (though it is still noticeable comparing to right-click without Sync's extension).

Link to post
Share on other sites

@Catsrules

While we are working to get this issue resolved - could you please try to disable AVG and ESET on-access file scan and see if it improves the situation? In our lab, it reduced delay twice (though it is still noticeable comparing to right-click without Sync's extension).

 

I didn't notice a difference with AVG enebled or disabled. I will try ESET when I go back to work next week.

 

However I did start counting the seconds of the delays. This didn't folow this pattern everytime but generly the first right click was the longest between 14-30 seconds, the following clicks were 5-6 seconds. Ocationaly there was a period of no waiitng at all.

After waiting before right clicking again the pattern would start over again.    

Link to post
Share on other sites

Try running process monitor by sysinternals with and without the btsync context menu. Might reveal more hints... If the delay in seconds is reliably produced, might be a network timeout. Mapped drives are authenticated with saved passwords... But network locations don't always have that luxury. Just a guess...

Sent from my iPhone using Tapatalk

Link to post
Share on other sites
  • 1 year later...
  • 1 year later...
On 1/18/2017 at 4:50 AM, Helen said:

ok, open RegEdit, find key HKEY_CURRENT_USER\SOFTWARE\Resilio\Sync, put its value  `ShellMenuSharingEnable`to zero. Relaunc explorer.exe. 
See if it helps. 
if not, send all ShellExt....log files from Sync storage to Support 

This isn't working for me, even after a restart.

I tried disabling it using ShellExView, and it STILL shows up.

Edited by Megalith
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.