dzonsie

No permissions on synology DS212j

Recommended Posts

Hi.

I installed the newest packages of BTSync available for my Synology DS212j.

On volume 1 I have a network share called "books".

User1 on NAS has read/write permissions to that share and the share is accessible from pc

BTSync asked me to set user administrator. From the information provided I assume that the username doesn't have to be the same as on NAS (since it's only to manage settings of BTSync). So I set User2

When I try to add this share to BTSync, BTSync pops up a message of no permissions to this share. Could anyone help me with that?

Share this post


Link to post
Share on other sites

The application BitTorrent Sync has to be able to access the data stored on your hard drive on the NAS. So if the user you are running BitTorrent Sync under is not allowed to access that data, it just wont.

Share this post


Link to post
Share on other sites

But how to allow access? Even if I set on ds user2 permisions to allow read,/write nothing happens. It's all the same. Where can I find user name of BTsync?

Edited by dzonsie

Share this post


Link to post
Share on other sites

OK. I managed to overcome most of the odds.

If you disabled "admin" account and created another with administrative privileges it won't work (at least in my case). Unfortunately you have to enable read/write permissions for "guest". The odd is that you can't do anything to prevent that share from unwanted access form your LAN.

In my opinion BTSync on NAS should have option to change default username of the client.

Share this post


Link to post
Share on other sites

I just updated from 1.4.111 to 2.3.1 and I get the same error. It sounds weird that I should have to enable read/write to my guest account, that's really not secure by any means!

 

I have a Synology DS213j and running DSM 5.2-5644 Update 3

I've uninstalled and re-installed a couple of times, that didn't help.

Any ideas?

 

 

No_permissions.JPG

Edited by e2zippo

Share this post


Link to post
Share on other sites

@e2zippo, 

As dzonsie correctly noticed, Sync on NAS runs under "admin" user, so that user shall have write access to the folder. If it doesn't or if you don't have 'admin' user on your NAS, Sync won't have permissions to write to selected folder. 

There shall be admin user. Any other, even with administrative privileges won't work. This is coded into package's scripts. perhaps will be reconsidered. 

Share this post


Link to post
Share on other sites
34 minutes ago, Helen said:

@e2zippo, 

As dzonsie correctly noticed, Sync on NAS runs under "admin" user, so that user shall have write access to the folder. If it doesn't or if you don't have 'admin' user on your NAS, Sync won't have permissions to write to selected folder. 

There shall be admin user. Any other, even with administrative privileges won't work. This is coded into package's scripts. perhaps will be reconsidered. 

 

 

 

Has this been changed since 1.4.111? Because I haven't made any changes with my users.

I just enabled Read & Write on my admin user, still getting the error.

Tried stopping the service and starting again, didn't work. Do I need to reinstall?

Edited by e2zippo

Share this post


Link to post
Share on other sites
2 hours ago, Helen said:

@e2zippo, 

As dzonsie correctly noticed, Sync on NAS runs under "admin" user, so that user shall have write access to the folder. If it doesn't or if you don't have 'admin' user on your NAS, Sync won't have permissions to write to selected folder. 

There shall be admin user. Any other, even with administrative privileges won't work. This is coded into package's scripts. perhaps will be reconsidered. 

 

Has this been changed since 1.4.111? Because I haven't made any changes with my users.

So I have to 

Uninstalled and reinstalled, checked the permissions on the admin user but I still get the error?! 

Share this post


Link to post
Share on other sites

Helen, wouldn't it be easier to have some input field to specify credentials for particular folder? Writing in code default username it's in my opinion bad solution. Consider safety of NAS unit. Every single one of NAS from Synology is shipped with an "admin" account. Even Synology sees that as a vulnerability and suggests turning it off...

Share this post


Link to post
Share on other sites

as was mentioned, this might be reconsidered. 
And no, it wasn't so till Sync 2.0. Earlier syncs (1.4.x and older) were made by SynoComminuty, not us, and they run under btsync user. 

Share this post


Link to post
Share on other sites
On 2/5/2016 at 11:41 AM, Helen said:

as was mentioned, this might be reconsidered. 
And no, it wasn't so till Sync 2.0. Earlier syncs (1.4.x and older) were made by SynoComminuty, not us, and they run under btsync user. 

OK. But I still l can't get it working, I've made sure both the admin and guest account has rw access to my folders, still getting the same error Uninstalled and installed several times. Any ideas?

Share this post


Link to post
Share on other sites

e2zippo,

That will need ssh connection to NAS. See under who Sync runs (ps aux | grep sync) and see if that user has access to the folder, go to the folder (cd /folder/path) and list the permissions (ls -alh). Are you OK with ssh connection to NAS? 

Share this post


Link to post
Share on other sites
8 hours ago, Helen said:

e2zippo,

That will need ssh connection to NAS. See under who Sync runs (ps aux | grep sync) and see if that user has access to the folder, go to the folder (cd /folder/path) and list the permissions (ls -alh). Are you OK with ssh connection to NAS? 

Totally fine with SSH.

Getting these results.

 

 

grep sync.JPG

 

This is from the folder bittorentsync

ls-alh.JPG

Edited by e2zippo

Share this post


Link to post
Share on other sites

e2zippo,

You did listing on the sync's storage? please do that on the folder you are trying to add to Sync and on which you get permissions error! 

20 hours ago, Helen said:

e2zippo,

 go to the folder (cd /folder/path) and list the permissions (ls -alh). 

 

Share this post


Link to post
Share on other sites
16 minutes ago, Helen said:

e2zippo,

You did listing on the sync's storage? please do that on the folder you are trying to add to Sync and on which you get permissions error! 

 

Sorry, my bad.

This is what it looks like on the folders I'm trying to add.

ls-alh_canonhv20.JPG

ls-alh_minabilder.JPG

Share this post


Link to post
Share on other sites

So, apparently the folder owner is some 20 102 (what is this user?),  not admin, and admin, even if it belongs to 'users' group, which i doubt, doesn't have write access to the folder. Thus you get "no permission" error message. 

Share this post


Link to post
Share on other sites
1 hour ago, Helen said:

So, apparently the folder owner is some 20 102 (what is this user?),  not admin, and admin, even if it belongs to 'users' group, which i doubt, doesn't have write access to the folder. Thus you get "no permission" error message. 

Yeah, I get that. Any ideas how I can change this? In DSM I've assigned admin RW to these folders, but apparently it doesn't work? 

Share this post


Link to post
Share on other sites

e2zippo,

The easiest is ssh as root (might be necessary) and `chown -R admin /path/to/the/folder`. However, if this is some domain or network folder, I'd rather turn to your system admin for that. There might be some special permissions set there I'm not aware of. 

Share this post


Link to post
Share on other sites
On 2/10/2016 at 9:43 AM, Helen said:

e2zippo,

The easiest is ssh as root (might be necessary) and `chown -R admin /path/to/the/folder`. However, if this is some domain or network folder, I'd rather turn to your system admin for that. There might be some special permissions set there I'm not aware of. 

Hey!

I made a test folder with these permissions 

e2zippo.JPG.6ac2adf1399b814c6a223a17bdf8

e2zippo is a member of the admin group.

This folder works as intended!

However, when I added my other folder with all my pictures (same permissions) I get a lot of these errors (on Synology end)

Errors_nars.JPG.5f3e579f3f65ee2d5318b0de

Exactly how should the permissions look like?

I mean, the test folder works fine when e2zippo is set as the owner.

 

 

Share this post


Link to post
Share on other sites

CheckOriginalFile is not related to permissions. That line in history means that on the source peer the file info cannot be obtained. This may happen if the file is still being used (I see they are copied from a camera attached?) or if they have some incorrect parameter, for example, timestamp (please check these).  It's hard to give more specific details. 

Usually this problem goes away after folder rescan or once the file is released for syncing. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.